Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategoryTask TypePriority  descSeveritySummaryStatusProgress
 237 PackagesBug ReportVery LowLow i686: pango need to be rebuilt against harfbuzz Closed
100%
Task Description

Hi,

pango-list (and many packages depending on pango) fails to run with the following error:

$ pango-list 
pango-list: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant

hb_font_set_synthetic_slant seems to be related to harfbuzz.

While I used Parabola i686 for the test, both pango and harfbuzz come from Arch Linux 32 i686, so Arch Linux 32 i686 should also be affected:

$ pacman -Q -o pango-list 
/usr/bin/pango-list is owned by pango 1:1.50.4-1.0
$ pacman -sS "^pango$"
extra/pango 1:1.50.4-1.0 [installed]
    A library for layout and rendering of text
$ pacman -sS "^harfbuzz$"
extra/harfbuzz 3.1.2-1.0 [installed]
    OpenType text shaping engine

Denis.

 238 PackagesBug ReportVery LowLow Linux-zen kernel 5.16.8.arch1-1.0 made with gcc 11.1 an ...Closed
100%
Task Description

Linux and Linux-zen kernel 5.16.8.arch1-1.0 made with gcc 11.1 and cannot build dkms modules with gcc 11.2

remake linux and linux-zen kernel with gcc version 11.2

 241 PackagesBug ReportVery LowLow mpd probably needs to be rebuilt against pipewire Closed
100%
Task Description

Hi,

If I run mpd, it fails to run due to a missing PW_LOG_TOPIC_DEFAULT symbol:
> $ mpd
> mpd: symbol lookup error: mpd: undefined symbol: PW_LOG_TOPIC_DEFAULT

While I run Parabola, both mpd and pipewire comes from the i686 repository of Arch Linux 32:
> extra/mpd 0.23.5-1.2 [installed]
> Flexible, powerful, server-side application for playing music
> extra/pipewire 1:0.3.36-1.0 [installed]
> Low-latency audio/video router and processor

If I look on a x86_64 Parabola installation instead, PW_LOG_TOPIC_DEFAULT can be found in libpipewire:
> $ readelf -s /usr/lib/libpipewire-0.3.so.0 | grep PW_LOG_
> 383: 00000000000d7128 8 OBJECT GLOBAL DEFAULT 21 > PW_LOG_TOPIC_DEFAULT

But that command returns nothing on Parabola i686.

Denis.

 244 PackagesBug ReportVery LowLow unable to satisfy dependency 'libx264.so=163-32' requir ...Closed
100%
Task Description

# pacman -Sy ffmpeg
:: Synchronizing package databases… core is up to date
extra is up to date
community is up to date
resolving dependencies… warning: cannot resolve “libx264.so=163-32”, a dependency of “ffmpeg” :: The following package cannot be upgraded due to unresolvable dependencies:

    ffmpeg
 251 Packages: StableBug ReportVery LowLow [pavucontrol] libcanberra/libcanberra-pulse dependency  ...Closed
100%
Task Description

There is currently a problem preventing the installation of pavucontrol on i686:

resolving dependencies...
warning: cannot resolve "libcanberra=0.30+2+gc0620e4-3.2", a dependency of "libcanberra-pulse"
warning: cannot resolve "libcanberra-pulse", a dependency of "pavucontrol"
:: The following package cannot be upgraded due to unresolvable dependencies:
      pavucontrol
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcanberra=0.30+2+gc0620e4-3.2' required by libcanberra-pulse
:: unable to satisfy dependency 'libcanberra-pulse' required by pavucontrol
 255 PackagesBug ReportVery LowLow [seamonkey] Does not start, needs rebuilding Closed
100%
Task Description

Seamonkey is built with now outdated versions of libffi and icu (69). Neither pentium4 nor i686 build starts right now.

 259 PackagesBug ReportVery LowLow Broken GSL package Closed
100%
Task Description

GSL broken dependence with inkscape:

$ inkscape
inkscape: error while loading shared libraries: libgsl.so.27: cannot open shared object file: No such file or directory

Check the library:

# pacman -Ss gsl
extra/gsl 2.7-1.0 [instalado]

# pacman -Ql gsl | grep ‘\.so’ gsl /usr/lib/libgsl.so
gsl /usr/lib/libgsl.so.25
gsl /usr/lib/libgsl.so.25.1.0
gsl /usr/lib/libgslcblas.so
gsl /usr/lib/libgslcblas.so.0
gsl /usr/lib/libgslcblas.so.0.0.0

 267 PackagesBug ReportVery LowLow [(g)vim] libperl.so dependency version mismatch Closed
100%
Task Description

`/bin/vim` in version 8.2.5046-2.0 has an rpath on `libperl.so` version 5.36, which is currently only available in staging (i686/core is at version 5.34). vim does not start (cannot open shared object file).

```
$ readelf -d /bin/vim

Dynamic section at offset 0×486090 contains 43 entries:

Tag        Type                         Name/Value

[…]
0x000000000000000f (RPATH) Library rpath: [/usr/lib/perl5/5.36/core_perl/CORE]
```

 269 PackagesBug ReportVery LowLow [spam] Closed
100%
Task Description

spam

 270 PackagesBug ReportVery LowLow [spam] Closed
100%
Task Description

spam

 271 PackagesBug ReportVery LowLow [spam] Closed
100%
Task Description

spam

 272 PackagesBug ReportVery LowLow [spam] Closed
100%
Task Description

spam

 281 Packages: Build-listBug ReportVery LowLow Firefox compilation Closed
100%
Task Description

I checked the firefox on the build-list and its not compiling because of missing lvm13 libs which are packages are llvm13-libs and llvm13

283PackagesBug ReportVery LowLow[icu70/icu71 ] packages not rebuilt yetAssigned
0%
Task Description

starting to collect them here packages which require icu69 (and have thus not been rebuilt
for icu 71 yet):

libreoffice-fresh

 285 PackagesBug ReportVery LowLow [s-tui] /usr/bin/s-tui missing Closed
100%
Task Description

In s-tui 1.1.3-2.0, the run script /usr/bin/s-tui is missing. Only the files under /usr/lib/python3.10 are included in the package.

In the upstream Arch package the file is included: https://archlinux.org/packages/community/any/s-tui/

Rebuilding the package on a pentium4 machine resulted in a correct package. I cannot find any Arch Linux 32 specific PKGBUILD, so I’m not sure where this problem comes from. Maybe just rebuilding the package will fix it.

 286 PackagesBug ReportVery LowLow [speedtest-cli] missing scripts Closed
100%
Task Description

The package speedtest-cli (2.1.3-2.0) is missing the following scripts:
usr/bin/speedtest
usr/bin/speedtest-cli

These are generated scripts, but they should be included in the package.

287PackagesFeature RequestVery LowLowchromium not able to buildAssigned
0%
Task Description

Wait unfortunately i found a patch through which chromium would compile on x86

please try to build chromium using those patches

https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/reenable-linux-i686-builds.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-i686-vaapi-fpermissive.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-105-bitmap-include.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-105-browser-include.patch

 291 PackagesFeature RequestVery LowLow Hey , if possible can u build temite based on https://g ...Closed
100%
Task Description

Note:- It will compile very easily as i have a modified PKGBUILD

```
# Maintainer: Frederik Schwan freswa@archlinux.org pkgdesc=’A simple VTE-based terminal’ pkgname=termite
pkgver=16.4
pkgrel=2
url=https://github.com/aperezdc/termite license=(LGPL)
depends=(gtk3 pcre2 gnutls vte-common)
makedepends=(gperf ‘meson>=0.58’ ninja)
arch=(’x86_64’,’i686’,’pentium4’‘i486’)
backup=(etc/xdg/termite/config)

source=(”${url}/releases/download/v${pkgver}/termite-${pkgver}.tar.xz”{,.asc})
b2sums=(’SKIP’

      'SKIP')

build () {

rm -rf _build
arch-meson _build "${pkgname}-${pkgver}"
meson compile -C _build

}

package () {

meson install -C _build --skip-subprojects vte --destdir "${pkgdir}"

}
```

 292 PackagesFeature RequestVery LowLow Hey , if possible can u build temite based on https://g ...Closed
100%
Task Description

Note:- It will compile very easily as i have a modified PKGBUILD

# Maintainer: Frederik Schwan freswa@archlinux.org pkgdesc=’A simple VTE-based terminal’ pkgname=termite
pkgver=16.4
pkgrel=2
url=https://github.com/aperezdc/termite license=(LGPL)
depends=(gtk3 pcre2 gnutls vte-common)
makedepends=(gperf ‘meson>=0.58’ ninja)
arch=(’x86_64’,’i686’,’pentium4’‘i486’)
backup=(etc/xdg/termite/config)

source=(”${url}/releases/download/v${pkgver}/termite-${pkgver}.tar.xz”{,.asc})
b2sums=(’SKIP’

      'SKIP')

build () {

rm -rf _build
arch-meson _build "${pkgname}-${pkgver}"
meson compile -C _build

}

package () {

meson install -C _build --skip-subprojects vte --destdir "${pkgdir}"

}

 293 PackagesBug ReportVery LowLow Please update those packages:- Closed
100%
Task Description

Gimp
Krita

If possible can u add Julia Lang though its on blacklist but i will try to compile it :)

 295 PackagesBug ReportVery LowLow [qemu][seabios]: file conflict Closed
100%
Task Description
# pacman -S qemu seabios
resolving dependencies...
looking for conflicting packages...

Packages (2) qemu-6.2.0-4.0  seabios-1.16.0-3.2

Total Installed Size:  36.97 MiB

checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
/usr/share/qemu/bios-microvm.bin exists in both 'seabios' and 'qemu'
/usr/share/qemu/vgabios-ati.bin exists in both 'seabios' and 'qemu'
Errors occurred, no packages were upgraded.

 296 PackagesBug ReportVery LowLow Fix terminal emulators  Closed
100%
Task Description

On arch32 currently foot and alacritty is broken

 297 PackagesBug ReportVery LowLow jack2 can not install Closed
100%
Task Description
# pacman -S jack --noconfirm
:: There are 2 providers available for jack:
:: Repository extra
   1) jack2  2) pipewire-jack

Enter a number (default=1): 
resolving dependencies...
warning: cannot resolve "libcelt0.so=2-32", a dependency of "jack2"
:: The following package cannot be upgraded due to unresolvable dependencies:
      jack2

:: Do you want to skip the above package for this upgrade? [y/N] error: failed to prepare transaction (could not satisfy dependencies)

:: unable to satisfy dependency 'libcelt0.so=2-32' required by jack2
 298 PackagesBug ReportVery LowLow Please update Arduino Closed
100%
Task Description

Arduino is out dated and my teacher said to use the latest arduino version 1.8.x for the robotics class…

 299 PackagesFeature RequestVery LowLow [dart] request for bootstrapping dart Closed
100%
Task Description

The dart sdk files are still availble for ia32:-
https://storage.googleapis.com/dart-archive/channels/stable/release/2.18.2/sdk/dartsdk-linux-ia32-release.zip

can you send the old PKGBUILD which was used

 300 PackagesBug ReportVery LowLow Pinta needs to be updated Closed
100%
Task Description

please update pinta i am facing problems with p.net clone and the closest is pinta so if u look to update it then it would be greatful

 301 PackagesBug ReportVery LowLow [dino]: wont start Closed
100%
Task Description
# pacman -Syu dino
$ dino
main.vala:25: Fatal error: /usr/lib/libgupnp-1.2.so.1: undefined symbol: gssdp_client_can_reach
 302 DevopsFeature RequestVery LowLow Are you gonna continue 486 support? Closed
100%
Task Description

https://www.tomshardware.com/news/linux-removes-486-cpu-support

486 will be removed from the kernel and especially from 6.1 onwards rust will be integrated with the kernel…

 303 PackagesBug ReportVery LowLow codeblocks issue.. Closed
100%
Task Description

its requested that please push the codeblocks testing to stable..

 308 PackagesBug ReportVery LowLow gettext needs a rebuild for libunistring Closed
100%
Task Description

I’m on pentium4 and I’m getting:

/usr/bin/xgettext: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory
/usr/bin/msgmerge: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory
/usr/bin/msgfmt: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory

gettext 0.21.1-1.1
libunistring 1.1-2.0

 309 PackagesBug ReportVery LowLow gcompris links to openssl-1.1.so Closed
100%
Task Description

```
gcompris-qt: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory
```

 312 PackagesBug ReportVery LowLow In testing calibre will not start Closed
100%
Task Description
[keith@Arch32 ~]$ calibre
Failed to import PyQt module: PyQt6.QtQuick with error: No module named 'PyQt6.QtQuick'
Traceback (most recent call last):
  File "/usr/bin/calibre", line 21, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 546, in main
    app, opts, args = init_qt(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 123, in init_qt
    app = Application(args, override_program_name=override, windows_app_uid=MAIN_APP_UID)
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 1096, in __init__
    setup_to_run_webengine()
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 1078, in setup_to_run_webengine
    from qt.core import QQuickWindow, QSGRendererInterface
ImportError: cannot import name 'QQuickWindow' from 'qt.core' (/usr/lib/calibre/qt/core.py)
[keith@Arch32 ~]$ calibre --version
calibre (calibre 6.7.1)
[keith@Arch32 ~]$ 
314PackagesBug ReportVery LowLowMumble requires a outdated protobuf Unconfirmed
0%
Task Description

libprotobuf=28 is a mumble (package) dependency, but protobuf package has libprotobuf=32.

I needed to downgrade to protobuf-3.17.3-1.3-pentium4.pkg.tar.zst (from the archive) to install mumble.

 315 Packages: StableBug ReportVery LowLow [ncmpcpp] requires wrongly boost libraries  Closed
100%
Task Description

ncmpcpp-git compiles on AUR with no problem with all dependencies found on AL32 repositories.

 318 PackagesBug ReportVery LowLow [multiple]: Note: This key has expired! Closed
100%
Task Description
$ wget http://pool.mirror.archlinux32.org/i686/core/binutils-2.40-2.0-i686.pkg.tar.zst
$ wget http://pool.mirror.archlinux32.org/i686/core/binutils-2.40-2.0-i686.pkg.tar.zst.sig
$ sudo pacman-key --verify binutils-2.40-2.0-i686.pkg.tar.zst.sig
==> Checking binutils-2.40-2.0-i686.pkg.tar.zst.sig... (detached)
gpg: Signature made Mon Jan 23 01:17:18 2023 EST
gpg:                using RSA key 16194A82231E9EF823562181C8E8F5A0AF9BA7E7
gpg: Good signature from "Andreas Baumann (sign) <mail@andreasbaumann.cc>" [expired]
gpg: Note: This key has expired!
Primary key fingerprint: 1619 4A82 231E 9EF8 2356  2181 C8E8 F5A0 AF9B A7E7
==> ERROR: The signature identified by binutils-2.40-2.0-i686.pkg.tar.zst.sig could not be verified.

<KitsuWhooa> fuse also fails for me

 330 PackagesBug ReportVery LowLow [gcompris-qt] no game icons Closed
100%
Task Description

gcompris-qt 3.0-1.0 is missing a dependency on llvm14 (or maybe it needs a rebuild for llvm) and thus it doesn’t show any game in the menu.

 332 PackagesBug ReportVery LowLow firefox 112 compilation Closed
100%
Task Description

any ideas hpw to get past this error (i686)?

18:33.80 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:38:16: error: ‘any’ is not a member of ‘xsimd’
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:16:70: error: incomplete type ‘xsimd::batch<short int, xsimd::sse2>’ used in nested name specifier
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:35:31: error: ‘xsimd::batch<short int, xsimd::sse2> vectmask’ has incomplete type
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:37:64: error: incomplete type ‘xsimd::batch<short int, xsimd::sse2>’ used in nested name specifier
 334 PackagesBug ReportVery LowLow Calibre is out of date and will not start Closed
100%
Task Description

The latest version of calibre is 6.16.

The version in the repositories is 6.11.0-1.0 and unfortunately will no longer start.

[keith@Arch32 ~]$ calibre
Failed to import PyQt module: PyQt6.QtNetwork with error: /usr/lib/python3.10/site-packages/PyQt6/QtNetwork.abi3.so: undefined symbol: _ZN16QNetworkDatagram7destroyEP23QNetworkDatagramPrivate, version Qt_6
Traceback (most recent call last):
  File "/usr/bin/calibre", line 21, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 72, in calibre
    from calibre.gui2.main import main
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 13, in <module>
    from qt.core import (
ImportError: cannot import name 'QNetworkProxyFactory' from 'qt.core' (/usr/lib/calibre/qt/core.py)
[keith@Arch32 ~]$ pacman -Qi calibre
Name            : calibre
Version         : 6.11.0-1.0
Description     : Ebook management application
Architecture    : pentium4
URL             : https://calibre-ebook.com
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : hunspell  hyphen  icu  jxrlib  libmtp  libstemmer  libusb  libwmf  mathjax  mtdev  optipng  podofo
                  python-apsw  python-beautifulsoup4  python-cchardet  python-css-parser  python-cssselect  python-dateutil
                  python-dnspython  python-feedparser  python-html2text  python-html5-parser  python-jeepney  python-lxml
                  python-markdown  python-mechanize  python-msgpack  python-netifaces  python-pdftotext  python-pillow
                  python-psutil  python-py7zr  python-pychm  python-pycryptodome  python-pygments  python-pyqt6
                  python-pyqt6-webengine  python-regex  python-unrardll  python-zeroconf  qt6-imageformats  qt6-svg
                  qt6-webengine  ttf-liberation  uchardet  udisks2
Optional Deps   : poppler: required for converting pdf to html [installed]
                  speech-dispatcher: TTS support in the viewer
Required By     : None
Optional For    : None
Conflicts With  : calibre-common  calibre-python3
Replaces        : calibre-common  calibre-python3
Installed Size  : 91.69 MiB
Packager        : Andreas Baumann <mail@andreasbaumann.cc>
Build Date      : Thu 12 Jan 2023 05:31:50 GMT
Install Date    : Tue 24 Jan 2023 10:15:48 GMT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

[keith@Arch32 ~]$ 
336PackagesBug ReportVery LowLow[pyqt-builder]: needs rebuildUnconfirmed
0%
Task Description

just wanted to get this one on the board - i am unable to build ‘python-pyqt5’ which many other packages depend on, such as ‘qutebrowser’

the current ‘python-pyqt5’ PKGBUILD, which builds fine for x86_64 and arm, has unspecified dependencies in the i686 repos - not sure why that is

ModuleNotFoundError: No module named ‘jaraco.functools’
ModuleNotFoundError: No module named ‘jaraco.context’

that is easily fixed by requiring them explicitly:
> makedepends_i686=(’python-jaraco.context’ ‘python-jaraco.functools’)

however, after that, it gives a more fatal error:

sip-build: Unable to import ‘project.py’: No module named ‘pyqtbuild’

that module is in the ‘pyqt-builder’ package, i beleive - ‘pyqt-builder’ is installed as a build dependency; but it was built for python 3.9 - so probably that is why the build could not find the module

338PackagesBug ReportVery LowLow[libreoffice-still]: error while loading shared librari...Unconfirmed
0%
Task Description

needs rebuild against latest ‘boost’

$ sudo pacman -Sy libreoffice-still

$ pacman -Qs libreoffice-still
local/libreoffice-still 7.3.7-2.0
    LibreOffice maintenance branch

$ lowriter
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_locale.so.1.80.0: cannot open shared object file: No such file or directory
339PackagesBug ReportVery LowLow[libcanberra-pulse]: can not be installedUnconfirmed
0%
Task Description
# pacman -S libcanberra-pulse
resolving dependencies...
warning: cannot resolve "libcanberra=0.30+2+gc0620e4-3.2", a dependency of "libcanberra-pulse"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libcanberra-pulse

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcanberra=0.30+2+gc0620e4-3.2' required by libcanberra-pulse
343PackagesBug ReportVery LowLowPackage 'screen 4.9.1-1.0' is missing dependency libute...Unconfirmed
0%
Task Description

Package ‘screen 4.9.1-1.0’ is missing dependency libutempter. I assume this is because libutempter used to be a dependency of util-linux which is part of base, so was assumed to be installed.

With the regular Arch Linux distro libutempter is still a dependency of util-linux.

345PackagesBug ReportVery LowLow[gcompris-qt] doesn't start due to Qt 5.15.10Unconfirmed
0%
Task Description

I fails to start with: “Cannot mix incompatible Qt library (5.15.9) with this library (5.15.10)”

346PackagesBug ReportVery LowLowpandoc: error while loading shared librariesUnconfirmed
0%
Task Description
# pacman -Syyuu base
# pacman -S pandoc
# pandoc
pandoc: error while loading shared libraries: libHSzip-archive-0.4.1-FOOm53qGfUr2AB1Oel9iH4-ghc8.10.2.so: cannot open shared object file: No such file or directory
347PackagesBug ReportVery LowLowMeld will not start - error message -> Meld requires Gt...Unconfirmed
0%
Task Description

[keith@Arch32 ~]$ meld
Meld requires Gtk+ 3.20 or higher.
[keith@Arch32 ~]$ pacman -Qi meld
Name : meld
Version : 3.22.0-2.0
Description : Compare files, directories and working copies
Architecture : any
URL : https://meldmerge.org/ Licenses : GPL Groups : None
Provides : None
Depends On : python-gobject python-cairo gtksourceview4 gsettings-desktop-schemas dconf
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 5.06 MiB
Packager : TasosSah arch32@tasossah.com Build Date : Sat 19 Aug 2023 23:25:57 BST
Install Date : Sat 26 Aug 2023 07:08:59 BST
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

[keith@Arch32 ~]$ pacman -Qi gtksourceview4
Name : gtksourceview4
Version : 4.8.4-1.0
Description : A text widget adding syntax highlighting and more to GNOME
Architecture : pentium4
URL : https://wiki.gnome.org/Projects/GtkSourceView Licenses : GPL Groups : None
Provides : libgtksourceview-4.so=0-32
Depends On : gtk3 libxml2
Optional Deps : None
Required By : meld xed
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 7.44 MiB
Packager : Andreas Baumann mail@andreasbaumann.cc Build Date : Mon 07 Nov 2022 11:50:56 GMT
Install Date : Mon 28 Nov 2022 11:49:04 GMT
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

[keith@Arch32 ~]$ pacman -Qi gtk3
Name : gtk3
Version : 1:3.24.37-1.0
Description : GObject-based multi-platform GUI toolkit
Architecture : pentium4
URL : https://www.gtk.org/ Licenses : LGPL Groups : None
Provides : gtk3-print-backends libgailutil-3.so=0-32 libgdk-3.so=0-32 libgtk-3.so=0-32
Depends On : adwaita-icon-theme atk cairo cantarell-fonts dconf desktop-file-utils fontconfig fribidi gdk-pixbuf2 glib2 harfbuzz iso-codes

                libcloudproviders  libcolord  libcups  libegl  libepoxy  libgl  librsvg  libxcomposite  libx11  libxcursor  libxdamage  libxext  libxfixes
                libxi  libxinerama  libxkbcommon  libxrandr  libxrender  pango  shared-mime-info  wayland  at-spi2-core  tracker3  gtk-update-icon-cache

Optional Deps : evince: Default print preview command
Required By : bleachbit engrampa firefox gcr gpicview gspell gtkmm3 gtksourceview4 libdbusmenu-gtk3 libgnomekbd libindicator-gtk3 libnma

                libpeas  lightdm-gtk-greeter  lxmusic  vte3  xdg-user-dirs-gtk

Optional For : avahi gvfs libcanberra libdecor libreoffice-still
Conflicts With : gtk3-print-backends
Replaces : gtk3-print-backends⇐3.22.26-1
Installed Size : 49.88 MiB
Packager : Andreas Baumann mail@andreasbaumann.cc Build Date : Sun 16 Apr 2023 11:18:09 BST
Install Date : Tue 25 Apr 2023 13:06:04 BST
Install Reason : Installed as a dependency for another package
Install Script : Yes
Validated By : Signature

[keith@Arch32 ~]$

352PackagesBug ReportVery LowLowgmtp in extra is brokenUnconfirmed
0%
Task Description

It is an i686-system.

steps to reproduce:

    1) # pacman -Syyuu base
    2) # pacman -S gmtp
    3) $ gmtp

expected result:

    Start screen of gmtp appears.

actual result:

    $ gmtp
    gmtp: error while loading shared libraries: libFLAC.so.8: cannot open shared object file: No such file or directory

gmtp in extra-staging works though

 353 PackagesBug ReportVery LowLow mc: is broken Closed
100%
Task Description
$ mc
mc: symbol lookup error: mc: undefined symbol: g_string_new_take

$ mcedit
mcedit: symbol lookup error: mcedit: undefined symbol: g_string_new_take
 354 PackagesBug ReportVery LowLow staging mkinitcpio<->cryptsetup conflict Closed
100%
Task Description

it is not possible to enable staging

$ sudo pacman -Syuu
:: Synchronizing package databases...
 core-staging is up to date
 core is up to date
 extra-staging                      2.5 MiB  2.22 MiB/s 00:01 [##################################] 100%
 extra is up to date
 community-staging is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
:: There are 2 providers available for dbus-units:
:: Repository core-staging
   1) dbus-broker-units  2) dbus-daemon-units

Enter a number (default=1): 
looking for conflicting packages...
:: cryptsetup and mkinitcpio are in conflict. Remove mkinitcpio? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'initramfs' required by linux
359PackagesBug ReportVery LowLowQterminal 1.3.0-1.1 is brokenUnconfirmed
0%
Task Description

Qterminal 1.3.0-1.1 is broken. It causes a segmentation fault. Upgrade to 1.4.0-1.0 (still in staging) solves this issue.

342PackagesBug ReportVery LowVery Lownmap missing dependency openssl-1.1Unconfirmed
0%
Task Description

no task description

Showing tasks 301 - 350 of 350 Page 7 of 7<<First - 3 - 4 - 5 - 6 - 7

Available keyboard shortcuts

Tasklist

Task Details

Task Editing