Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategoryTask TypePrioritySeveritySummaryStatusProgress
 146 Packages: UpstreamBug ReportMediumLow trojita doesn't build, missing a patch, failures on qt  ...Closed
100%
Task Description

=⇒ ERROR: Failure while downloading https://cgit.kde.org/trojita.git/patch/?id=cf2364b8

SHA1 in https://anongit.kde.org/trojita):

cf2364b80fa8ae844df8350cd5833d47cce235f2

    Fix possible crash when downloading attachments

Yep, promising, lets download the patch and add it to the package.

Original bug: https://bugs.kde.org/show_bug.cgi?id=417697

/build/trojita/src/trojita-0.7/src/Gui/Window.cpp:981:26: error: aggregate ‘QPainterPath path’ has incomplete type and cannot be defined
  981 |             QPainterPath path;
      |                          ^~~~

needs a #include <QPainterPath>

Reported as https://bugs.kde.org/show_bug.cgi?id=432827

 145 PackagesBug ReportMediumLow glibc 2.33 breaks i686 and i486 architectures Closed
100%
Task Description
/usr/lib/libc.6: CPU ISA level is lower than required.

updating effectively breaks all commands!

For those lucky enough to have a pacman-static installed, they can
IMMEDIATEDY downgrade glibc and keep the machine alive.

This is considered a distribution-killing bug for i486 and i686.

Pentium4 is not affectted.

 144 PackagesBug ReportMediumLow firefox fails to build Closed
100%
Task Description
/build/seamonkey/src/seamonkey-2.53.5/obj-i686-pc-linux-gnu/_virtualenv/bin/python /build/seamonkey/src/s                                                                                                           eamonkey-2.53.5/mozilla/toolkit/mozapps/installer/packager.py -DMOZ_APP_NAME=seamonkey -DPREF_DIR=default                                                                                                           s/pref -DJAREXT= -DMOZ_CALENDAR=1 -DMOZ_GTK=1 -DMOZ_IRC=1 -DMOZ_DOMINSPECTOR=1 -DMOZ_SYSTEM_NSPR=1 -DMOZ_                                                                                                           SYSTEM_NSS=1 -DMOZ_MOVEMAIL=1 -DNECKO_WIFI=1 -DMOZ_BUNDLED_FONTS=1 -DMOZ_CHILD_PROCESS_NAME=plugin-contai                                                                                                           ner -DDLL_PREFIX=lib -DDLL_SUFFIX=.so -DBIN_SUFFIX= -DDIR_MACOS= -DDIR_RESOURCES= -DBINPATH=bin -DRESPATH                                                                                                           =bin -DLPROJ_ROOT=en -DCLANG_CXX -DA11Y_LOG=1 -DACCESSIBILITY=1 -DATK_MAJOR_VERSION=2 -DATK_MINOR_VERSION                                                                                                           =36 -DATK_REV_VERSION=0 -DBUILD_CTYPES=1 -DCROSS_COMPILE='' -DD_INO=d_ino -DENABLE_INTL_API=1 -DENABLE_SY                                                                                                           STEM_EXTENSION_DIRS=1 -DEXPOSE_INTL_API=1 -DFIREFOX_VERSION=60.7.5 -DFORCE_PR_LOG=1 -DFUNCPROTO=15 -DGDK_                                                                                                           VERSION_MAX_ALLOWED=GDK_VERSION_3_4 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_32 -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_26 -DGL_PROVIDER_GLX=1 -DHAVE_ALLOCA_H=1 -DHAVE_BYTESWAP_H=1 -DHAVE_CLOCK_MONOTONIC=1 -DHAVE_CPUID_H=1 -DHAVE_DIRENT_H=1 -DHAVE_DLADDR=1 -DHAVE_DLOPEN=1 -DHAVE_FONTCONFIG_FCFREETYPE_H=1 -DHAVE_FT_BITMAP_SIZE_Y_PPEM=1 -DHAVE_FT_GLYPHSLOT_EMBOLDEN=1 -DHAVE_FT_LOAD_SFNT_TABLE=1 -DHAVE_GETOPT_H=1 -DHAVE_GETTID=1 -DHAVE_GMTIME_R=1 -DHAVE_I18N_LC_MESSAGES=1 -DHAVE_INTTYPES_H=1 -DHAVE_LCHOWN=1 -DHAVE_LINUX_IF_ADDR_H=1 -DHAVE_LINUX_PERF_EVENT_H=1 -DHAVE_LINUX_QUOTA_H=1 -DHAVE_LINUX_RTNETLINK_H=1 -DHAVE_LOCALECONV=1 -DHAVE_LOCALTIME_R=1 -DHAVE_LSTAT64=1 -DHAVE_MALLINFO=1 -DHAVE_MALLOC_H=1 -DHAVE_MALLOC_USABLE_SIZE=1 -DHAVE_MEMALIGN=1 -DHAVE_MEMMEM=1 -DHAVE_MOVEMAIL=1 -DHAVE_NETINET_IN_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_POSIX_FADVISE=1 -DHAVE_POSIX_FALLOCATE=1 -DHAVE_POSIX_MEMALIGN=1 -DHAVE_PTHREAD_H=1 -DHAVE_RES_NINIT=1 -DHAVE_SETPRIORITY=1 -DHAVE_STAT64=1 -DHAVE_STDINT_H=1 -DHAVE_STRERROR=1 -DHAVE_STRNDUP=1 -DHAVE_SYSCALL=1 -DHAVE_SYS_QUEUE_H=1 -DHAVE_SYS_QUOTA_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_THREAD_TLS_KEYWORD=1 -DHAVE_TRUNCATE64=1 -DHAVE_UNISTD_H=1 -DHAVE_VALLOC=1 -DHAVE_VA_COPY=1 -DHAVE_VISIBILITY_ATTRIBUTE=1 -DHAVE_VISIBILITY_HIDDEN_ATTRIBUTE=1 -DHAVE__UNWIND_BACKTRACE=1 -DHAVE___CXA_DEMANGLE=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMALLOC_H='<malloc.h>' -DMALLOC_USABLE_SIZE_CONST_PTR='' -DMOZILLA_OFFICIAL=1 -DMOZILLA_UAVERSION='"60.0"' -DMOZILLA_VERSION='"60.7.5"' -DMOZILLA_VERSION_U=60.7.5 -DMOZ_ACCESSIBILITY_ATK=1 -DMOZ_ALLOW_LEGACY_EXTENSIONS=1 -DMOZ_APP_UA_NAME='""' -DMOZ_APP_UA_VERSION='"2.53.5"' -DMOZ_AV1=1 -DMOZ_BUILD_APP=../suite -DMOZ_BUNDLED_FONTS=1 -DMOZ_CONTENT_SANDBOX=1 -DMOZ_DAV1D_ASM=1 -DMOZ_DISABLE_STARTUPCACHE=1 -DMOZ_DISTRIBUTION_ID='"org.mozilla"' -DMOZ_DLL_SUFFIX='".so"' -DMOZ_ENABLE_DBUS=1 -DMOZ_ENABLE_MASK_AS_SHORTHAND=1 -DMOZ_ENABLE_SKIA=1 -DMOZ_ENABLE_STARTUP_NOTIFICATION=1 -DMOZ_ENABLE_XREMOTE=1 -DMOZ_FEEDS=1 -DMOZ_FFMPEG=1 -DMOZ_FFVPX=1 -DMOZ_FFVPX_FLACONLY=1 -DMOZ_FMP4=1 -DMOZ_GECKO_PROFILER=1 -DMOZ_GLUE_IN_PROGRAM=1 -DMOZ_GMP_SANDBOX=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DMOZ_LOGGING=1 -DMOZ_MACBUNDLE_ID=org.mozilla.seamonkey -DMOZ_MEMORY=1 -DMOZ_MORK=1 -DMOZ_PEERCONNECTION=1 -DMOZ_PERMISSIONS=1 -DMOZ_PLACES=1 -DMOZ_PULSEAUDIO=1 -DMOZ_RAW=1 -DMOZ_RUST_SIMD=1 -DMOZ_SAMPLE_TYPE_FLOAT32=1 -DMOZ_SANDBOX=1 -DMOZ_SCTP=1 -DMOZ_SEPARATE_MANIFEST_FOR_THEME_OVERRIDES=1 -DMOZ_SRTP=1 -DMOZ_STATIC_JS=1 -DMOZ_SUITE=1 -DMOZ_SYSTEM_ICU=1 -DMOZ_TREE_CAIRO=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_USER_DIR='".mozilla"' -DMOZ_VORBIS=1 -DMOZ_VPX_NO_MEM_REPORTING=1 -DMOZ_WEBM_ENCODER=1 -DMOZ_WEBRTC=1 -DMOZ_WEBRTC_ASSERT_ALWAYS=1 -DMOZ_WEBRTC_SIGNALING=1 -DMOZ_WEBSPEECH=1 -DMOZ_WEBSPEECH_TEST_BACKEND=1 -DMOZ_WIDGET_GTK=3 -DMOZ_X11=1 -DMOZ_XUL=1 -DNO_NSPR_10_SUPPORT=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DRELEASE_OR_BETA=1 -DSTATIC_JS_API=1 -DSTDC_HEADERS=1 -DTARGET_XPCOM_ABI='"x86-gcc3"' -DUSE_SKIA=1 -DUSE_SKIA_GPU=1 -DU_USING_ICU_NAMESPACE=0 -DVA_COPY=va_copy -DVPX_X86_ASM=1 -DXP_LINUX=1 -DXP_UNIX=1 -D_REENTRANT=1 -DAB_CD=en-US \
        --format omni \
        --removals /build/seamonkey/src/seamonkey-2.53.5/suite/installer/removed-files.in \
         \
         \
         \
         \
        --optimizejars \
        --disable-compression \
        package-manifest ../../dist ../../dist/seamonkey \
        --non-resource defaults/messenger/mailViews.dat defaults/profile/panels.rdf defaults/profile/mimeTypes.rdf defaults/profile/chrome/userChrome-example.css defaults/profile/chrome/userContent-example.css 
terminate called after throwing an instance of 'std::runtime_error'
  what():  Section index out of bounds
Traceback (most recent call last):
  File "/build/seamonkey/src/seamonkey-2.53.5/mozilla/toolkit/mozapps/installer/packager.py", line 326, in <module>
    main()
  File "/build/seamonkey/src/seamonkey-2.53.5/mozilla/toolkit/mozapps/installer/packager.py", line 320, in main
    copier.copy(args.destination)
  File "/build/seamonkey/src/seamonkey-2.53.5/mozilla/python/mozbuild/mozpack/copier.py", line 428, in copy
    copy_results.append((destfile, f.copy(destfile, skip_if_older)))
  File "/build/seamonkey/src/seamonkey-2.53.5/mozilla/python/mozbuild/mozpack/files.py", line 296, in copy
    elfhack(dest)
  File "/build/seamonkey/src/seamonkey-2.53.5/mozilla/python/mozbuild/mozpack/executables.py", line 124, in elfhack
    errors.fatal('Error executing ' + ' '.join(cmd))
  File "/build/seamonkey/src/seamonkey-2.53.5/mozilla/python/mozbuild/mozpack/errors.py", line 103, in fatal
    self._handle(self.FATAL, msg)
  File "/build/seamonkey/src/seamonkey-2.53.5/mozilla/python/mozbuild/mozpack/errors.py", line 98, in _handle
    raise ErrorMessage(msg)
mozpack.errors.ErrorMessage: Error: Error executing /build/seamonkey/src/seamonkey-2.53.5/obj-i686-pc-linux-gnu/build/unix/elfhack/elfhack ../../dist/seamonkey/libxul.so
make[2]: *** [/build/seamonkey/src/seamonkey-2.53.5/mozilla/toolkit/mozapps/installer/packager.mk:22: stage-package] Error 1
make[2]: Leaving directory '/build/seamonkey/src/seamonkey-2.53.5/obj-i686-pc-linux-gnu/suite/installer'
make[1]: *** [/build/seamonkey/src/seamonkey-2.53.5/mozilla/../suite/build.mk:13: install] Error 2
make[1]: Leaving directory '/build/seamonkey/src/seamonkey-2.53.5/obj-i686-pc-linux-gnu'
make: *** [client.mk:404: install] Error 2
==> ERROR: A failure occurred in package().
    Aborting...
==> ERROR: Build failed, check /var/lib/archbuild/slave1/staging-pentium4/slave1/build
used straw: :mirrored_source:mirrored_source_by_hash:

143PackagesBug ReportMediumLowthunderbird doesn't build and runNew
0%
Task Description

still linked against icu67.

Same here, I cannot believe that somebody is actually using thunderbird on Archlinux32 anymore.

Triggered rebuild, doesn’t build currently.

 142 PackagesBug ReportMediumLow gnome-terminal doesn't start Closed
100%
Task Description
# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Could not connect: Connection refused

As this is the case since months, I cannot imagine somebody is still using Gnome on Archlinux32..

141DevopsBug ReportMediumLowmake iso build more reliablyNew
0%
Task Description

Currently, the iso build are several bash scripts on several machines requiring to move stuff via sshfs and alike.

This should become more stable - ideally some single script/package/systemd-unit with proper error reporting (email or irc come to my mind)

 140 PackagesBug ReportMediumLow libproxy doesn't build Closed
100%
Task Description
-- Installing: /build/libproxy/pkg/libproxy/usr/include/proxy.h
-- Installing: /build/libproxy/pkg/libproxy/usr/bin/proxy
mv: cannot stat '/build/libproxy/pkg/libproxy/usr/lib/libproxy/*/modules/pacrunner_webkit.so': No such file or directory
==> ERROR: A failure occurred in package_libproxy().
    Aborting...
 139 PackagesBug ReportMediumLow webkit2gtk doesn't build Closed
100%
Task Description

This blocks tons of packages..

 138 PackagesBug ReportMediumLow polkit doesn't build because of a stuck js78 Closed
100%
Task Description

no task description

 137 PackagesBug ReportMediumLow llvm rebuild fails (aka sphinx requires a python module ...Closed
100%
Task Description
Configuration error:
There is a programmable error in your configuration file:

Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/sphinx/config.py", line 326, in eval_config_file
    execfile_(filename, namespace)
  File "/usr/lib/python3.9/site-packages/sphinx/util/pycompat.py", line 88, in execfile_
    exec(code, _globals)
  File "/build/llvm/src/llvm-11.0.1.src/docs/conf.py", line 40, in <module>
    import recommonmark
ModuleNotFoundError: No module named 'recommonmark'
 136 PackagesBug ReportMediumLow Haskell probably completely fails to rebuild Closed
100%
Task Description
Configuring attoparsec-0.13.2.4...
Error:
    The following packages are broken because other packages they depend on are missing. These broken packages must be rebuilt before they can be used.
installed package tasty-1.3.1 is broken due to missing package ansi-terminal-0.11-2SXi8ZhU18i2uWLidRUotS, async-2.2.2-K8T9LglWxlG5HgD5vvGjbo, optparse-applicative-0.16.1.0-JDPEASK1GJS1Nsq2qjjZCq
installed package tasty-quickcheck-0.10.1.2 is broken due to missing package QuickCheck-2.14.2-io0WylueSG4seqSTUQCKM, optparse-applicative-0.16
 135 PackagesBug ReportMediumLow namcap fails on libxkbcommon Closed
100%
Task Description
Checking PKGBUILD
Traceback (most recent call last):
  File "/usr/lib/python3.9/runpy.py", line 197, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/lib/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/usr/lib/python3.9/site-packages/namcap.py", line 247, in <module>
    process_pkgbuild(package, active_modules)
  File "/usr/lib/python3.9/site-packages/namcap.py", line 153, in process_pkgbuild
    name = "PKGBUILD (" + pkginfo["name"] + ")"
  File "/usr/lib/python3.9/site-packages/Namcap/package.py", line 128, in __getitem__
    return self._data[self.canonical_varname(key)]
KeyError: 'name'
==> Running checkpkg
error: no targets specified (use -h for help)
==> WARNING: Skipped checkpkg due to missing repo packages
 134 PackagesBug ReportVery LowLow arm-none-eabi-gdb requires rebuild Closed
100%
Task Description

arm-none-eabi-gdb is broken due to not satisfiable dependency: “libpython3.8.so.1.0” After recompiling from upstream it works.

 133 PackagesBug ReportMediumLow libao and libpulse mixup Closed
100%
Task Description
resolving dependencies...
warning: cannot resolve "libpulse.so=0-32", a dependency of "libao"
warning: cannot resolve "libpulse-simple.so=0-32", a dependency of "libao"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libao

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libpulse.so=0-32' required by libao
:: unable to satisfy dependency 'libpulse-simple.so=0-32' required by libao
132PackagesBug ReportMediumLowOLPC-XO-1 kernel, usb8xx module crashingNew
0%
Task Description
[   21.686772] usb8xxx: Firmware ready event received
[   21.717061] usb8xxx 1-1:1.0 (unnamed net_device) (uninitialized): 00:17:c4:10:e3:67, fw 5.110.22p23, cap 0x000003a3
[   21.897489] usb8xxx 1-1:1.0 wlan0: Marvell WLAN 802.11 adapter
[   22.004871] usb8xxx 1-1:1.0 wlan0: PREP_CMD: command 0x0074 failed: 2
[   22.109002] usb8xxx 1-1:1.0 wlan0: Firmware does not seem to support PS mode
[   22.217405] usb8xxx 1-1:1.0 wlan0: PREP_CMD: command 0x0043 failed: 1
[   22.318862] usb8xxx 1-1:1.0 wlan0: HOST_SLEEP_CFG failed 1
[   23.468484] usb8xxx 1-1:1.0 wlp0s15f5u1: renamed from msh0
[   43.523176] ------------[ cut here ]------------
[   43.556197] WARNING: CPU: 0 PID: 148 at net/wireless/core.c:1346 cfg80211_netdev_notifier_call+0x102/0x31e
[   43.625361] Modules linked in: input_leds led_class usb8xxx libertas serio_raw
[   43.664224] CPU: 0 PID: 148 Comm: wpa_supplicant Not tainted 5.10.5-arch1-1.0-olpc-xo1 #1
[   43.715531] Hardware name: OLPC XO/XO, BIOS OLPC Ver 1.00.01 06/11/2014
[   43.754829] EIP: cfg80211_netdev_notifier_call+0x102/0x31e
[   43.792862] Code: ff 89 f0 e8 4d fc ff ff 8b 46 7c 85 c0 74 2a 39 58 34 75 25 80 78 64 00 75 16 8b 96 80 00 00 00 85 d2 74 06 80 7a 64 00 75 06 <0f> 0b c6 40 62 01 31 d2 89 f0 e8 3d 7a 00 00 8b 86 88 00 00 00 8b
[   43.911511] EAX: c36e1d00 EBX: c2cb8800 ECX: ffffffff EDX: 00000000
[   43.958939] ESI: c341c000 EDI: c1f7d000 EBP: c1eebdd4 ESP: c1eebdbc
[   44.002464] DS: 007b ES: 007b FS: 0000 GS: 00e0 SS: 0068 EFLAGS: 00010246
[   44.045454] CR0: 80050033 CR2: b69e5428 CR3: 01ff0000 CR4: 00000090
[   44.088019] Call Trace:
[   44.126010]  ? fib_disable_ip+0x2a/0x2d
[   44.165297]  ? cfg80211_register_wdev+0x46/0x46
[   44.208941]  notifier_call_chain+0x2a/0x4e
[   44.252482]  raw_notifier_call_chain+0xc/0xe
[   44.296501]  call_netdevice_notifiers_info+0x5d/0x64
[   44.338599]  call_netdevice_notifiers+0x18/0x1a
[   44.379580]  __dev_notify_flags+0x4a/0x7c
[   44.419064]  dev_change_flags+0x3d/0x46
[   44.464304]  devinet_ioctl+0x260/0x4cd
[   44.502437]  inet_ioctl+0x139/0x163
[   44.539766]  ? dev_name_hash+0x20/0x36
[   44.577060]  ? dev_get_by_name_rcu+0x1c/0x2f
[   44.614874]  ? dev_ioctl+0x2e4/0x40e
[   44.651928]  ? inet_recvmsg+0x77/0x77
[   44.692778]  sock_ioctl+0x2ad/0x36f
[   44.730157]  ? preempt_count_add+0x4a/0x4f
[   44.771397]  ? ____sys_recvmsg+0xbc/0xbc
[   44.808485]  vfs_ioctl+0x1a/0x24
[   44.847256]  __ia32_sys_ioctl+0x5aa/0x5c4
[   44.891962]  ? debug_smp_processor_id+0x12/0x14
[   44.930996]  ? fpregs_assert_state_consistent+0x17/0x34
[   44.967562]  ? exit_to_user_mode_prepare+0x84/0x94
[   45.002448]  do_int80_syscall_32+0x2c/0x39
[   45.035656]  entry_INT80_32+0xf3/0xf3
[   45.067762] EIP: 0xb790ffc4
[   45.097915] Code: 83 c4 0c 89 d8 5b 5e 5f 5d c3 66 90 66 90 66 90 66 90 66 90 66 90 53 8b 54 24 10 8b 4c 24 0c 8b 5c 24 08 b8 36 00 00 00 cd 80 <5b> 3d 01 f0 ff ff 0f 83 a0 3f f3 ff c3 66 90 66 90 66 90 66 90 66
[   45.199342] EAX: ffffffda EBX: 00000007 ECX: 00008914 EDX: bffe736c
[   45.233187] ESI: bffe736c EDI: 0076c850 EBP: 00000000 ESP: bffe7348
[   45.266705] DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 007b EFLAGS: 00000296
[   45.300799] ---[ end trace 20811b76aa348f84 ]---
[   64.909322] IPv6: ADDRCONF(NETDEV_CHANGE): wlp0s15f5u1: link becomes ready

Warm reboot a second time seems to help.

 131 PackagesBug ReportMediumLow libseccomp doesn't build in python bindings Closed
100%
Task Description

no task description

 130 PackagesBug ReportMediumLow user-manager and plasma-meta are in conflict Closed
100%
Task Description

:: removing user-manager breaks dependency ‘user-manager’ required by plasma-meta

 129 PackagesBug ReportMediumLow rust 1.47 is outdated Closed
100%
Task Description

either building 1.49 via 1.48, via 1.47 or we have to bootstrap from a binary version again.

 128 PackagesBug ReportMediumLow newsboat needs rebuild against newer libjson-c Closed
100%
Task Description
newsboat: error while loading shared libraries: libjson-c.so.4: cannot open shared object file: No such file or directory
 127 PackagesBug ReportMediumLow iotop doesn't work Closed
100%
Task Description
root@arch32-stable-pentium4 ~]# iotop
No module named 'iotop'
To run an uninstalled copy of iotop,
launch iotop.py in the top directory

iotop is a Python script, presumably some Python modules are missing.

126PackagesBug ReportMediumLowlua hooks break in TeX on i686New
0%
Task Description
PANIC: unprotected error in call to Lua API (CPU with SSE2 required)
PANIC: unprotected error in call to Lua API (CPU with SSE2 required)
fmtutil [ERROR]: running `luajittex -ini   -jobname=luajittex -progname=luajittex luatex.ini </dev/null' return status: 1
fmtutil [ERROR]: cannot copy log luajittex.log to: /var/lib/texmf/web2c/luajittex
fmtutil [ERROR]: returning error due to option --strict
fmtutil [ERROR]: running `luajithbtex -ini   -jobname=luajithbtex -progname=luajithbtex luatex.ini </dev/null' return status: 1
fmtutil [ERROR]: cannot copy log luajithbtex.log to: /var/lib/texmf/web2c/luajithbtex
fmtutil [ERROR]: returning error due to option --strict
error: command failed to execute correctly
 125 PackagesBug ReportMediumLow seamonkey broken on i686 Closed
100%
Task Description

breaks in more SIMD optimizations.

 124 PackagesBug ReportMediumLow mutter and gnome-shell are in confllict Closed
100%
Task Description

:: installing mutter (3.38.1-1.1) breaks dependency ‘libmutter-6.so=0-32’ required by gnome-shell

 123 PackagesBug ReportMediumLow libhandy0, libhandy conflicts Closed
100%
Task Description

libhandy0: /usr/share/vala/vapi/libhandy-0.0.deps exists in filesystem (owned by libhandy)
libhandy0: /usr/share/vala/vapi/libhandy-0.0.vapi exists in filesystem (owned by libhandy)

 122 PackagesBug ReportVery LowLow Permissions bits on files on the primary mirror are too ...Closed
100%
Task Description

In my quest to find a working mirror close to me, I’ve come across another issue with at least a couple of mirrors. Some mirrors respond with a HTTP 403 Forbidden for certain files, notably many of the Pacman database files. At the time of this writing, I’m aware of this problem happening with the princeton.edu and the clarkson.edu mirrors. I’ve been in contact with the admin of one of the mirrors, and they’ve pointed out that the permission bits are set to 0600 at the source. If the primary mirror could have their files be world readable, it would likely fix this problem automatically across more than one mirror.

Is that something we can do?

Steps to verify:

1. Access certain files from the primary mirror using rsync, for example:

% rsync -av rsync://mirror.archlinux32.org/archlinux32/i686/extra/extra.db.tar.gz .
receiving incremental file list
extra.db.tar.gz

sent 43 bytes  received 2,044,453 bytes  371,726.55 bytes/sec
total size is 2,043,851  speedup is 1.00

2. Examine permission bits:

% ls -l extra.db.tar.gz
-rw------- 1 user user 2043851 Jan  8 11:51 extra.db.tar.gz

Should be -rw-r–r–.

 121 PackagesBug ReportVery LowHigh Multiple packages need rebuild after libicu upgrade Closed
100%
Task Description

Over in  FS#119 , @abaumann mentioned that the libicu upgrade from 67 to 68 was part of what broke gdb. I missed the libicu upgrade when looking at gdb, but now that that one is resolved, I noticed a number of other packages that still link against the old and now nonexistant /usr/lib/libicu*.so.67 files. On my particular system, the following packages are installed, link to icu 67, and need rebuilt as well:

* harfbuzz-icu (2.7.0-1.0)
* mongo-c-driver (1.17.3-1.0)
* postfix (3.5.6-2.0)
* postgresql (12.4-1.0)
* postgresql-old-upgrade (12.5-1.0)
* samba (4.12.3-1.2)
* smbclient (4.12.3-1.2)
* syslog-ng (3.28.1-3.0)
* texlive-bin (2020.54586-4.0)
* xfsprogs (5.8.0-1.0)

… but I’m sure you have a way of determining all the affected packages?

As a workaround, in case others have the same problem, I manually extracted the old versioned .so files from the previous package to get things working again:

```
tar -C / -xf /var/cache/pacman/pkg/icu-67.1-1.0-i686.pkg.tar.zst –wildcards ‘usr/lib/lib*.so.*’ ```

- I’ll just have to remember to clean them up again later.

 120 PackagesBug ReportVery LowLow Princeton ArchLinux32 mirror has been out of date; ques ...Closed
100%
Task Description

The ArchLinux32 mirror at http[s]://mirror.math.princeton.edu/pub/archlinux32/ appears to have stopped syncing properly in October. I contacted web@math.princeton.edu on January 1 to alert them to the problem, and received the following response from a Princeton sysadmin:


Here is the configuration I am using:
archlinux32:
   remotesrc: “rsync://mirror.archlinux32.org/archlinux32/”
   localdest: “/var/www/html/pub/archlinux32”
   extraopts: “–port=22873”
Looks like at some point this stopped working from upstream:
Raw standard error:
rsync: failed to connect to mirror.archlinux32.org (85.10.198.216): Connection refused (111)
rsync: failed to connect to mirror.archlinux32.org (2a01:4f8:a0:5264::2): Network is unreachable (101)
rsync error: error in socket IO (code 10) at clientserver.c(125) [Receiver=3.1.2]
Can you recommend a better upstream target I can use? And if there are additional constraints on checkin time or frequency.

I informed him that I am not an official member of the ArchLinux32 team, but suggested that using the regular rsync port of 873 might work as mirror.archlinux32.org appears to accept connections to that port from the Internet. As of the time of this writing, it appears that the mirror is now again up to date (although it has other issues returning HTTP error 403 for some of its files), but I promised to bring his additional questions to the official team.

So, to iterate, is this the appropriate target to mirror, or should they use some other parameters?

Thank you.

 119 PackagesBug ReportVery LowHigh [gdb] needs rebuilt after python upgrade Closed
100%
Task Description

Pacman recently upgraded python from 3.8 to 3.9, which breaks the gdb package:

% gdb
gdb: error while loading shared libraries: libpython3.8.so.1.0: cannot open shared object file: No such file or directory
 118 PackagesBug ReportVery LowMedium signing key is expired Closed
100%
Task Description

When trying to install the package, packman complies about the the key to be of unknown trust. Cheking the keyring the associated key appers to be expired.

117PackagesBug ReportVery LowLowvboxdrive module missingNew
0%
Task Description

vboxdrv module is missing making virtualbox unusable.

I’m currently running kernel 5.9.0-1.0-pae but it doesn’t seem to be there in any version

116PackagesBug ReportMediumLowRace causes iptables not to be ready after startupNew
0%
Task Description

Nov 06 08:04:01 eurohp1 systemd[1]: Starting IPv4 Packet Filtering Framework… Nov 06 08:04:01 eurohp1 iptables-restore[287]: Another app is currently holding the xtables lock. Perhap>
Nov 06 08:04:01 eurohp1 systemd[1]: iptables.service: Main process exited, code=exited, status=4/NOPERMI>
Nov 06 08:04:01 eurohp1 systemd[1]: iptables.service: Failed with result ‘exit-code’.
Nov 06 08:04:01 eurohp1 systemd[1]: Failed to start IPv4 Packet Filtering Framework.

Works when starting iptables later manually.

This is security relevant as not having a firewall after startup puts the system at risk.

 115 PackagesBug ReportMediumLow gnome doesn't start Closed
100%
Task Description

gnome-shell segfaults in libmutter.

                                                               Stack trace of thread 1009:
                                                               #0  0x00000000b64d5436 n/a (libmutter-cogl-6.so.0 + 0xe436)
                                                               #1  0x00000000b64d809c n/a (libmutter-cogl-6.so.0 + 0x1109c)
                                                               #2  0x00000000b653edb9 n/a (libmutter-cogl-6.so.0 + 0x77db9)
                                                               #3  0x00000000b64f8fc5 cogl_flush (libmutter-cogl-6.so.0 + 0x31fc5)
                                                               #4  0x00000000b6549154 cogl_onscreen_swap_buffers_with_damage (libmutter-cogl-6.so.0 + 0x82154)
                                                               #5  0x00000000b6c59f73 n/a (libmutter-clutter-6.so.0 + 0x10ff73)
                                                               #6  0x00000000b6c53cf2 n/a (libmutter-clutter-6.so.0 + 0x109cf2)
                                                               #7  0x00000000b6c54747 n/a (libmutter-clutter-6.so.0 + 0x10a747)
                                                               #8  0x00000000b6bf52ad n/a (libmutter-clutter-6.so.0 + 0xab2ad)
                                                               #9  0x00000000b7703bde g_main_context_dispatch (libglib-2.0.so.0 + 0x4dbde)
                                                               #10 0x00000000b7752962 n/a (libglib-2.0.so.0 + 0x9c962)
                                                               #11 0x00000000b7702299 g_main_loop_run (libglib-2.0.so.0 + 0x4c299)
                                                               #12 0x00000000b697f216 meta_run (libmutter-6.so.0 + 0xb9216)
                                                               #13 0x000000000043144e n/a (gnome-shell + 0x244e)
                                                               #14 0x00000000b7cd900e __libc_start_main (libc.so.6 + 0x1f00e)
                                                               #15 0x0000000000431635 n/a (gnome-shell + 0x2635)
 114 Packages: StableBug ReportVery LowMedium Kmail: symbol lookup error Closed
100%
Task Description

Kmail 20.08.1-1.0 fails to start with symbol lookup error.

Steps to reproduce: invoking kmail on the console shows:

kmail: symbol lookup error: /usr/lib/libKF5MailImporter.so.5: undefined symbol: _ZN9PimCommon15CustomLogWidgetC1EP7QWidget

Downgrading messagelib fixes this issue but generates other issues (missing files or other undefined symbols).

After all I didn’t find a solution.

 113 PackagesBug ReportVery LowLow [leafpad]: segfaults Closed
100%
Task Description

start leafpad
everything looks fine
type or paste anything and it segfaults with this error in dmesg

leafpad[550]: segfault at 1 ip b77adf13 sp bfd0eaec error 4 in libgobject-2.0.so.0.6400.3[b7787000+2f000]
 112 PackagesBug ReportVery LowLow [lxpanel]: segfaults on startup Closed
100%
Task Description

# pacman -Sy lxde
reboot and start lxsession
lxpanel will crash immediately, with this error in dmesg

pcmanfm[501]: segfault at 2d ip b74823cf sp bf9dd0d0 error 4 in libpango-1.0.so.0.4600.0[b7466000+29000]

lxpanel does not have this problem with GTK3
# pacman -Sy lxde-gtk3
works as expectd

 111 PackagesBug ReportVery LowHigh [libxcrypt]: conflicts with glibc Closed
100%
Task Description
# pacman -Syu
....
error: failed to commit transaction (conflicting files)
libxcrypt: /usr/include/crypt.h exists in filesystem (owned by glibc)
libxcrypt: /usr/lib/libcrypt.so exists in filesystem (owned by glibc)
Errors occurred, no packages were upgraded.

this is a rather critical bug - it is required by gtk and qt, via libcups; so most desktop users are affected by it

 110 PackagesBug ReportVery LowLow [syslog-ng] is built without systemd support Closed
100%
Task Description

The packages for syslog-ng since version 3.27.1-1.0 appears to have been built without systemd support. Although their PKGBUILD runs configure with –enable-systemd, running syslog-ng –version shows Enable-Systemd: off. The official Arch x86_64 package (at version 3.28.1-1) doesn’t exhibit this problem.

I tried building the package locally on i686 using the official Arch PKGBUILD and could not reproduce the problem. My locally built version correctly finds libsystemd during configure, and gets built with systemd support. This leads me to believe the problem happens somewhere in the Archlinux32 build process.


The practical upshot of the problem is that the systemd unit file supplied with syslog-ng lists it as a Type=notify service, but when it fails to notify systemd after startup, systemd eventually kills it and restarts it repeatedly:

Jul 24 07:32:31 wolfie systemd[1]: Starting System Logger Daemon "default" instance...
Jul 24 07:32:32 wolfie syslog-ng[18977]: syslog-ng starting up; version='3.28.1'
Jul 24 07:34:01 wolfie systemd[1]: syslog-ng@default.service: start operation timed out. Terminating.
Jul 24 07:34:01 wolfie syslog-ng[18977]: syslog-ng shutting down; version='3.28.1'
Jul 24 07:34:01 wolfie systemd[1]: syslog-ng@default.service: Failed with result 'timeout'.
Jul 24 07:34:01 wolfie systemd[1]: Failed to start System Logger Daemon "default" instance.
Jul 24 07:34:02 wolfie systemd[1]: syslog-ng@default.service: Scheduled restart job, restart counter is at 1.
Jul 24 07:34:02 wolfie systemd[1]: Stopped System Logger Daemon "default" instance.
Jul 24 07:34:02 wolfie systemd[1]: Starting System Logger Daemon "default" instance...
109PackagesBug ReportMediumLowgcc10 -fno-common breaks jdkNew
0%
Task Description

/usr/bin/ld: /build/java-openjdk/src/jdk14u-jdk-14.0.1+7/build/linux-x86-server-release/support/native/java.base/libjava/childproc.o:/build/java-openjdk/src/jdk14u-jdk-14.0.1+7/src/java.base/unix/native/libjava/childproc.h:129: multiple definition of `parentPathv’; /build/java-openjdk/src/jdk14u-jdk-14.0.1+7/build/linux-x86-server-release/support/native/java.base/libjava/ProcessImpl_md.o:/build/java-openjdk/src/jdk14u-jdk-14.0.1+7/src/java.base/unix/native/libjava/childproc.h:129: first defined here

collect2: error: ld returned 1 exit status

This is fixed known and fixed upstream (without just setting
-fcommon again):

https://bugs.openjdk.java.net/browse/JDK-8235903

108Packages: StagingBug ReportVery LowHighlldb fails to run any binary (error: failed to launch o...Unconfirmed
0%
Task Description

Very easy to reproduce. lldb version 10.0.0, just try to run any binary.

[aeden@arch32 bin]$ lldb $(which date)
(lldb) target create “/usr/bin/date” Current executable set to ‘/usr/bin/date’ (i386).
(lldb) run
error: failed to launch or debug process
(lldb)

 107 PackagesBug ReportVery LowLow wireguard-dkms-0.0.20200318-1.0 does not build with 5.5 ...Closed
100%
Task Description

Installing wireguard-dkms fails with:

(2/2) Install DKMS modules
==> dkms install wireguard/0.0.20200318 -k 5.5.8-arch1-1.0
Error! Bad return status for module build on kernel: 5.5.8-arch1-1.0 (i686)
Consult /var/lib/dkms/wireguard/0.0.20200318/build/make.log for more information.

The file /var/lib/dkms/wireguard/0.0.20200318/build/make.log contains the following messages:

DKMS make.log for wireguard-0.0.20200318 for kernel 5.5.8-arch1-1.0 (i686)
Fri 03 Apr 2020 10:11:21 PM CEST
make: Entering directory '/usr/lib/modules/5.5.8-arch1-1.0/build'
  AR      /var/lib/dkms/wireguard/0.0.20200318/build/built-in.a
  CC [M]  /var/lib/dkms/wireguard/0.0.20200318/build/main.o
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/structleak_plugin.so
make[1]: *** [scripts/Makefile.build:266: /var/lib/dkms/wireguard/0.0.20200318/build/main.o] Error 1
make: *** [Makefile:1693: /var/lib/dkms/wireguard/0.0.20200318/build] Error 2
make: Leaving directory '/usr/lib/modules/5.5.8-arch1-1.0/build'
 106 PackagesBug ReportMediumLow packages are unstripped? Closed
100%
Task Description

looks, like the new devtools do not strip packages anymore - maybe it was only an intermediate version, that lacked automatic stripping.

 105 Packages: StableBug ReportMediumLow chromium crash in blocked syscalls (libseccomp) Closed
100%
Task Description

chromium apparently also has trouble in some seccomp jailing:

 ../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
[1201:1210:0227/131355.020958:FATAL:gpu_data_manager_impl_private.cc(990)] The display compositor is frequently crashing. Goodbye.

[1]+  Trace/breakpoint trap   (core dumped) chromium
 104 PackagesBug ReportMediumHigh [glibc] 2.31-1.0 broken Closed
100%
Task Description

Real machines (i686) break apart in mutliple ways: systemd-journald fails to start, also udev seems to have trouble. This leaves one with a rescue console. And at least in my rescue console, my keyboard did not work.
I also have a pentium4 vm which won’t boot currently (I might give some details, when I have a little more time).

103Packages: StableBug ReportMediumLowyarn segfaultsNew
0%
Task Description

experienced when building buildbot-www

/bin/sh: line 1: 4744 Segmentation fault (core dumped) yarn install –pure-lockfile

 102 Packages: StableBug ReportMediumLow firefox-i18-n gets pushed to stable though firefox is n ...Closed
100%
Task Description

warning: cannot resolve “firefox>=71.0”, a dependency of “firefox-i18n-de”

 101 Packages: StableBug ReportMediumLow clang 9.0.0 moved to stable too soon (breaks kdevelop) Closed
100%
Task Description

:: installing clang (9.0.1-1.0) breaks dependency ‘clang=9.0.0’ required by kdevelop

100Packages: StableBug ReportVery LowLowmldonkey crashesUnconfirmed
0%
Task Description

All versions of mldonkey crash in arch32 updated. (segmentation fault and core dumped)

 99 Packages: StableBug ReportMediumLow Incompatible Qt library (version 0x50d02) with this lib ...Closed
100%
Task Description

Seen with trojita:
Cannot mix incompatible Qt library (version 0x50d02) with this library (version 0x50d01)

 98 Packages: TestingBug ReportMediumLow swap encryption fails Closed
100%
Task Description

I tried to get encrypted swap following the guide in the wiki.

However, ultimately,

/usr/lib/systemd/systemd-cryptsetup attach 'swap' '/dev/disk/by-uuid/13b0e159-8573-40f8-a308-b34f1bbf1a6f' '/dev/urandom' 'swap,offset=2048'

fails, which works on upstream archlinux. It gives:

Set cipher aes, mode cbc-essiv:sha256, key size 256 bits for device /dev/disk/by-uuid/13b0e159-8573-40f8-a308-b34f1bbf1a6f.
device-mapper: reload ioctl on   failed: No such file or directory
Failed to activate with key file '/dev/urandom'. (Key file missing?)
Please enter passphrase for disk Ultra_Line (swap): 
Loading of cryptographic parameters failed: Invalid argument

In the middle, it asks for a passphrase. On archlinux, the output is:

Set cipher aes, mode cbc-essiv:sha256, key size 256 bits for device /dev/loop0.

are we missing ciphers here somewhere (where?)?

As usual (for my boxes), everything is up-to-date on that machine:
cryptsetup 2.2.2-1.0
linux 5.1.15.arch1-1.0
systemd 243.162-2.0

Cheers,
Erich

 97 Packages: StableBug ReportVery LowLow mesa-vdpau /usr/lib/dri/r300_dri.so links to wrong libL ...Closed
100%
Task Description
grep LLVM /var/log/Xorg.0.log
[    29.423] (EE) AIGLX error: dlopen of /usr/lib/dri/r300_dri.so failed (libLLVM-8.so: cannot open shared object file: No such file or directory)
[    29.424] (EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed (libLLVM-8.so: cannot open shared object file: No such file or directory)
ldd /usr/lib/dri/r300_dri.so 
        linux-gate.so.1 (0xb7f26000)
        libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb6836000)
        libLLVM-8.so => not found
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb680a000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0xb6804000)
        libsensors.so.5 => /usr/lib/libsensors.so.5 (0xb67f3000)
        libdrm_radeon.so.1 => /usr/lib/libdrm_radeon.so.1 (0xb67e4000)
        libelf.so.1 => /usr/lib/libelf.so.1 (0xb67c6000)
        libdrm_amdgpu.so.1 => /usr/lib/libdrm_amdgpu.so.1 (0xb67b9000)
        libdrm_nouveau.so.2 => /usr/lib/libdrm_nouveau.so.2 (0xb67ae000)
        libglapi.so.0 => /usr/lib/libglapi.so.0 (0xb678d000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb6773000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6595000)
        libm.so.6 => /usr/lib/libm.so.6 (0xb64c3000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb64a6000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0xb6483000)
        libc.so.6 => /usr/lib/libc.so.6 (0xb62d3000)
        /usr/lib/ld-linux.so.2 (0xb7f27000)
ls /usr/lib/libLLVM*
/usr/lib/libLLVM-9.0.0.so  /usr/lib/libLLVM-9.so  /usr/lib/libLLVM.so
Showing tasks 201 - 250 of 345 Page 5 of 7<<First - 3 - 4 - 5 - 6 - 7 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing