Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategoryTask TypePrioritySeveritySummaryStatusProgress  desc
 72 Packages: StableBug ReportMediumLow [mpd] icu version mismatch Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by bill auger - 13.05.2019
Last edited by Andreas Baumann - 28.08.2019
 FS#72  - [mpd] icu version mismatch

$ mpd
mpd: error while loading shared libraries: libicui18n.so.63: cannot open shared object file: No such file or directory

Closed by Andreas Baumann
28.08.2019 16:59
Reason for closing: Fixed
Additional comments about closing:

works for me after the rebuild.

  Comments (2)
  Related Tasks (0/0)

Levi commented on 13.05.2019 20:33

This also affects libreoffice from libreoffice-stable. Run it from a terminal and the splash screen briefly loads before closing, and it spits out to STDERR:
[quote]usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libicuuc.so.63: cannot open shared object file: No such file or directory[/quote]

My icu package is currently at version 64.2-1.0 and from the core repo (nothing in testing, apparently). I’m currently on the pentium4 binary branch, by the way, but I think this issue affects us all at present.

I suspect if the maintainer just rebuilds libreoffice-stable and mpd with icu 64.2 in the environment it may resolve this. Looking at the libreoffice web site, version 6.1.6 is already available for download, while I still have 6.1.5 installed and there’s nothing in the download tubes just yet. Although 6.1.5 is still available on libreoffices download page along with 6.1.6 and 6.2.3, so maybe we don’t get the upgrade till 6.1.5 expires, I’ve not checked before. I also can’t find when anything libreoffice produces got released; their release notes don’t express patch levels and they don’t expose their download folder for my perusal. I did manage to find their announcements for what becomes libreoffice-fresh on their twitter feed, but they only announce the fresh releases there. Presumably 6.1.6 got released following 6.2.3, since presumably it fixes the same bugs backported though.
Admin
Andreas Baumann commented on 28.08.2019 16:58

Should be solved with rebuilding libreoffice, mpd etc.

Google Cache

 73 PackagesBug ReportMediumLow [gajim] fails to launch when (optional) gupnp-igd is in ...Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by bill auger - 13.05.2019
Last edited by Andreas Baumann - 02.10.2019
 FS#73  - [gajim] fails to launch when (optional) gupnp-igd is installed

$ gajim
No translations found
Dirs searched: [PosixPath(’/usr/local/share’), PosixPath(’/usr/share’), PosixPath(’/usr/share/gdm’), PosixPath(’/var/lib/menu-xdg’)]

(gajim:1588): dbind-WARNING : 15:14:29.481: Couldn’t connect to accessibility bus: Failed to connect to socket /tmp/dbus-Nv1LTXmb8O: Connection refused (gajim:1588): WARNING **: 15:14:29.534: Failed to load shared library ‘libgupnp-igd-1.0.so.4’ referenced by the typelib: libgupnp-1.2.so.0: cannot open shared object file: No such file or directory
/usr/lib/python3.7/site-packages/gajim/common/app.py:281: Warning: cannot retrieve class for invalid (unclassed) type ‘void’

gupnp_igd = GUPnPIgd.SimpleIgd()

Traceback (most recent call last):

File "/usr/lib/python3.7/site-packages/gajim/application.py", line 185, in _startup
  app.detect_dependencies()
File "/usr/lib/python3.7/site-packages/gajim/common/app.py", line 281, in detect_dependencies
  gupnp_igd = GUPnPIgd.SimpleIgd()

TypeError: could not get a reference to type class
Traceback (most recent call last):

File "/usr/lib/python3.7/site-packages/gajim/application.py", line 220, in _activate
  self.interface = Interface()
File "/usr/lib/python3.7/site-packages/gajim/gui_interface.py", line 2615, in __init__
  cfg_was_read = parser.read()
File "/usr/lib/python3.7/site-packages/gajim/common/optparser.py", line 86, in read
  self.update_config(old_version, new_version)
File "/usr/lib/python3.7/site-packages/gajim/common/optparser.py", line 158, in update_config
  caps_cache.capscache.initialize_from_db()

AttributeError: ‘NoneType’ object has no attribute ‘initialize_from_db’ Traceback (most recent call last):

File "/usr/lib/python3.7/site-packages/gajim/application.py", line 269, in do_shutdown
  app.logger.commit()

AttributeError: ‘NoneType’ object has no attribute ‘commit’

Closed by Andreas Baumann
02.10.2019 19:36
Reason for closing: Fixed
Additional comments about closing:

Seems to work on pentium4/stable. Feel free to reopen if you it crashes
for you..

Google Cache

 74 Packages: StableBug ReportMediumLow webkit2gtk requires SSE2 Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 16.05.2019
 FS#74  - webkit2gtk requires SSE2

– Performing Test HAVE_SSE2_EXTENSIONS
– Performing Test HAVE_SSE2_EXTENSIONS - Failed
CMake Error at CMakeLists.txt:115 (message):

SSE2 support is required to compile WebKit

not quite clear yet, what happens, if it gets disabled forcefully..

  Comments (5)
  Related Tasks (0/0)

Admin
Andreas Baumann commented on 16.05.2019 18:43

Let’s see, what happens if we just comment out the SSE2 test in CMakeLists.txt.. :-) Admin
Andreas Baumann commented on 17.05.2019 11:54

Rebuilding runs in issues like:

make[2]: *** No rule to make target ‘JavaScriptCore-4.0.gir’, needed by ‘WebKit2-4.0.gir’. Stop.

Using in ‘build’ make JavaScriptCore-4-gir VERBOSE=1 reveils the true nature of the bug:

/usr/lib/gcc/i686-pc-linux-gnu/8.3.0/include/stddef.h:435: syntax error, unexpected identifier in ' float128 max_align_f128 attribute1)));’ at ‘__float128’

So again, the 128-bit alignment hack in glibc spreading everywhere.
Admin
Andreas Baumann commented on 17.05.2019 11:56

Also the make error sounds suspicious, like cmake/make generated files are not really tested.
Admin
Andreas Baumann commented on 17.05.2019 11:59

The 128-alignment issue is hopefully just a warning..
Admin
Andreas Baumann commented on 17.05.2019 12:55

patched build in the queue..

Google Cache

1) aligned(alignof(float128
 75 Packages: Build-listBug ReportMediumLow openjdk8/10/11/12 break with march=pentium4 optimizatio ...Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 18.05.2019
Last edited by Andreas Baumann - 16.08.2019
 FS#75  - openjdk8/10/11/12 break with march=pentium4 optimization

This blocks ant, needed for building libreoffice.
Closed by Andreas Baumann
16.08.2019 13:55
Reason for closing: Fixed
Additional comments about closing:

fixed for 8, 10, 11 and 12. Not for 7.

  Comments (34)
  Related Tasks (0/0)

Admin
Andreas Baumann commented on 18.05.2019 18:18

mmh. java is fine.

java -version
openjdk version “1.8.0_212” OpenJDK Runtime Environment (build 1.8.0_212-b01)
OpenJDK Server VM (build 25.212-b01, mixed mode)

javac
#
# A fatal error has been detected by the Java Runtime Environment:
#
# Internal Error (os_linux_x86.cpp:291), pid=124, tid=0xf6dc1b40
# fatal error: An irrecoverable SI_KERNEL SIGSEGV has occurred due to unstable signal handling in this distribution.
#
# JRE version: OpenJDK Runtime Environment (8.0_212-b01) (build 1.8.0_212-b01)
# Java VM: OpenJDK Server VM (25.212-b01 mixed mode linux-x86 )
# Core dump written. Default location: /build/libreoffice-still/core or core.124
#
# An error report file with more information is saved as:
# /build/libreoffice-still/hs_err_pid124.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp #
Aborted (core dumped)

ant
#
# A fatal error has been detected by the Java Runtime Environment:
#
# Internal Error (os_linux_x86.cpp:291), pid=155, tid=0xf6d4fb40
# fatal error: An irrecoverable SI_KERNEL SIGSEGV has occurred due to unstable signal handling in this distribution.
#
# JRE version: OpenJDK Runtime Environment (8.0_212-b01) (build 1.8.0_212-b01)
# Java VM: OpenJDK Server VM (25.212-b01 mixed mode linux-x86 )
# Core dump written. Default location: /build/libreoffice-still/core or core.155
#
# An error report file with more information is saved as:
# /build/libreoffice-still/hs_err_pid155.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp #
Aborted (core dumped)

Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
V [libjvm.so+0x897c76]
V [libjvm.so+0x36392a]
V [libjvm.so+0x71341f] JVM_handle_linux_signal+0x6bf
V [libjvm.so+0x70507f]
C [linux-gate.so.1+0×950] __kernel_rt_sigreturn+0×0

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j java.lang.System.nanoTime()J+0
j java.net.URLClassLoader.defineClass(Ljava/lang/String;Lsun/misc/Resource;)Ljava/lang/Class;+0
j java.net.URLClassLoader.access$100(Ljava/net/URLClassLoader;Ljava/lang/String;Lsun/misc/Resource;)Ljava/lang/Class;+3
j java.net.URLClassLoader$1.run()Ljava/lang/Class;+43
j java.net.URLClassLoader$1.run()Ljava/lang/Object;+1
v ~StubRoutines::call_stub
j java.security.AccessController.doPrivileged(Ljava/security/PrivilegedExceptionAction;Ljava/security/AccessControlContext;)Ljava/lang/Object;+0
j java.net.URLClassLoader.findClass(Ljava/lang/String;)Ljava/lang/Class;+13
j java.lang.ClassLoader.loadClass(Ljava/lang/String;Z)Ljava/lang/Class;+70
j sun.misc.Launcher$AppClassLoader.loadClass(Ljava/lang/String;Z)Ljava/lang/Class;+81
j java.lang.ClassLoader.loadClass(Ljava/lang/String;)Ljava/lang/Class;+3
v ~StubRoutines::call_stub
j com.sun.tools.javac.main.Main.(Ljava/lang/String;Ljava/io/PrintWriter;)V+5
j com.sun.tools.javac.main.Main.(Ljava/lang/String;)V+13
j com.sun.tools.javac.Main.compile([Ljava/lang/String;)I+6
j com.sun.tools.javac.Main.main([Ljava/lang/String;)V+1
v ~StubRoutines::call_stub
Admin
Andreas Baumann commented on 18.05.2019 18:19

well. Java errors, hard to debug..
Admin
Andreas Baumann commented on 18.05.2019 18:21

Installing the i686 version in the pentium4 chroot also segfaults..
Admin
Andreas Baumann commented on 18.05.2019 18:25

Java 686 doesn’t segfault on a real i686 installed system. So, I fear, some library in pentium4
is causing java to segfault.
Admin
Andreas Baumann commented on 18.05.2019 18:36

Event: 0.057 Thread 0xf6b07c00 Exception <a> (0xd7b86ea0) thrown at [/build/java8-openjdk/src/jdk8u-jdk8u212-b01/hotspot/src/share/vm/prims/jni.cp
Event: 0.057 Thread 0xf6b07c00 Exception </a><a> (0xd7b87170) thrown at [/build/java8-openjdk/src/jdk8u-jdk8u212-b01/hotspot/src/share/vm/prims/jni.cpp, line 4012]
Event: 0.231 Thread 0xf6b07c00 Exception </a><a> (0xd7cc0498) thrown at [/build/java8-openjdk/src/jdk8u-jdk8u212-b01/hotspot/src/share/vm/prims/jvm.cpp, line 1502]

mmh. this sounds quite internal..
</a>
Admin
Andreas Baumann commented on 18.05.2019 18:50

pentium$:
javac -version
javac 11.0.3

why is libreoffice built with java 8?
Admin
Andreas Baumann commented on 18.05.2019 19:00

weird: on my pentium4 test machine with jdk 8 and 11 installed, I can switch to java 8
and everything is fine.
Admin
Andreas Baumann commented on 18.05.2019 19:03

I remember issues with shared libraries and the way the Jvm is bootstrapping. For
instance not having a /proc causes trouble of this sort. But we have a /proc
(we are using arch-chroot and a bind mount point).
Admin
Andreas Baumann commented on 18.05.2019 19:07

using java 11 and javac 11 on pentium4 works..
Admin
Andreas Baumann commented on 18.05.2019 19:08

..and now we get to “find the 10 differences in this picture”. :-) Admin
Andreas Baumann commented on 18.05.2019 19:14

The only thing I can think of is a different kernel (with more protection enabled):

https://bugs.openjdk.java.net/browse/JDK-8023956 https://bugs.openjdk.java.net/browse/JDK-8181068

This cries for building it on a real Pentium4 or on a properly emulated one, not
in a chroot.
Admin
Erich Eckner commented on 22.05.2019 04:34

&gt; using java 11 and javac 11 on pentium4 works..

why not simply pin the java version to 11, then?
Admin
Andreas Baumann commented on 06.06.2019 18:19

When installing the i686 version of glibc and openjdk8 there is no segfault!
So this sounds more like a new glibc and optimization triggering something in java..
Admin
Andreas Baumann commented on 07.06.2019 16:54

Actually also original SUN java 7 segfaults with this glibc.
Rebuilding glibc didn’t help. So I’m pretty sure it’s some protection thingy
getting into the way of old Java JDKs (because they always pushed their limits
and did funny tricks in the past).
Luke commented on 18.06.2019 18:27

Erich Eckner,
Ant is still broken with pentium4 build of java 11 (i686 works).

$ archlinux-java status
Available Java environments:

java-11-openjdk (default)

Admin
Andreas Baumann commented on 19.06.2019 17:57

19:40 &lt; slacka123&gt; should use “-march=i686 -msse2 -mtune=generic -mfpmath=sse -mstackrealign” instead?
19:54 &lt; slacka123&gt; Yes, it does - https://bugs.documentfoundation.org/show_bug.cgi?id=108619
19:54 &lt; phrik&gt; Title: 108619 – (32bitjavacrash) Java Crash on x86 in jfw_plugin_startJavaVirtualMachine

             w/ recent linux kernels (at bugs.documentfoundation.org)

19:55 &lt; slacka123&gt; Fedora 30 also needs that kernel parameter, “stack_guard_gap=1” to run/build

                 LibreOffice and other java apps

… 19:56 &lt; slacka123&gt; but i686 arch32 also needs it

from the chat protocol: https://mirror.archlinux32.org/irc-logs/%23archlinux32/2019-06-19.html#19:39:59 Admin
Andreas Baumann commented on 21.06.2019 08:29

See: https://src.fedoraproject.org/rpms/glibc/blob/master/f/glibc.spec Admin
Andreas Baumann commented on 21.06.2019 12:23

Thanks slacka123 for the hint. This seems to solve the java/javac crashes.

It’s fixed now in staging and will soon hop into testing.
Admin
Andreas Baumann commented on 11.08.2019 06:03

The segfaults persist through all pentium4 versions of the openjdk.
Additionally now also the 7 version of i686 and pentium4 are segfaulting.
Admin
Andreas Baumann commented on 11.08.2019 07:11

jkd7 also cannot find libattr:

https://patchwork.openembedded.org/patch/110857/ Admin
Andreas Baumann commented on 11.08.2019 07:13

On 64-bit it complains about ant:

error: target not found: apache-ant&gt;=1.8.1

flagged out-of-date upstream, unusable currently for bootstrapping.
Admin
Andreas Baumann commented on 11.08.2019 07:56

https://bugs.archlinux.org/task/63430 Admin
Andreas Baumann commented on 11.08.2019 07:56

configure: Found potential Boot JDK using java© in PATH
configure: Potential Boot JDK found at /usr/lib/jvm/java-8-openjdk is incorrect JDK version (#); ignoring
configure: (Your Boot JDK must be version 7 or 8)
configure: Found potential Boot JDK using well-known locations (in /usr/lib/jvm/java-8-openjdk)
configure: Potential Boot JDK found at /usr/lib/jvm/java-8-openjdk is incorrect JDK version (#); ignoring
configure: (Your Boot JDK must be version 7 or 8)
configure: Found potential Boot JDK using well-known locations (in /usr/lib/jvm/default-runtime)
configure: Potential Boot JDK found at /usr/lib/jvm/default-runtime is incorrect JDK version (#); ignoring
configure: (Your Boot JDK must be version 7 or 8)
configure: Found potential Boot JDK using well-known locations (in /usr/lib/jvm/default)
configure: Potential Boot JDK found at /usr/lib/jvm/default is incorrect JDK version (#); ignoring
configure: (Your Boot JDK must be version 7 or 8)
configure: Could not find a valid Boot JDK.
configure: This might be fixed by explicitely setting –with-boot-jdk
configure: error: Cannot continue
configure exiting with result code 1
Admin
Andreas Baumann commented on 11.08.2019 18:02

building on i686 (where openjdk8 still works) and using makepkg.conf with pentium4
cflags gives a package with wrong architecture though, but running in a pentium4
chroot if installed.

Though when I try to rebuild it with the ‘cross-compiled’ package in a pentium4
chroot, I get:

checking headful support… include support for both headful and headless
configure: Found potential Boot JDK using configure arguments
configure: Potential Boot JDK found at /usr/lib/jvm/java-8-openjdk is incorrect JDK version (#); ignoring
configure: (Your Boot JDK must be version 7 or 8)
configure: error: The path given by –with-boot-jdk does not contain a valid Boot JDK configure exiting with result code 1

Inside I have a hs_err_pid3361.log showing again the darn SI_KERNEL SIGSEGV.

This problem is over my head (and skills).
Admin
Andreas Baumann commented on 12.08.2019 15:26

This sounds interesting:

https://icedtea.classpath.org/bugzilla/show_bug.cgi?id=3533

related question: is -march=pentium4 changing the stack layout?
Admin
Andreas Baumann commented on 12.08.2019 15:28

Should we force stack alignment globally for all libraries which could potentially be
called from java with -mstack-alignment=16? This could break havock on other software..
Admin
Andreas Baumann commented on 12.08.2019 15:28

Also interesting:

https://icedtea.classpath.org/bugzilla/show_bug.cgi?id=3533 Admin
Andreas Baumann commented on 12.08.2019 15:30

Also: -mincoming-stack-boundary=2

https://bugs.gentoo.org/attachment.cgi?id=522650&amp;action=diff Admin
Andreas Baumann commented on 12.08.2019 16:00

So -mstackrealign in the glibc flags helps to realign the stack, so that 4 and 16 byte stacks
can coexist, but Java generates it’s own executable code, which doesn’t respect that?
Why should -mincoming-stack-boundary=2 help then?
I’ll test again a double compilation via working i686 chroot to pentium4 (with -mincoming-stack-boundary=2 in the PKGBUILD of java8-openjdk), then see if it can rebuild itself in a pentium4
chroot.
Admin
Andreas Baumann commented on 13.08.2019 04:48

Apparently this helps, thanks to the Gentoo guys. :-) Admin
Andreas Baumann commented on 13.08.2019 05:05

Now to jdk10, jdk11 and jdk12 (weirdly enough there is no jdk9?).
Admin
Andreas Baumann commented on 15.08.2019 07:32

a working JDK8 for pentium4 hit staging. now for the other versions..
Admin
Andreas Baumann commented on 15.08.2019 11:40

This helps against GOT/PLT errors:

if test ${CARCH} = i686 -o ${CARCH} = pentium4; then
  echo "Removing '-fno-plt' from CFLAGS and CXXFLAGS to prevent build fail with th
  _CFLAGS=${CFLAGS/-fno-plt/}
  _CXXFLAGS=${CXXFLAGS/-fno-plt/}
fi

Admin
Andreas Baumann commented on 15.08.2019 12:03

Finished building targets ‘images docs’ in configuration ‘linux-x86-normal-server-release’ find: &lt;80&gt;&lt;98&gt;../jdk10u-jdk-10.0.2+13/build/linux-i386-normal-server-release/images&lt;80&gt;&lt;99&gt;: No such file or directory
ESC[1mESC[31m==&gt; ERROR:ESC[m^OESC[1m A failure occurred in build().ESC[m^O
ESC[1m Aborting…ESC[m^O
==&gt; ERROR: Build failed, check /var/lib/archbuild/staging-i686/abaumann/build
(END)

needs:

case “${CARCH}” in

x86_64) _JARCH='x86_64';;
i486|i686|pentium4)   _JARCH='x86';;

esac

Google Cache

 76 Packages: StableBug ReportMediumLow libreoffice-fresh needs to be rebuild against icu Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Raphael Scholer - 25.05.2019
 FS#76  - libreoffice-fresh needs to be rebuild against icu

  Comments (1)
  Related Tasks (0/0)

Levi commented on 25.05.2019 18:22

This bug is already captured 90% by https://bugs.archlinux32.org/index.php?do=details&amp;task_id=72 (see my comment underneath it), although to be fair I noted it against libreoffice-stable since that’s what I use.

Google Cache

 77 Packages: Build-listBug ReportMediumLow librsvg doesn't rebuild Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 30.05.2019
 FS#77  - librsvg doesn’t rebuild

  1. -&gt; /build/librsvg/src/librsvg/target/release/build/typenum-ff577e94a786118f/out/consts.rs:2113:5

|
2111 | pub type P1024 = PInt; pub type N1024 = NInt;

   |     ----------------------------- previous definition of the type `P1024` here

2112 | pub type U1024 = UInt, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;;
2113 | pub type P1024 = PInt; pub type N1024 = NInt;

   |     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ `P1024` redefined here
   |
   = note: `P1024` must be defined only once in the type namespace of this module

error[E0428]: the name `N1024` is defined multiple times

  1. -&gt; /build/librsvg/src/librsvg/target/release/build/typenum-ff577e94a786118f/out/consts.rs:2113:35

|
2111 | pub type P1024 = PInt; pub type N1024 = NInt;

   |                                   ----------------------------- previous definition of the type `N1024` here

2112 | pub type U1024 = UInt, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;, B0&gt;;
2113 | pub type P1024 = PInt; pub type N1024 = NInt;

   |                                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ `N1024` redefined here
   |
   = note: `N1024` must be defined only once in the type namespace of this module

error: aborting due to 3 previous errors

For more information about this error, try `rustc –explain E0428`.
error: Could not compile `typenum`.

Caused by:

process didn't exit successfully: `rustc --crate-name typenum /build/.cargo/registry/src/github.com-1ecc6299db9ec823/typenum-1.10.0/src/lib.rs --color never --crate-type lib --emit=dep-info,link -C opt-level=3 -C debuginfo=2 -C metadata=045a2ce7f5cfaab5 -C extra-filename=-045a2ce7f5cfaab5 --out-dir /build/librsvg/src/librsvg/target/release/deps -L dependency=/build/librsvg/src/librsvg/target/release/deps --cap-lints allow -C target-cpu=pentium3 -C target-feature=-sse2` (exit code: 1)

warning: build failed, waiting for other jobs to finish… error: build failed
make[2]: * [Makefile:1934: /build/librsvg/src/librsvg/target/release/librsvg_internals.a] Error 101
make[2]: Leaving directory ‘/build/librsvg/src/librsvg’ make[1]:
* [Makefile:1438: all-recursive] Error 1
make[1]: Leaving directory ‘/build/librsvg/src/librsvg’ make: *** [Makefile:931: all] Error 2

The same error with typenum as when bootstrapping rust in stage 2.

librsvg is very important as it blocks tons of other stuff (so why
again was it written in Rust?!)

I might have seen a Debian patch for it, but Debian goes a “complete
Rust micro-packaging” way, not sure whether we can apply it here?

  Comments (1)
  Related Tasks (0/0)

Levi commented on 30.05.2019 18:26

Since it looks to me like it’s redefining P1024 and N1024 the same, can’t you just eliminate one of these definitions. Sure, it makes a patch you’d have to maintain henceforth until they fix this upstream, and I don’t understand what kind of preprocessing is ending up with this particular duplication, but deleting a line is about the simplest patch you could maintain.

Google Cache

 78 Packages: StableBug ReportMediumLow The qt5 group contains packages of different versions. Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Erling Hellenäs - 05.07.2019
 FS#78  - The qt5 group contains packages of different versions.

The qt5 group contains a qt5-base which is of a later revision, 5.12.4 instead of 5.12.3. pyside2 is also of a this later revision, but I don’t use it. I guess the group should be fixed.

Workaround: I downgraded qt5-base and it is working again.

I get this error: sddm-greeter[441]: Cannot mix incompatible Qt library (version 0x50c03) with this library (version 0x50c04)
Then systemd dumps core.

Excerpt from my journal: External Link

The group definition as seen when installing the group with pacman: External Link

My architecture is i686.

I consider it critical since QT is not working.

Google Cache

 79 Packages: StableBug ReportMediumLow trojita libstdc++ ABI mismatch Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 06.07.2019
Last edited by Andreas Baumann - 11.08.2019
 FS#79  - trojita libstdc++ ABI mismatch

trojita
trojita: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.26’ not found (required by /usr/lib/libQt5WebKit.so.5)
Closed by Andreas Baumann
11.08.2019 06:01
Reason for closing: Not a bug
Additional comments about closing:

Temporary glitch, glibc got published, trojita didn’t get rebuild.

  Comments (1)
  Related Tasks (0/0)

Admin
Andreas Baumann commented on 06.07.2019 09:17

This goes into the same ABI mismatches as Qt5. The problem here is: qt5-webkit refuses
to build on machines without SSE2 currently, but glibc is supposed to be backwards compatible,
but not libstdc++).

Google Cache

 80 Packages: Build-listBug ReportMediumLow kate refuses to build due to some broken shared ... Closed
100%
Task Description

07.07.2019 -  FS#80  - kate refuses to build due to some broken shared library dependencies. /usr/bin/ld: warning: libgit2.so.27, needed by …

 81 Packages: StableBug ReportMediumLow KDE/Plasma crashes on startup (i686) Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 07.07.2019
 FS#81  - KDE/Plasma crashes on startup (i686)

Application: ksplashqml (ksplashqml), signal: Aborted
Using host libthread_db library “/usr/lib/libthread_db.so.1”.
[Current thread is 1 (Thread 0xb21d5900 (LWP 427))]

Thread 3 (Thread 0xaa75cb40 (LWP 429)):
#0 0xb4b95418 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#1 0xb4b959f7 in ?? () from /usr/lib/libglib-2.0.so.0
#2 0xb4b95be6 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3 0xb6e75ce5 in QEventDispatcherGlib::processEvents(QFlags) () from /usr/lib/libQt5Core.so.5
#4 0xb6e18ef5 in QEventLoop::exec(QFlags) () from /usr/lib/libQt5Core.so.5
#5 0xb6c5fe1a in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6 0xb66317c3 in ?? () from /usr/lib/libQt5Qml.so.5
#7 0xb6c611cc in ?? () from /usr/lib/libQt5Core.so.5
#8 0xb5e34018 in start_thread () from /usr/lib/libpthread.so.0
#9 0xb697c25a in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0xb1a18b40 (LWP 428)):
#0 0xb7f6a82d in kernel_vsyscall ()
#1 0xb6972873 in poll () from /usr/lib/libc.so.6
#2 0xb550c6ce in ?? () from /usr/lib/libxcb.so.1
#3 0xb550e864 in xcb_wait_for_event () from /usr/lib/libxcb.so.1
#4 0xb1bad3da in ?? () from /usr/lib/libQt5XcbQpa.so.5
#5 0xb6c611cc in ?? () from /usr/lib/libQt5Core.so.5
#6 0xb5e34018 in start_thread () from /usr/lib/libpthread.so.0
#7 0xb697c25a in clone () from /usr/lib/libc.so.6 Thread 1 (Thread 0xb21d5900 (LWP 427)):
[KCrash Handler]
#6 0xb7f6a82d in
kernel_vsyscall ()
#7 0xb68c4376 in raise () from /usr/lib/libc.so.6
#8 0xb68ae299 in abort () from /usr/lib/libc.so.6
#9 0xb6c1f873 in QMessageLogger::fatal(char const*, …) const () from /usr/lib/libQt5Core.so.5
#10 0xb6387c44 in QV4::Compiler::Codegen::visit(QQmlJS::AST::UiProgram*) () from /usr/lib/libQt5Qml.so.5
#11 0xb64298d6 in QJSEngine::QJSEngine(QJSEnginePrivate&amp;, QObject*) () from /usr/lib/libQt5Qml.so.5
#12 0xb6575fcd in QQmlEngine::QQmlEngine(QObject*) () from /usr/lib/libQt5Qml.so.5
#13 0xb6888bc4 in KDeclarative::QmlObjectSharedEngine::QmlObjectSharedEngine(QObject*) () from /usr/lib/libKF5Declarative.so.5
#14 0xb7f0fb00 in KQuickAddons::QuickViewSharedEngine::QuickViewSharedEngine(QWindow*) () from /usr/lib/libKF5QuickAddons.so.5
#15 0x0040a29b in ?? ()
#16 0x00408e7a in ?? ()
#17 0x004095a2 in ?? ()
#18 0x004081de in ?? ()
#19 0xb68af7b9 in __libc_start_main () from /usr/lib/libc.so.6
#20 0x004082e5 in _start ()
[Inferior 1 (process 427) detached]

Google Cache

 83 Packages: StableBug ReportMediumLow kdeinit5 is filling the systemd journal with nonsensica ...Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 13.07.2019
 FS#83  - kdeinit5 is filling the systemd journal with nonsensical messages

Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: ()
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: ()
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: ()
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: ()
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: (QUrl(”tags:/”))
Jul 13 20:12:45 arch32-stable-pentium4 kdeinit5[1037]: ()

225 root      20   0  359832 225172 224128 S  24.5  29.5   0:45.52 systemd-journal 

Upstream too? Or is it fast enough if one core is dedicated to output
nonsensical output.. :-&gt;

Google Cache

 84 PackagesBug ReportMediumLow Unknown bug FS#84 Closed
100%
Task Description

no task description

 85 Packages: StableBug ReportMediumLow [wireguard-arch] Package not being updated alongside ke ...Closed
100%
Task Description

The last update to this package was August 25, despite several new kernel builds since this. As a result, the package does not work and users must use …

 86 Packages: StableBug ReportMediumLow newsboat contains SSE2 instuctions Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 14.09.2019
Last edited by Andreas Baumann - 14.09.2019
 FS#86  - newsboat contains SSE2 instuctions

shell&gt; newsboat

Program received signal SIGILL, Illegal instruction.
0x005f5cd9 in ?? ()
=&gt; 0x005f5cd9: f2 0f 10 06 movsd (%esi),%xmm0
(gdb) bt
#0 0x005f5cd9 in ?? ()
#1 0x005f40fa in ?? ()
#2 0x005f3f3b in ?? ()
#3 0x0072e9fd in ?? ()
#4 0×00661600 in ?? ()
#5 0×00659435 in ?? ()
#6 0x0061fe88 in ?? ()
#7 0x0065770c in ?? ()
#8 0x005ea416 in ?? ()
#9 0x0044ca68 in ?? ()
#10 0xb76f9859 in __libc_start_main () from /usr/lib/libc.so.6
#11 0x0044da75 in ?? ()

This actually looks like glibc got a SSE2 infection on i686.

Google Cache

 87 PackagesBug ReportMediumLow firefox doesn't rebuild Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 21.09.2019
Last edited by Andreas Baumann - 21.09.2019
 FS#87  - firefox doesn’t rebuild

OOM when build gkrust:

patching out debug_level=2 in moz.configure/toolchain.configure

thanks BoidLinux for the hint.

  Comments (3)
  Related Tasks (0/0)

Admin
Andreas Baumann commented on 21.09.2019 17:05

A test is executed testing the generated Gecko rust library (a static library), whether
it contains references to networking functions, this fails on IA32:

https://hg.mozilla.org/mozilla-central/rev/47cd8671b12c

$(call py_action,check_binary,–target –networking $@)

Solution is just not to execute this check in config/makefiles/rust.mk
Admin
Andreas Baumann commented on 21.09.2019 17:08

187:52.88 toolkit/library/libxul.so
190:00.47 readelf: Error: Unable to seek to 0x801db328 for section headers
190:01.36 out of memory allocating 3761314508 bytes after a total of 1595923192 bytes
190:01.47 File “/build/firefox/src/firefox-69.0.1/python/mozbuild/mozbuild/action/check_binary.py”, line 361, in

=&gt; python/readelf combo reads whole generated libxul.so into memory in order to do
some ELF fidding.

190:01.48 make[4]: *** [/build/firefox/src/firefox-69.0.1/config/rules.mk:661: libxul.so] Error 1

shows us:

$(SHARED_LIBRARY): $(OBJS) $(RESFILE) $(RUST_STATIC_LIB) $(STATIC_LIBS) $(EXTRA_DEPS) $(GLOBAL_DEPS)

      $(REPORT_BUILD)

ifndef INCREMENTAL_LINKER

      $(RM) $@

endif

      $(MKSHLIB) $($@_$(OBJS_VAR_SUFFIX)) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(RUST_STATIC_LIB) $(SHARE
      $(call py_action,check_binary,--target $@)

Trying to comment that out too (the python check).
Admin
Andreas Baumann commented on 22.09.2019 07:46

Now libxul.so misses some libraries, like libmozsandbox.so, liblgpllibs.so, … The libraries exists, but most likely libxul.so cannot find them (rpath ELF fiddling?).

As a workaround I’ll set LD_LIBRARY_PATH=/usr/lib/firefox in the startup wrapper
scripts /usr/bin/firefox.

Google Cache

 88 PackagesBug ReportMediumLow Unknown Bug FS#88 Closed
100%
Task Description

no task description

 89 PackagesBug ReportMediumLow Unknown Bug FS#89 Closed
100%
Task Description

no task description

 90 PackagesBug ReportMediumLow Unknown Bug FS#90 Closed
100%
Task Description

no task description

 91 Packages: StableBug ReportMediumLow [python2]: segfault Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by bill auger - 12.10.2019
 FS#91  - [python2]: segfault

i am trying to build calibre for i686 - using the arch PKGBUILD for v3.48.0, and also the latest 4.1.0 - python2 segfults immediately in build()

possibly related to #20 https://bugs.archlinux32.org/index.php?do=details&amp;task_id=20

“line 86” below depends on the PKGBUILD - it is the command:

LANG=’en_US.UTF-8’ python2 setup.py build

$ makepkg -sr
….
==&gt; Starting build()…

*
* Running build
*

/home/auser/calibre/PKGBUILD: line 86: 7793 Segmentation fault (core dumped) LANG=’en_US.UTF-8’ python2 setup.py build
==&gt; ERROR: A failure occurred in build().

  Aborting...

$ cd src/calibre-3.48.0/
$ LANG=’en_US.UTF-8’ python2 setup.py build

*
* Running build
*

Segmentation fault (core dumped)

Google Cache

 92 PackagesBug ReportMediumLow nfs mounts with sec=krb5 fail with 'stale file handle'  ...Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Markus Schaaf - 22.10.2019
 FS#92  - nfs mounts with sec=krb5 fail with ‘stale file handle’ for everyone but root

rpc.gssd bug due to missing syscall (setgroups). See https://bugzilla.linux-nfs.org/show_bug.cgi?id=340 `journalctl –unit=rpc-gssd.service` shows:

WARNING: unable to drop supplimentary groups!
WARNING: failed to change identity: Function not implemented

Until a fixed upstream release, use
$ cat abs/packages/nfs-utils/trunk/setgroups32.patch
— nfs-utils-2.4.1/utils/gssd/gssd_proc.c.orig 2019-10-22 11:26:48.059877484 +0200
+++ nfs-utils-2.4.1/utils/gssd/gssd_proc.c 2019-10-22 11:28:03.874553996 +0200
@@ -437,7 +437,7 @@

    int res;
    /* drop list of supplimentary groups first */

- if (syscall(SYS_setgroups, 0, 0) != 0) {
+ if (syscall(SYS_setgroups32, 0, 0) != 0) {

            printerr(0, "WARNING: unable to drop supplimentary groups!");
            return errno;
    }

Google Cache

 94 Packages: TestingBug ReportMediumLow Weechat needs a rebuild Closed
100%
Task Description

Since the uprgade to python from testing, weechat has broken it’s python support, which at least knocks out the plugin I use to keep in touch with my old workmates over slack.

# weechat
|   ___       __         ______________        _____ 
|   __ |     / /___________  ____/__  /_______ __  /_
|   __ | /| / /_  _ \  _ \  /    __  __ \  __ `/  __/
|   __ |/ |/ / /  __/  __/ /___  _  / / / /_/ // /_  
|   ____/|__/  \___/\___/\____/  /_/ /_/\__,_/ \__/  
| WeeChat 2.6 [compiled on Nov 12 2019 13:06:27]
| - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
| Error: unable to load plugin "/usr/lib/weechat/plugins/python.so": libpython3.7m.so.1.0: cannot open shared object file:
| No such file or directory

Inside /usr/lib/weechat/plugins there is a file named python.so, but its not any kind of link. I expect it to be fixed up if it were to be rebuilt.

 97 Packages: StableBug ReportVery LowLow mesa-vdpau /usr/lib/dri/r300_dri.so links to wrong libL ...Closed
100%
Task Description
grep LLVM /var/log/Xorg.0.log
[    29.423] (EE) AIGLX error: dlopen of /usr/lib/dri/r300_dri.so failed (libLLVM-8.so: cannot open shared object file: No such file or directory)
[    29.424] (EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed (libLLVM-8.so: cannot open shared object file: No such file or directory)
ldd /usr/lib/dri/r300_dri.so 
        linux-gate.so.1 (0xb7f26000)
        libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb6836000)
        libLLVM-8.so => not found
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb680a000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0xb6804000)
        libsensors.so.5 => /usr/lib/libsensors.so.5 (0xb67f3000)
        libdrm_radeon.so.1 => /usr/lib/libdrm_radeon.so.1 (0xb67e4000)
        libelf.so.1 => /usr/lib/libelf.so.1 (0xb67c6000)
        libdrm_amdgpu.so.1 => /usr/lib/libdrm_amdgpu.so.1 (0xb67b9000)
        libdrm_nouveau.so.2 => /usr/lib/libdrm_nouveau.so.2 (0xb67ae000)
        libglapi.so.0 => /usr/lib/libglapi.so.0 (0xb678d000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb6773000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6595000)
        libm.so.6 => /usr/lib/libm.so.6 (0xb64c3000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb64a6000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0xb6483000)
        libc.so.6 => /usr/lib/libc.so.6 (0xb62d3000)
        /usr/lib/ld-linux.so.2 (0xb7f27000)
ls /usr/lib/libLLVM*
/usr/lib/libLLVM-9.0.0.so  /usr/lib/libLLVM-9.so  /usr/lib/libLLVM.so
 98 Packages: TestingBug ReportMediumLow swap encryption fails Closed
100%
Task Description

I tried to get encrypted swap following the guide in the wiki.

However, ultimately,

/usr/lib/systemd/systemd-cryptsetup attach 'swap' '/dev/disk/by-uuid/13b0e159-8573-40f8-a308-b34f1bbf1a6f' '/dev/urandom' 'swap,offset=2048'

fails, which works on upstream archlinux. It gives:

Set cipher aes, mode cbc-essiv:sha256, key size 256 bits for device /dev/disk/by-uuid/13b0e159-8573-40f8-a308-b34f1bbf1a6f.
device-mapper: reload ioctl on   failed: No such file or directory
Failed to activate with key file '/dev/urandom'. (Key file missing?)
Please enter passphrase for disk Ultra_Line (swap): 
Loading of cryptographic parameters failed: Invalid argument

In the middle, it asks for a passphrase. On archlinux, the output is:

Set cipher aes, mode cbc-essiv:sha256, key size 256 bits for device /dev/loop0.

are we missing ciphers here somewhere (where?)?

As usual (for my boxes), everything is up-to-date on that machine:
cryptsetup 2.2.2-1.0
linux 5.1.15.arch1-1.0
systemd 243.162-2.0

Cheers,
Erich

 99 Packages: StableBug ReportMediumLow Incompatible Qt library (version 0x50d02) with this lib ...Closed
100%
Task Description

Seen with trojita:
Cannot mix incompatible Qt library (version 0x50d02) with this library (version 0x50d01)

 101 Packages: StableBug ReportMediumLow clang 9.0.0 moved to stable too soon (breaks kdevelop) Closed
100%
Task Description

:: installing clang (9.0.1-1.0) breaks dependency ‘clang=9.0.0’ required by kdevelop

 102 Packages: StableBug ReportMediumLow firefox-i18-n gets pushed to stable though firefox is n ...Closed
100%
Task Description

warning: cannot resolve “firefox>=71.0”, a dependency of “firefox-i18n-de”

 105 Packages: StableBug ReportMediumLow chromium crash in blocked syscalls (libseccomp) Closed
100%
Task Description

chromium apparently also has trouble in some seccomp jailing:

 ../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
[1201:1210:0227/131355.020958:FATAL:gpu_data_manager_impl_private.cc(990)] The display compositor is frequently crashing. Goodbye.

[1]+  Trace/breakpoint trap   (core dumped) chromium
 106 PackagesBug ReportMediumLow packages are unstripped? Closed
100%
Task Description

looks, like the new devtools do not strip packages anymore - maybe it was only an intermediate version, that lacked automatic stripping.

 107 PackagesBug ReportVery LowLow wireguard-dkms-0.0.20200318-1.0 does not build with 5.5 ...Closed
100%
Task Description

Installing wireguard-dkms fails with:

(2/2) Install DKMS modules
==> dkms install wireguard/0.0.20200318 -k 5.5.8-arch1-1.0
Error! Bad return status for module build on kernel: 5.5.8-arch1-1.0 (i686)
Consult /var/lib/dkms/wireguard/0.0.20200318/build/make.log for more information.

The file /var/lib/dkms/wireguard/0.0.20200318/build/make.log contains the following messages:

DKMS make.log for wireguard-0.0.20200318 for kernel 5.5.8-arch1-1.0 (i686)
Fri 03 Apr 2020 10:11:21 PM CEST
make: Entering directory '/usr/lib/modules/5.5.8-arch1-1.0/build'
  AR      /var/lib/dkms/wireguard/0.0.20200318/build/built-in.a
  CC [M]  /var/lib/dkms/wireguard/0.0.20200318/build/main.o
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/structleak_plugin.so
make[1]: *** [scripts/Makefile.build:266: /var/lib/dkms/wireguard/0.0.20200318/build/main.o] Error 1
make: *** [Makefile:1693: /var/lib/dkms/wireguard/0.0.20200318/build] Error 2
make: Leaving directory '/usr/lib/modules/5.5.8-arch1-1.0/build'
 110 PackagesBug ReportVery LowLow [syslog-ng] is built without systemd support Closed
100%
Task Description

The packages for syslog-ng since version 3.27.1-1.0 appears to have been built without systemd support. Although their PKGBUILD runs configure with –enable-systemd, running syslog-ng –version shows Enable-Systemd: off. The official Arch x86_64 package (at version 3.28.1-1) doesn’t exhibit this problem.

I tried building the package locally on i686 using the official Arch PKGBUILD and could not reproduce the problem. My locally built version correctly finds libsystemd during configure, and gets built with systemd support. This leads me to believe the problem happens somewhere in the Archlinux32 build process.


The practical upshot of the problem is that the systemd unit file supplied with syslog-ng lists it as a Type=notify service, but when it fails to notify systemd after startup, systemd eventually kills it and restarts it repeatedly:

Jul 24 07:32:31 wolfie systemd[1]: Starting System Logger Daemon "default" instance...
Jul 24 07:32:32 wolfie syslog-ng[18977]: syslog-ng starting up; version='3.28.1'
Jul 24 07:34:01 wolfie systemd[1]: syslog-ng@default.service: start operation timed out. Terminating.
Jul 24 07:34:01 wolfie syslog-ng[18977]: syslog-ng shutting down; version='3.28.1'
Jul 24 07:34:01 wolfie systemd[1]: syslog-ng@default.service: Failed with result 'timeout'.
Jul 24 07:34:01 wolfie systemd[1]: Failed to start System Logger Daemon "default" instance.
Jul 24 07:34:02 wolfie systemd[1]: syslog-ng@default.service: Scheduled restart job, restart counter is at 1.
Jul 24 07:34:02 wolfie systemd[1]: Stopped System Logger Daemon "default" instance.
Jul 24 07:34:02 wolfie systemd[1]: Starting System Logger Daemon "default" instance...
 112 PackagesBug ReportVery LowLow [lxpanel]: segfaults on startup Closed
100%
Task Description

# pacman -Sy lxde
reboot and start lxsession
lxpanel will crash immediately, with this error in dmesg

pcmanfm[501]: segfault at 2d ip b74823cf sp bf9dd0d0 error 4 in libpango-1.0.so.0.4600.0[b7466000+29000]

lxpanel does not have this problem with GTK3
# pacman -Sy lxde-gtk3
works as expectd

 113 PackagesBug ReportVery LowLow [leafpad]: segfaults Closed
100%
Task Description

start leafpad
everything looks fine
type or paste anything and it segfaults with this error in dmesg

leafpad[550]: segfault at 1 ip b77adf13 sp bfd0eaec error 4 in libgobject-2.0.so.0.6400.3[b7787000+2f000]
 115 PackagesBug ReportMediumLow gnome doesn't start Closed
100%
Task Description

gnome-shell segfaults in libmutter.

                                                               Stack trace of thread 1009:
                                                               #0  0x00000000b64d5436 n/a (libmutter-cogl-6.so.0 + 0xe436)
                                                               #1  0x00000000b64d809c n/a (libmutter-cogl-6.so.0 + 0x1109c)
                                                               #2  0x00000000b653edb9 n/a (libmutter-cogl-6.so.0 + 0x77db9)
                                                               #3  0x00000000b64f8fc5 cogl_flush (libmutter-cogl-6.so.0 + 0x31fc5)
                                                               #4  0x00000000b6549154 cogl_onscreen_swap_buffers_with_damage (libmutter-cogl-6.so.0 + 0x82154)
                                                               #5  0x00000000b6c59f73 n/a (libmutter-clutter-6.so.0 + 0x10ff73)
                                                               #6  0x00000000b6c53cf2 n/a (libmutter-clutter-6.so.0 + 0x109cf2)
                                                               #7  0x00000000b6c54747 n/a (libmutter-clutter-6.so.0 + 0x10a747)
                                                               #8  0x00000000b6bf52ad n/a (libmutter-clutter-6.so.0 + 0xab2ad)
                                                               #9  0x00000000b7703bde g_main_context_dispatch (libglib-2.0.so.0 + 0x4dbde)
                                                               #10 0x00000000b7752962 n/a (libglib-2.0.so.0 + 0x9c962)
                                                               #11 0x00000000b7702299 g_main_loop_run (libglib-2.0.so.0 + 0x4c299)
                                                               #12 0x00000000b697f216 meta_run (libmutter-6.so.0 + 0xb9216)
                                                               #13 0x000000000043144e n/a (gnome-shell + 0x244e)
                                                               #14 0x00000000b7cd900e __libc_start_main (libc.so.6 + 0x1f00e)
                                                               #15 0x0000000000431635 n/a (gnome-shell + 0x2635)
 120 PackagesBug ReportVery LowLow Princeton ArchLinux32 mirror has been out of date; ques ...Closed
100%
Task Description

The ArchLinux32 mirror at http[s]://mirror.math.princeton.edu/pub/archlinux32/ appears to have stopped syncing properly in October. I contacted web@math.princeton.edu on January 1 to alert them to the problem, and received the following response from a Princeton sysadmin:


Here is the configuration I am using:
archlinux32:
   remotesrc: “rsync://mirror.archlinux32.org/archlinux32/”
   localdest: “/var/www/html/pub/archlinux32”
   extraopts: “–port=22873”
Looks like at some point this stopped working from upstream:
Raw standard error:
rsync: failed to connect to mirror.archlinux32.org (85.10.198.216): Connection refused (111)
rsync: failed to connect to mirror.archlinux32.org (2a01:4f8:a0:5264::2): Network is unreachable (101)
rsync error: error in socket IO (code 10) at clientserver.c(125) [Receiver=3.1.2]
Can you recommend a better upstream target I can use? And if there are additional constraints on checkin time or frequency.

I informed him that I am not an official member of the ArchLinux32 team, but suggested that using the regular rsync port of 873 might work as mirror.archlinux32.org appears to accept connections to that port from the Internet. As of the time of this writing, it appears that the mirror is now again up to date (although it has other issues returning HTTP error 403 for some of its files), but I promised to bring his additional questions to the official team.

So, to iterate, is this the appropriate target to mirror, or should they use some other parameters?

Thank you.

 122 PackagesBug ReportVery LowLow Permissions bits on files on the primary mirror are too ...Closed
100%
Task Description

In my quest to find a working mirror close to me, I’ve come across another issue with at least a couple of mirrors. Some mirrors respond with a HTTP 403 Forbidden for certain files, notably many of the Pacman database files. At the time of this writing, I’m aware of this problem happening with the princeton.edu and the clarkson.edu mirrors. I’ve been in contact with the admin of one of the mirrors, and they’ve pointed out that the permission bits are set to 0600 at the source. If the primary mirror could have their files be world readable, it would likely fix this problem automatically across more than one mirror.

Is that something we can do?

Steps to verify:

1. Access certain files from the primary mirror using rsync, for example:

% rsync -av rsync://mirror.archlinux32.org/archlinux32/i686/extra/extra.db.tar.gz .
receiving incremental file list
extra.db.tar.gz

sent 43 bytes  received 2,044,453 bytes  371,726.55 bytes/sec
total size is 2,043,851  speedup is 1.00

2. Examine permission bits:

% ls -l extra.db.tar.gz
-rw------- 1 user user 2043851 Jan  8 11:51 extra.db.tar.gz

Should be -rw-r–r–.

 123 PackagesBug ReportMediumLow libhandy0, libhandy conflicts Closed
100%
Task Description

libhandy0: /usr/share/vala/vapi/libhandy-0.0.deps exists in filesystem (owned by libhandy)
libhandy0: /usr/share/vala/vapi/libhandy-0.0.vapi exists in filesystem (owned by libhandy)

 124 PackagesBug ReportMediumLow mutter and gnome-shell are in confllict Closed
100%
Task Description

:: installing mutter (3.38.1-1.1) breaks dependency ‘libmutter-6.so=0-32’ required by gnome-shell

 125 PackagesBug ReportMediumLow seamonkey broken on i686 Closed
100%
Task Description

breaks in more SIMD optimizations.

 127 PackagesBug ReportMediumLow iotop doesn't work Closed
100%
Task Description
root@arch32-stable-pentium4 ~]# iotop
No module named 'iotop'
To run an uninstalled copy of iotop,
launch iotop.py in the top directory

iotop is a Python script, presumably some Python modules are missing.

 128 PackagesBug ReportMediumLow newsboat needs rebuild against newer libjson-c Closed
100%
Task Description
newsboat: error while loading shared libraries: libjson-c.so.4: cannot open shared object file: No such file or directory
 129 PackagesBug ReportMediumLow rust 1.47 is outdated Closed
100%
Task Description

either building 1.49 via 1.48, via 1.47 or we have to bootstrap from a binary version again.

 130 PackagesBug ReportMediumLow user-manager and plasma-meta are in conflict Closed
100%
Task Description

:: removing user-manager breaks dependency ‘user-manager’ required by plasma-meta

 131 PackagesBug ReportMediumLow libseccomp doesn't build in python bindings Closed
100%
Task Description

no task description

 133 PackagesBug ReportMediumLow libao and libpulse mixup Closed
100%
Task Description
resolving dependencies...
warning: cannot resolve "libpulse.so=0-32", a dependency of "libao"
warning: cannot resolve "libpulse-simple.so=0-32", a dependency of "libao"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libao

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libpulse.so=0-32' required by libao
:: unable to satisfy dependency 'libpulse-simple.so=0-32' required by libao
 134 PackagesBug ReportVery LowLow arm-none-eabi-gdb requires rebuild Closed
100%
Task Description

arm-none-eabi-gdb is broken due to not satisfiable dependency: “libpython3.8.so.1.0” After recompiling from upstream it works.

 135 PackagesBug ReportMediumLow namcap fails on libxkbcommon Closed
100%
Task Description
Checking PKGBUILD
Traceback (most recent call last):
  File "/usr/lib/python3.9/runpy.py", line 197, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/lib/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/usr/lib/python3.9/site-packages/namcap.py", line 247, in <module>
    process_pkgbuild(package, active_modules)
  File "/usr/lib/python3.9/site-packages/namcap.py", line 153, in process_pkgbuild
    name = "PKGBUILD (" + pkginfo["name"] + ")"
  File "/usr/lib/python3.9/site-packages/Namcap/package.py", line 128, in __getitem__
    return self._data[self.canonical_varname(key)]
KeyError: 'name'
==> Running checkpkg
error: no targets specified (use -h for help)
==> WARNING: Skipped checkpkg due to missing repo packages
 136 PackagesBug ReportMediumLow Haskell probably completely fails to rebuild Closed
100%
Task Description
Configuring attoparsec-0.13.2.4...
Error:
    The following packages are broken because other packages they depend on are missing. These broken packages must be rebuilt before they can be used.
installed package tasty-1.3.1 is broken due to missing package ansi-terminal-0.11-2SXi8ZhU18i2uWLidRUotS, async-2.2.2-K8T9LglWxlG5HgD5vvGjbo, optparse-applicative-0.16.1.0-JDPEASK1GJS1Nsq2qjjZCq
installed package tasty-quickcheck-0.10.1.2 is broken due to missing package QuickCheck-2.14.2-io0WylueSG4seqSTUQCKM, optparse-applicative-0.16
 137 PackagesBug ReportMediumLow llvm rebuild fails (aka sphinx requires a python module ...Closed
100%
Task Description
Configuration error:
There is a programmable error in your configuration file:

Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/sphinx/config.py", line 326, in eval_config_file
    execfile_(filename, namespace)
  File "/usr/lib/python3.9/site-packages/sphinx/util/pycompat.py", line 88, in execfile_
    exec(code, _globals)
  File "/build/llvm/src/llvm-11.0.1.src/docs/conf.py", line 40, in <module>
    import recommonmark
ModuleNotFoundError: No module named 'recommonmark'
 138 PackagesBug ReportMediumLow polkit doesn't build because of a stuck js78 Closed
100%
Task Description

no task description

 139 PackagesBug ReportMediumLow webkit2gtk doesn't build Closed
100%
Task Description

This blocks tons of packages..

Showing tasks 101 - 150 of 350 Page 3 of 7 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing