Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategory  ascTask TypePrioritySeveritySummaryStatusProgress
 225 PackagesBug ReportHighCritical [zstd] 1.5.1, zstd compressed ramdisk fails to load pro ...Closed
100%
Task Description

kernel issue with some network card and/or
systemd subservice not working add all

I cannot login remotely or locally.

System drops to maintainance shell..

Not a single systemd subdaemon is working..

This also effectively kills all i486 build machines..

 227 PackagesBug ReportMediumLow [object-introspection] [libosinfo] rebuild issue Closed
100%
Task Description

affects: tracker-miners tracker3-miners gnome-documents gnome-music gnome-photos nautilus

 232 PackagesBug ReportVery LowLow clementine fails on missing libprotobuf.so.27 Closed
100%
Task Description

After just having updated my trusty EeePC 1000H to be fully up to date again, I discovered that clementine is no longer working. It fails, stating that libprotobuf.so.27 cannot be found. Looking in /usr/lib, I can see libprotobuf.so.28, so I assume that the clementine package needs a rebuild.

 233 PackagesBug ReportVery LowLow Cannot install smplayer due to broken dependency Closed
100%
Task Description

I am currently unable to install smplayer in testing due to a broken dependency of mpv

[~]$ sudo pacman -S smplayer
resolving dependencies...
warning: cannot resolve "libplacebo.so=120-32", a dependency of "mpv"
warning: cannot resolve "mpv", a dependency of "smplayer"
:: The following package cannot be upgraded due to unresolvable dependencies:
      smplayer

:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...
 there is nothing to do
 237 PackagesBug ReportVery LowLow i686: pango need to be rebuilt against harfbuzz Closed
100%
Task Description

Hi,

pango-list (and many packages depending on pango) fails to run with the following error:

$ pango-list 
pango-list: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant

hb_font_set_synthetic_slant seems to be related to harfbuzz.

While I used Parabola i686 for the test, both pango and harfbuzz come from Arch Linux 32 i686, so Arch Linux 32 i686 should also be affected:

$ pacman -Q -o pango-list 
/usr/bin/pango-list is owned by pango 1:1.50.4-1.0
$ pacman -sS "^pango$"
extra/pango 1:1.50.4-1.0 [installed]
    A library for layout and rendering of text
$ pacman -sS "^harfbuzz$"
extra/harfbuzz 3.1.2-1.0 [installed]
    OpenType text shaping engine

Denis.

 238 PackagesBug ReportVery LowLow Linux-zen kernel 5.16.8.arch1-1.0 made with gcc 11.1 an ...Closed
100%
Task Description

Linux and Linux-zen kernel 5.16.8.arch1-1.0 made with gcc 11.1 and cannot build dkms modules with gcc 11.2

remake linux and linux-zen kernel with gcc version 11.2

 239 PackagesBug ReportMediumLow [ffmpeg] and [ffmepg4.4] fail to build Closed
100%
Task Description
libswscale/x86/rgb2rgb_template.c: In function ‘interleaveBytes_sse2’:
libswscale/x86/rgb2rgb_template.c:1838:9: error: the register ‘xmm2’ cannot be clobbered in ‘asm’ for the current target
 1838 |         __asm__(
      |         ^

Also on i486 symbols are missing if not using LTO and probing of libraries like x264/x265 fail.

 241 PackagesBug ReportVery LowLow mpd probably needs to be rebuilt against pipewire Closed
100%
Task Description

Hi,

If I run mpd, it fails to run due to a missing PW_LOG_TOPIC_DEFAULT symbol:
> $ mpd
> mpd: symbol lookup error: mpd: undefined symbol: PW_LOG_TOPIC_DEFAULT

While I run Parabola, both mpd and pipewire comes from the i686 repository of Arch Linux 32:
> extra/mpd 0.23.5-1.2 [installed]
> Flexible, powerful, server-side application for playing music
> extra/pipewire 1:0.3.36-1.0 [installed]
> Low-latency audio/video router and processor

If I look on a x86_64 Parabola installation instead, PW_LOG_TOPIC_DEFAULT can be found in libpipewire:
> $ readelf -s /usr/lib/libpipewire-0.3.so.0 | grep PW_LOG_
> 383: 00000000000d7128 8 OBJECT GLOBAL DEFAULT 21 > PW_LOG_TOPIC_DEFAULT

But that command returns nothing on Parabola i686.

Denis.

 242 PackagesBug ReportMediumLow [flac] fails to build Closed
100%
Task Description

This is just the sad state of what people do to working software:

if(CMAKE_SYSTEM_PROCESSOR STREQUAL "i686" AND HAVE_STACKREALIGN_FLAG)
    add_compile_options(-mstackrealign)
endif()

which results in nasm to fail with “unknown option -m”

a) they rewrite half of the build system without apparently understanding fully the autoconf part
b) they don’t bother to delete to autoconf part
c) they write code for porting the software apparenty without testing (why bother then in the first place?)

 244 PackagesBug ReportVery LowLow unable to satisfy dependency 'libx264.so=163-32' requir ...Closed
100%
Task Description

# pacman -Sy ffmpeg
:: Synchronizing package databases… core is up to date
extra is up to date
community is up to date
resolving dependencies… warning: cannot resolve “libx264.so=163-32”, a dependency of “ffmpeg” :: The following package cannot be upgraded due to unresolvable dependencies:

    ffmpeg
 253 PackagesBug ReportMediumLow [rust] rebuilds but fails to build anything Closed
100%
Task Description

Bootstrapping rust via rust159-bin leads to:

error[E0463]: can't find crate for `std`

error[E0463]: can't find crate for `core`

error[E0463]: can't find crate for `compiler_builtins`

Basically, rust is broken.

 256 PackagesBug ReportMediumLow [ISO] fails to boot, mount value too large error Closed
100%
Task Description
/init: line 477: mount: Value too large for defined data type

At least ISO 2022.04.03 is affected..

 259 PackagesBug ReportVery LowLow Broken GSL package Closed
100%
Task Description

GSL broken dependence with inkscape:

$ inkscape
inkscape: error while loading shared libraries: libgsl.so.27: cannot open shared object file: No such file or directory

Check the library:

# pacman -Ss gsl
extra/gsl 2.7-1.0 [instalado]

# pacman -Ql gsl | grep ‘\.so’ gsl /usr/lib/libgsl.so
gsl /usr/lib/libgsl.so.25
gsl /usr/lib/libgsl.so.25.1.0
gsl /usr/lib/libgslcblas.so
gsl /usr/lib/libgslcblas.so.0
gsl /usr/lib/libgslcblas.so.0.0.0

 263 PackagesBug ReportMediumLow [libnss_systemd] segfault on login Closed
100%
Task Description

Experienced with mate and xfce, logging in results in:

md-coredump@1-384-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 15 12:33:34 arch32 kernel: audit: type=1130 audit(1652610814.953:50): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@1-384-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 15 12:33:35 arch32 systemd-coredump[385]: Process 345 (lightdm) of user 0 dumped core.
                                              
                                              Module linux-gate.so.1 with build-id a27879231a619f481c5f61675aaa832fd638cb59
                                              Module libnss_systemd.so.2 with build-id 513870f67a61f7ea3d6e57c8f95f354de951706d
                                              Module pam_warn.so with build-id c2d0d3d8af8a67a71b5f2c65b5c1bbd307215915
                                              Module pam_deny.so with build-id 3f3db5fc2f00b0311c1055abff87446bd21ed382
                                              Module libpam_misc.so.0 with build-id f9b9c0b45bff4398cfb8af0d4ab66e20e862490a
                                              Module pam_systemd.so with build-id 7e789653df9c1d629075ca9e56b924a39ab8f30a
                                              Module pam_mail.so with build-id 113680c35df7dd7d41f77b00b004c201c4f19a09
                                              Module pam_motd.so with build-id ac0c4aa42752e17cbd95f6625873d3e84dffbabd
                                              Module pam_limits.so with build-id a229b08f2ae095fec0f9b9fcc08a9851501a47f3
                                              Module pam_keyinit.so with build-id bc58e8776715407d61b32b6d8d4bf4e7317dd98c
                                              Module pam_loginuid.so with build-id 41a858e6a28f79da7ff5800bc27195119be5626a
                                              Module pam_time.so with build-id 703a26cf2e5c055cc07ddf7f323e0eefbb84ec8a
                                              Module pam_access.so with build-id 55b6fed1bfe3f208cb32ee028c2ff06025ab3a45
                                              Module pam_env.so with build-id 055f29545a53ec4d2443001c1e03c75320988013
                                              Module pam_permit.so with build-id ebe5828bc48cb18e3dd029a2240cebb57e14f768
                                              Module libkeyutils.so.1 with build-id 5a50265493bf37e60323c71fb776cfd730bf8964
                                              Module libkrb5support.so.0 with build-id 716c0f85b8408ce69093706649d5ebaae25456b0
                                              Module libcom_err.so.2 with build-id 60116fbed67a6c3ab90da2f38c550bc1d1f79f02
                                              Module libk5crypto.so.3 with build-id 3459692a8e859eec416dcfce08e9fe69a4f1311f
                                              Module libkrb5.so.3 with build-id 5400284945ac88bb9fa911a9b987a34ed2274010
                                              Module libgssapi_krb5.so.2 with build-id 546b080b472317aeb2f04b396935e03e2bd78911
                                              Module libtirpc.so.3 with build-id 5034a25480814d17e335ca016d0299fdbdc0cae9
                                              Module pam_unix.so with build-id 3d7111b8433120fb2793be17510462b7db176197
                                              Module libp11-kit.so.0 with build-id ee4f39a2bf217877ed8f65eee72b1af45a3bf1a2
                                              Module libcrypto.so.1.1 with build-id 9f5d5eddb3c55325af7d4241cbe597a48a5b999c
                                              Module libm.so.6 with build-id 9039ae10a04fcb30d921fd5c76097c7a3f665370
                                              Module libcap.so.2 with build-id 4d323ab3b69bef5921d049778199ca62a9c7811c
                                              Module libcrypt.so.2 with build-id a66b381fec2654ed68c0491bd86e896e8d190597
                                              Module pam_systemd_home.so with build-id 4331342dd5ed0b492d732501e4dc3fa9f1bd598a
                                              Module pam_faillock.so with build-id f8f59c3134d8d7d9a3b271ff3f81f77fb8b973a2
                                              Module pam_nologin.so with build-id 64f5509dbde1de344f52af9b73711769affbe840
                                              Module pam_shells.so with build-id 24a1716196a601444b2dd1866ce46de7973ef27b
                                              Module librt.so.1 with build-id fa61d1f12a409640b8cf40cf9a23b352f1bc0552
                                              Module libblkid.so.1 with build-id 5d2cf9b1a4781b9178b53d80028a93380d91520a
                                              Module ld-linux.so.2 with build-id 595ad200cc586e2697315fb53e2d0eb7b1b9c1c1
                                              Module libdl.so.2 with build-id 1d3a3521b2e6abc69c970335373065339a553791
                                              Module libgpg-error.so.0 with build-id ad225378bc723ed6b4b8b15099198fbedfcacd08
                                              Module libcap-ng.so.0 with build-id ee0d4a32f9f1173f386abc7d685ef18dd5c29061
                                              Module libXau.so.6 with build-id ca0c911ec4ccee4b60d41ce4d8cadb6303faa158
                                              Module libpcre.so.1 with build-id 9e8433d78efdfe75dc9ca017f477cf938d804df1
                                              Module libffi.so.8 with build-id 691b36b35ab1c4821e3e97a70d774dcd69133fdc
                                              Module libresolv.so.2 with build-id f9d6b273df20a9704fc122ac781527a783638301
                                              Module libmount.so.1 with build-id 1acb539ab365dd2f5b20907ad40da36b8e9fe264
                                              Module libz.so.1 with build-id bed5219c83b00026030d38c8912fc2d9cfd33851
                                              Module libgmodule-2.0.so.0 with build-id 8f6ff76c08d4ff9075c35915c959a867bfe58cf6
                                              Module libc.so.6 with build-id 17751704b417b7760f84338ea777fd67fae6ef96
                                              Module libpthread.so.0 with build-id e41f23d77ed9ff0c67d4d63e3e272b50cd81e3cc
                                              Module libpam.so.0 with build-id 01ddafaed94ed4dbbc9126943929915326d00290
                                              Module libgcrypt.so.20 with build-id 1f9f583f3f53e6556867735a4c2f9686e19067e0
                                              Module libaudit.so.1 with build-id 1ef22adc0a368bafd37e88808dc4fe06e1d04198
                                              Module libxcb.so.1 with build-id 350f0b983356df7c00c3edfd69e60869a3074671
                                              Module libXdmcp.so.6 with build-id d3227d8950007ff94ae016a81373b7e920eb8926
                                              Module libglib-2.0.so.0 with build-id 3057954359bdc8d2b6a0e220a8a4d5e13c134cb8
                                              Module libgobject-2.0.so.0 with build-id 63a1e70bd9f4e113f1dcd15ccd533ea00ee7e67b
                                              Module libgio-2.0.so.0 with build-id f8a91d2df4aa66c093de256c755782ef7d42850c
                                              Module lightdm with build-id 3892c6848f55843ad693ca2f1997ceb91354e9d4
                                              Stack trace of thread 345:

 267 PackagesBug ReportVery LowLow [(g)vim] libperl.so dependency version mismatch Closed
100%
Task Description

`/bin/vim` in version 8.2.5046-2.0 has an rpath on `libperl.so` version 5.36, which is currently only available in staging (i686/core is at version 5.34). vim does not start (cannot open shared object file).

```
$ readelf -d /bin/vim

Dynamic section at offset 0×486090 contains 43 entries:

Tag        Type                         Name/Value

[…]
0x000000000000000f (RPATH) Library rpath: [/usr/lib/perl5/5.36/core_perl/CORE]
```

 274 PackagesBug ReportVery LowMedium perl-term-readline-gnu should be rebuilt due to new per ...Closed
100%
Task Description

When you have system update there is this warning:

Warn about old perl modules
WARNING: '/usr/lib/perl5/5.34' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.34'

After searching you see it’s caused by

$ pacman -Qqo '/usr/lib/perl5/5.34'
perl-term-readline-gnu

So this package should be rebulded, because in repositories is perl 5.36

More info and problem description https://forum.manjaro.pl/t/archlinux32-ostrzezenie-od-perl/2356

 277 PackagesBug ReportMediumLow [emacs] rebuild fails on 486, needs librsvg Closed
100%
Task Description

/usr/src/debug/emacs-28.1/src/image.c:10009: undefined reference to `rsvg_handle_set_stylesheet’ # /usr/bin/ld: /usr/src/debug/emacs-28.1/src/image.c:10196: undefined reference to `rsvg_handle_set_stylesheet’

 297 PackagesBug ReportVery LowLow jack2 can not install Closed
100%
Task Description
# pacman -S jack --noconfirm
:: There are 2 providers available for jack:
:: Repository extra
   1) jack2  2) pipewire-jack

Enter a number (default=1): 
resolving dependencies...
warning: cannot resolve "libcelt0.so=2-32", a dependency of "jack2"
:: The following package cannot be upgraded due to unresolvable dependencies:
      jack2

:: Do you want to skip the above package for this upgrade? [y/N] error: failed to prepare transaction (could not satisfy dependencies)

:: unable to satisfy dependency 'libcelt0.so=2-32' required by jack2
 303 PackagesBug ReportVery LowLow codeblocks issue.. Closed
100%
Task Description

its requested that please push the codeblocks testing to stable..

 304 PackagesBug ReportMediumCritical [systemd] 251.2 breaking systems, cannot login Closed
100%
Task Description
Assertion 'close_nointr(fd) != -EBADF' failed at src/basic/fd-util.c:76, function safe_close(). Aborting.

The temporary workaround is to comment out ‘pam_system.so’ in system-auth and system-login..

 307 PackagesBug ReportMediumLow [i486] make guile JIT failing Closed
100%
Task Description
*** work/functions/guile.base   Wed Nov 16 17:55:19 2022
--- work/functions/guile.log    Wed Nov 16 17:55:19 2022
***************
*** 1,3 ****
--- 1,7 ----
+ JIT failed to initialize
+ disabling automatic JIT compilation
+ JIT failed due to resource exhaustion
+ disabling automatic JIT compilation
 308 PackagesBug ReportVery LowLow gettext needs a rebuild for libunistring Closed
100%
Task Description

I’m on pentium4 and I’m getting:

/usr/bin/xgettext: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory
/usr/bin/msgmerge: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory
/usr/bin/msgfmt: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory

gettext 0.21.1-1.1
libunistring 1.1-2.0

 309 PackagesBug ReportVery LowLow gcompris links to openssl-1.1.so Closed
100%
Task Description

```
gcompris-qt: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory
```

 312 PackagesBug ReportVery LowLow In testing calibre will not start Closed
100%
Task Description
[keith@Arch32 ~]$ calibre
Failed to import PyQt module: PyQt6.QtQuick with error: No module named 'PyQt6.QtQuick'
Traceback (most recent call last):
  File "/usr/bin/calibre", line 21, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 546, in main
    app, opts, args = init_qt(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 123, in init_qt
    app = Application(args, override_program_name=override, windows_app_uid=MAIN_APP_UID)
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 1096, in __init__
    setup_to_run_webengine()
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 1078, in setup_to_run_webengine
    from qt.core import QQuickWindow, QSGRendererInterface
ImportError: cannot import name 'QQuickWindow' from 'qt.core' (/usr/lib/calibre/qt/core.py)
[keith@Arch32 ~]$ calibre --version
calibre (calibre 6.7.1)
[keith@Arch32 ~]$ 
 317 PackagesBug ReportVery LowMedium [pacutils] paccheck core dumps Closed
100%
Task Description

$ paccheck pacman
pacman: all dependencies satisfied
zsh: segmentation fault (core dumped) paccheck pacman

It seems to be in the –files check (as with that the crash happens quicker).

Debuginfod doesn’t seem to work for ArchLinux32 (unlike standard ArchLinux) so no debug symbols, but here is the gdb backtrace:

(gdb) bt
#0 0xb7d1989a in strnlen () from /usr/lib/libc.so.6
#1 0xb7d197ac in strncpy () from /usr/lib/libc.so.6
#2 0x00402abe in ?? ()
#3 0x0040244a in ?? ()
#4 0xb7c96129 in ?? () from /usr/lib/libc.so.6
#5 0xb7c961fd in __libc_start_main () from /usr/lib/libc.so.6
#6 0x004026f5 in ?? ()

Valgrind does not seem to work properly on Arch32 either, so I can’t test that.

 318 PackagesBug ReportVery LowLow [multiple]: Note: This key has expired! Closed
100%
Task Description
$ wget http://pool.mirror.archlinux32.org/i686/core/binutils-2.40-2.0-i686.pkg.tar.zst
$ wget http://pool.mirror.archlinux32.org/i686/core/binutils-2.40-2.0-i686.pkg.tar.zst.sig
$ sudo pacman-key --verify binutils-2.40-2.0-i686.pkg.tar.zst.sig
==> Checking binutils-2.40-2.0-i686.pkg.tar.zst.sig... (detached)
gpg: Signature made Mon Jan 23 01:17:18 2023 EST
gpg:                using RSA key 16194A82231E9EF823562181C8E8F5A0AF9BA7E7
gpg: Good signature from "Andreas Baumann (sign) <mail@andreasbaumann.cc>" [expired]
gpg: Note: This key has expired!
Primary key fingerprint: 1619 4A82 231E 9EF8 2356  2181 C8E8 F5A0 AF9B A7E7
==> ERROR: The signature identified by binutils-2.40-2.0-i686.pkg.tar.zst.sig could not be verified.

<KitsuWhooa> fuse also fails for me

 323 PackagesBug ReportVery LowMedium qemu-desktop installation error Closed
100%
Task Description

While installing qemu-desktop for Archlinux32 following error appears:

/usr/bin/gtk-query-immodules-3.0: symbol lookup error: /usr/liblibpango-1.0.so.0: undefined symbol: hb_ot_color_has_paint

Pango version pango-1:1.50.14-1.0-pentium4. This is a problem of Archlinux32 only - in Archlinux there is no error.

 324 PackagesBug ReportMediumLow [libxft] segfaults Closed
100%
Task Description
Mar 08 19:16:01 arch32 audit[409]: ANOM_ABEND auid=1000 uid=0 gid=0 ses=5 pid=409 comm="slim" exe="/usr/bi                                                                                                          n/slim" sig=11 res=1                                                                                                                                                                                                
Mar 08 19:16:01 arch32 kernel: slim[409]: segfault at 30 ip b7dbe9e9 sp bf84f680 error 4 in libX11.so.6.4.                                                                                                          0[b7d9c000+8c000] likely on CPU 0 (core 0, socket 0)                                                                                                                                                                
Mar 08 19:16:01 arch32 kernel: Code: 04 00 00 83 c4 10 eb 8e 8d b4 26 00 00 00 00 66 90 53 e8 1a dd fd ff                                                                                                           81 c3 92 7a 11 00 83 ec 08 8b 44 24 10 8b 88 38 05 00 00 <8b> 51 30 83 fa ff 74 52 c7 41 30 ff ff ff ff 8b                                                                                                           88 d0 04 00 00 85                                                                                                                                                                  
Mar 08 19:16:01 arch32 systemd[1]: Started Process Core Dump (PID 424/UID 0).                                                                                                                                       
Mar 08 19:16:01 arch32 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=system                                                                                                          d-coredump@1-424-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'                                                                                                          
Mar 08 19:16:01 arch32 systemd-coredump[425]: [🡕] Process 409 (slim) of user 0 dumped core.                                                                                                                         
                                                                                                                                                                                                                    
                                              Stack trace of thread 409:                                                                                                                                            
                                              #0  0x00000000b7dbe9e9 _XAllocID (libX11.so.6 + 0x349e9)                                                                                                              
                                              #1  0x00000000b7d9f710 XCreatePixmap (libX11.so.6 + 0x15710)                                                                                                          
                                              #2  0x00000000b74cbd41 XRenderFindDisplay (libXrender.so.1 +                                                                                                           0x2d41)                                                                                                                                                                                                            
                                              #3  0x00000000b74cccf1 XRenderFreeGlyphSet (libXrender.so.1                                                                                                           + 0x3cf1)                                                                                                                                                                                                           
                                              #4  0x00000000b766e55b n/a (libXft.so.2 + 0x655b)                                                                                                                     
                                              #5  0x00000000b7c9a4fa _ZN5PanelD2Ev (libslim.so.1.3.6 + 0x1                                                                                                          34fa)                                                                                                                                                                                                               
                                              #6  0x00000000004bc49f _ZN3App13RestartServerEv (slim + 0xd4                                                                                                          9f)                                                                                                                                                                                                                 
                                              #7  0x00000000004bd623 _ZN3App5LoginEv (slim + 0xe623)                                                                                                                
                                              #8  0x00000000004bc073 _ZN3App3RunEv (slim + 0xd073)                                                                                                                  
                                              #9  0x00000000004b4742 main (slim + 0x5742)                                                                                                                           
                                              #10 0x00000000b7850129 n/a (libc.so.6 + 0x1f129)                                                                                                                      
                                              #11 0x00000000b78501fd __libc_start_main (libc.so.6 + 0x1f1f                                                                                                          d)                                                                                                                                                                                                                  
                                              #12 0x00000000004b48b5 _start (slim + 0x58b5)                                                                                                                         
                                              ELF object binary architecture: Intel 80386                                                                                                                           
 329 PackagesBug ReportVery LowHigh [go] Cannot install yay from AUR Closed
100%
Task Description

Installing yay from AUR

git clone https://aur.archlinux.org/yay.git
cd yay
makepkg -sri

gives following error

go: updates to go.sum needed, disabled by -mod=readonly

Reason - outdated version of go in i686 architecture

Temporary solution - use go for pentium4 (change temporarily architecture to pentium4 in /etc/pacman.conf)

 331 PackagesBug ReportMediumLow [rust] rebootstrap Closed
100%
Task Description

seems like the virtual memory exhaustion is fixed in the newest version.
We have to bootstrap again (mainly for librsvg and firefox).

 332 PackagesBug ReportVery LowLow firefox 112 compilation Closed
100%
Task Description

any ideas hpw to get past this error (i686)?

18:33.80 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:38:16: error: ‘any’ is not a member of ‘xsimd’
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:16:70: error: incomplete type ‘xsimd::batch<short int, xsimd::sse2>’ used in nested name specifier
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:35:31: error: ‘xsimd::batch<short int, xsimd::sse2> vectmask’ has incomplete type
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:37:64: error: incomplete type ‘xsimd::batch<short int, xsimd::sse2>’ used in nested name specifier
 357 PackagesBug ReportVery LowMedium pacman-contrib 1.10.5 requires rebuild Closed
100%
Task Description

The pactree tool in pacman-contrib 1.10.5 requires libalpm.so.13 which belongs to an older version of pacman. Rebuilding pacman-contrib with the latest version of pacman installed should resolve the issue.

 358 PackagesBug ReportMediumLow All versions of samba > 4.17.5 are broken Closed
100%
Task Description

Either because of ICU or LDB incompatibilites.
tdb, ldb, samba and python have to be rebuild.

 5 PackagesBug ReportMediumLow [sbcl] fails to compile - Arch Linux Closed
100%
Task Description

16.12.2017 - The best, I can get is trying to compile the git HEAD with clisp (instead of sbcl). However, this still errors with: entering make-target-2.sh

 6 PackagesBug ReportMediumLow [libreoffice-still] 5.3.7-4 crashes when opening a ... Closed
100%
Task Description

07.11.2017 - Nov 07 18:19:32 arch32-testing systemd[1]: Started Process Core Dump (PID 643/UID 0). Nov 07 18:19:35 arch32-testing …

 7 PackagesBug ReportMediumLow unknown bug FS#7 Closed
100%
Task Description

no task description

 10 PackagesBug ReportMediumLow unknown bug FS#10 Closed
100%
Task Description

no task description

 11 PackagesBug ReportMediumLow unknown bug FS#11 Closed
100%
Task Description

no task description

 13 PackagesBug ReportMediumLow [fox-devel] fails on 32-bit Intel - Arch Linux Closed
100%
Task Description

16.11.2017 - It’s the development version of the FOX toolkit. Breaks in some int/FXival/void * abstractions: FXWSQueue.cpp: In member function ‘FX::FXbool …

 14 PackagesBug ReportMediumLow [ghc-mod] Needs rebuilt Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Luke Shumaker - 21.11.2017
Last edited by Erich Eckner - 25.11.2017
 FS#14  - [ghc-mod] Needs rebuilt

Yesterday, I mentioned on IRC that many haskell packages need rebuilt. In response, deep42thought moved a bunch of packages from staging to stable, and told me to open a bug report if the issue persisted.

For the most part, this seems resolved. Some pacman -Qo/-Ql/ldd/grep magic tells me that all of the haskell packages I have are fine, except for [ghc-mod].
Closed by Erich Eckner
25.11.2017 14:58
Reason for closing: Fixed
Additional comments about closing:

removed - upstream removed it, too

  Comments (1)
  Related Tasks (0/0)

Luke Shumaker commented on 23.11.2017 04:47

deep42thought has removed ghc-mod, reflecting its removal in Arch. Requesting closure.

Google Cache

 16 PackagesBug ReportMediumLow [libreoffice-still] still using icu 59 - Arch Linux Closed
100%
Task Description

 FS#16  : [libreoffice-still] still using icu 59 - Arch Linux
28.11.2017 - /usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libicuuc.so.59: cannot open shared object file: No such file or …

 17 PackagesBug ReportMediumLow nvidia and nvidia-lts kernel module build failure on 32 ...Closed
100%
Task Description

26.11.2017 - In file included from ./arch/x86/include/asm/page.h:75:0, from ./arch/x86/include/asm/thread_info.h:11, from ./include/linux/thread_info.h:37, …

 18 PackagesBug ReportMediumLow  [android-tools] missing a -latomic when linking adb .. Closed
100%
Task Description

08.12.2017 -  FS#18  - [android-tools] missing a -latomic when linking adb (and maybe other utilities). Didn’t find the place where to report this upstream!?

 19 PackagesBug ReportMediumLow unknown bug FS#19 Closed
100%
Task Description

no task description

 21 PackagesBug ReportMediumLow [ceph] unit tests failing or segfault Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 13.12.2017
Last edited by Erich Eckner - 03.01.2018
 FS#21  - [ceph] unit tests failing or segfault

5/142 Test   #3: test_objectstore_memstore.sh ............***Failed    1.13 sec
7/142 Test   #1: run-rbd-unit-tests.sh ...................***Failed    1.49 sec

46/142 Test #57: unittest_util ………………………*Failed 0.05 sec
51/142 Test #59: unittest_lru ……………………….
*Failed 0.57 sec
92/142 Test #100: unittest_erasure_code_shec_arguments ….*Failed 0.63 sec
96/142 Test #102: unittest_journal ……………………
*Exception: SegFault 0.90 sec
98/142 Test #106: unittest_mds_sessionfilter …………..*Exception: SegFault 1.02 sec
106/142 Test #116: unittest_bluefs …………………….
*Exception: SegFault 0.66 sec
107/142 Test #117: unittest_bluestore_types …………….*Exception: SegFault 1.25 sec
108/142 Test #119: unittest_memstore_clone ……………..
*Exception: SegFault 2.51 sec
114/142 Test #124: unittest_osdscrub …………………..*Exception: SegFault 0.63 sec
115/142 Test #125: unittest_pglog ……………………..
*Exception: SegFault 1.23 sec
116/142 Test #126: unittest_hitset …………………….*Failed 0.52 sec
125/142 Test #134: test_ceph_argparse.py ……………….
*Failed 1.64 sec
130/142 Test #6: run-tox-ceph-disk …………………..*Failed 94.75 sec
132/142 Test #142: unittest_rbd_mirror …………………
*Exception: SegFault 0.51 sec
140/142 Test #2: run-cli-tests ………………………*Failed 167.72 sec
141/142 Test #110: mgr-dashboard-smoke.sh ………………
*Failed 301.60 sec

Closed by Erich Eckner
03.01.2018 21:15
Reason for closing: Won’t fix
Additional comments about closing:

blacklisted ceph

Comments (9)

Admin
Erich Eckner commented on 17.12.2017 19:11

I’ll build it w/o check(), but we should definitely look into this (later)
Admin
Andreas Baumann commented on 19.12.2017 12:09

ceph goes heavy non-i686:

shell#&gt; cmake ….

Error at cmake/modules/BuildDPDK.cmake:61 (message):

not able to build DPDK support: unsupported target.
"i686-native-linuxapp-gcc" not listed in

Call Stack (most recent call first):

cmake/modules/BuildDPDK.cmake:83 (do_build_dpdk)
cmake/modules/BuildSPDK.cmake:4 (build_dpdk)
CMakeLists.txt:239 (build_spdk)

I suspect libvirt and the other packages can use ceph, but do not require it
really. I would make ceph an optdepend.
Admin
Andreas Baumann commented on 19.12.2017 12:10

Using it without check is no option IMHO.
Admin
Andreas Baumann commented on 03.01.2018 19:29

New try, same bugs:

        1 - run-rbd-unit-tests.sh (Failed)
        2 - run-cli-tests (Failed)
        3 - test_objectstore_memstore.sh (Failed)
       59 - unittest_lru (Failed)
      100 - unittest_erasure_code_shec_arguments (Failed)
      102 - unittest_journal (SEGFAULT)
      106 - unittest_mds_sessionfilter (SEGFAULT)
      116 - unittest_bluefs (SEGFAULT)
      117 - unittest_bluestore_types (SEGFAULT)
      119 - unittest_memstore_clone (SEGFAULT)
      124 - unittest_osdscrub (SEGFAULT)
      125 - unittest_pglog (SEGFAULT)
      126 - unittest_hitset (Failed)
      134 - test_ceph_argparse.py (Failed)
      142 - unittest_rbd_mirror (SEGFAULT)

Decision: remove ceph dependency on libvirt (more?), then blacklist the package.

Reason: we cannot maintain all software for companies upstream.
Admin
Andreas Baumann commented on 03.01.2018 19:45

mmh, a (most likely incomplete) list of software using ceph:

- libvirt: seems to be an optional storage method
- qemu: obvious, if used in combination with libvirt to store the disk image with ceph
- pifpaf: “Suite of tools and fixtures to manage daemons for testing”, ceph used in tests only
- fio: “Scriptable I/O tool for storage benchmarks and drive testing”, ceph seems to be optional

So, all seem to work fine without ceph.
Admin
Andreas Baumann commented on 03.01.2018 19:53

ceph on gihub: a project with pull requests only and no bug reports.. ok then.
Admin
Erich Eckner commented on 03.01.2018 20:59

agreed: I’ll blacklist it, once I compiled a list of ceph dependent packages.
Admin
Erich Eckner commented on 03.01.2018 21:04

I only see libvirt, python-pifpaf and qemu depending on ceph
Admin
Erich Eckner commented on 03.01.2018 21:07

ah, that’s because you already removed the dependencies :-)

Google Cache

Bing Cache

 24 PackagesBug ReportMediumLow [extra/viewnior] Needs rebuild against exiv2=0.26 Closed
100%
Task Description

I scheduled a rebuild of viewnior, let me know if viewnior 1.6-3.1 works.

 25 PackagesBug ReportMediumLow unknown bug FS#25 Closed
100%
Task Description

no task description

 26 PackagesBug ReportMediumLow [texlive] partially linked against old libmpfr Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 02.02.2018
Last edited by Andreas Baumann - 02.02.2018
 FS#26  - [texlive] partially linked against old libmpfr

( 9/18) Updating TeXLive filename database… texlua: error while loading shared libraries: libmpfr.so.4: cannot open shared object file: No such file or directory

Triggered a forced rebuild of textlive-core and texlive-bin.
Closed by Andreas Baumann
02.02.2018 10:15
Reason for closing: Fixed

  Comments (0)

Google Cache

 27 PackagesBug ReportMediumLow man breaks on gdbm sobump Closed
100%
Task Description

Attached to Project: Archlinux32
Opened by Andreas Baumann - 02.02.2018
Last edited by Andreas Baumann - 03.02.2018
 FS#27  - man breaks on gdbm sobump

man
man: error while loading shared libraries: libgdbm.so.4: cannot open shared object file: No such file or directory

either you must link against libgdbm_compat.so.4 or against libgdbm.5
Closed by Andreas Baumann
03.02.2018 07:47
Reason for closing: Fixed
Additional comments about closing:

fixed in man-db-2.7.6.1-3.1, installing that package from testing as temporary is the better
solution than adding a symlink you make forget to delete..

  Comments (4)
  Related Tasks (0/0)

Admin
Andreas Baumann commented on 02.02.2018 17:50

temporary workaround: ln -fs libgdbm_compat.so.4 /usr/lib/libgdbm.so.4
Admin
Andreas Baumann commented on 02.02.2018 17:53

weird: Archlinux has:

/usr/bin/man is owned by man-db 2.7.6.1-3
gdbm 1.14.1-1

Archlinux 32 has:

man-db 2.7.6.1-3.0
gdbm 1.14.1-1.0

This seems to be pretty much the same version.
Admin
Erich Eckner commented on 02.02.2018 18:15

it’s amazing what packages we managed to break :-/ I scheduled man-db for a rebuild
Admin
Andreas Baumann commented on 02.02.2018 20:38

man-db is rebuilding on my slave. *fingers crossed*

Google Cache

 30 PackagesBug ReportMediumLow libaio, will fail with stack smash protection enabled . ...Closed
100%
Task Description

12.04.2018 - io_queue_run.os: In function `io_queue_run’: io_queue_run.c:(.text+0×71): undefined reference to `__stack_chk_fail_local’ io_getevents.os: In …

Showing tasks 101 - 150 of 350 Page 3 of 7 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing