Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategoryTask TypePrioritySeveritySummaryStatus  descProgress
 96 Packages: StableBug ReportMediumMedium [rust] broken or missing backend Closed
100%
Task Description
shell> echo > rust.rc <<EOF
fn main() {
        println!( "Hello Rust! " );
}
EOF

shell> rustc rust.rs
error: failed to find a `codegen-backends` folder in the sysroot candidates:
* /usr
* /usr

Presumably the i686 folders are moved around in PKGBUILD to form lib32
libraries for rust on 64-bit.

 94 Packages: TestingBug ReportMediumLow Weechat needs a rebuild Closed
100%
Task Description

Since the uprgade to python from testing, weechat has broken it’s python support, which at least knocks out the plugin I use to keep in touch with my old workmates over slack.

# weechat
|   ___       __         ______________        _____ 
|   __ |     / /___________  ____/__  /_______ __  /_
|   __ | /| / /_  _ \  _ \  /    __  __ \  __ `/  __/
|   __ |/ |/ / /  __/  __/ /___  _  / / / /_/ // /_  
|   ____/|__/  \___/\___/\____/  /_/ /_/\__,_/ \__/  
| WeeChat 2.6 [compiled on Nov 12 2019 13:06:27]
| - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
| Error: unable to load plugin "/usr/lib/weechat/plugins/python.so": libpython3.7m.so.1.0: cannot open shared object file:
| No such file or directory

Inside /usr/lib/weechat/plugins there is a file named python.so, but its not any kind of link. I expect it to be fixed up if it were to be rebuilt.

 93 Packages: StableBug ReportVery LowMedium pyparsing error is preventing applications from startin ...Closed
100%
Task Description

Came across this after completing a system update two days ago.

I run Radicale and that is refusing to start with the following error:

Traceback (most recent call last):
  File "/usr/bin/radicale", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 84, in <module>
    __import__('packaging.requirements')
  File "/usr/lib/python3.7/site-packages/packaging/requirements.py", line 9, in <module>
    from pyparsing import stringStart, stringEnd, originalTextFor, ParseException
ModuleNotFoundError: No module named 'pyparsing'

When attempting to run pip to see if that might correct the issue, I got the following error:

Traceback (most recent call last):
  File "/usr/bin/pip", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 84, in <module>
    __import__('packaging.requirements')
  File "/usr/lib/python3.7/site-packages/packaging/requirements.py", line 9, in <module>
    from pyparsing import stringStart, stringEnd, originalTextFor, ParseException
ModuleNotFoundError: No module named 'pyparsing'

It looks as though something recently broke pyparsing and that’s had a knockon effect for a few packages.

 356 PackagesBug ReportMediumLow mkinitcpio core dump Closed
100%
Task Description
double free or corruption (out)
/usr/bin/mkinitcpio: line 557:  2387 Aborted                 (core dumped) MKINITCPIO_PROCESS_PRESET="$preset_name" "$0" "${preset_cmd[@]}"
error: command failed to execute correctly

Maybe also the age of the machine, the CMOS, the RAM, the moon, the universe could be
at fault here..

 316 PackagesBug ReportMediumLow [rust] exhausts virtual memory Closed
100%
Task Description
/usr/bin/ld: error: lib/libLLVMSupport.a(FileOutputBuffer.cpp.o)(.text._ZN12_GLOBAL__N_112OnDiskBufferD0Ev
) is too large (0x105 bytes)
/usr/bin/ld: failed to set dynamic section sizes: memory exhausted
collect2: error: ld returned 1 exit status

maybe we have to resort to cross-compiling rust in the end..

 306 PackagesBug ReportMediumLow [Xorg] fails on i686 Closed
100%
Task Description

For instance xauth cannot find libXext.so.6.

 298 PackagesBug ReportVery LowLow Please update Arduino Closed
100%
Task Description

Arduino is out dated and my teacher said to use the latest arduino version 1.8.x for the robotics class…

 278 PackagesBug ReportMediumLow [midori] doesn't work Closed
100%
Task Description

llvm13-libs is needed in libEGL (but the browser starts and works also without EGL support).

this one is harmless most likely:

(midori:6483): GLib-GObject-WARNING **: 08:14:57.679: ../glib/gobject/gbinding.c:467: Unable to convert a value of type gpointer to a value of type CairoSurface

this makes sure no tabs and URLs open:

** (midori:6483): CRITICAL **: 08:14:58.151: session.vala:290: Failed add tab to session database: Invalid type '(null)' in statement: 
                INSERT INTO tabs (crdate, tstamp, session_id, uri, title)
                VALUES (:crdate, :tstamp, :session_id, :uri, :title)

Let’s try a rebuild of midori first.. maybe later vala or some database layer for vala..
..or the error is deep in gobject-introspection..

 266 PackagesBug ReportMediumLow [mesa] and [mesa-amber] break on i486 Closed
100%
Task Description

mesa:

/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_sw.c.o:(.data.rel.ro.kopper_driver_descriptors+0x0): undefined reference to `sw_screen_create_zink'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_sw.c.o:(.data.rel.ro.driver_descriptors+0x0): undefined reference to `sw_screen_create_vk'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o: in function `get_driver_descriptor':
/usr/src/debug/build/../mesa-22.1.1/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c:100: undefined reference to `kmsro_driver_descriptor'
/usr/bin/ld: /usr/src/debug/build/../mesa-22.1.1/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c:100: undefined reference to `kmsro_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x0): undefined reference to `i915_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x4): undefined reference to `iris_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x8): undefined reference to `crocus_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0xc): undefined reference to `nouveau_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x10): undefined reference to `r300_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x14): undefined reference to `r600_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x18): undefined reference to `radeonsi_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x1c): undefined reference to `vmwgfx_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x20): undefined reference to `kgsl_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x24): undefined reference to `msm_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x28): undefined reference to `virtio_gpu_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x2c): undefined reference to `v3d_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x30): undefined reference to `vc4_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x34): undefined reference to `panfrost_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x38): undefined reference to `etnaviv_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x3c): undefined reference to `tegra_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x40): undefined reference to `lima_driver_descriptor'
/usr/bin/ld: src/gallium/auxiliary/pipe-loader/libpipe_loader_static.a.p/pipe_loader_drm.c.o:(.data.rel.ro.driver_descriptors+0x44): undefined reference to `zink_driver_descriptor'
collect2: fatal error: ld returned 1 exit status
compilation terminated.

mesa-amber:

osmesa.c:(.text.create_st_manager+0x4e): undefined reference to `osmesa_create_screen'
collect2: fatal error: ld returned 1 exit status
compilation terminated.

breaks now also without LTO (did before with LTO).

 264 PackagesBug ReportMediumLow [python] fails to build on i486 Closed
100%
Task Description

make[1]: *** [Makefile:637: sharedmods] Segmentation fault (core dumped)

no clue. No python on a subarchitecture means we loose the subarchitecture..

 262 PackagesBug ReportMediumLow [ca-certificates] contains empty cert bundle Closed
100%
Task Description
-r--r--r-- 1 root root 0 May 12 07:00 /etc/ca-certificates/extracted/tls-ca-bundle.pem

curl -v https://www.openssl.org
*   Trying 104.89.5.252:443...
* Connected to www.openssl.org (104.89.5.252) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* error setting certificate verify locations:  CAfile: /etc/ssl/certs/ca-certificates.crt CApath: none
* Closing connection 0
curl: (77) error setting certificate verify locations:  CAfile: /etc/ssl/certs/ca-certificates.crt CApath: none
 261 PackagesBug ReportMediumLow [binutils] FTBFS Closed
100%
Task Description
/build/binutils/src/binutils-gdb/libiberty/fibheap.c: In function ‘fibheap_replace_key_data’:
/build/binutils/src/binutils-gdb/libiberty/fibheap.c:38:25: error: ‘LONG_MIN’ undeclared (first use in th
is function)
   38 | #define FIBHEAPKEY_MIN  LONG_MIN
      |                         ^~~~~~~~
/build/binutils/src/binutils-gdb/libiberty/fibheap.c:220:30: note: in expansion of macro ‘FIBHEAPKEY_MIN’
  220 |   if (okey == key && okey != FIBHEAPKEY_MIN)
      |                              ^~~~~~~~~~~~~~
/build/binutils/src/binutils-gdb/libiberty/fibheap.c:36:1: note: ‘LONG_MIN’ is defined in header ‘<limits.h>’; did you forget to ‘#include <limits.h>’?
   35 | #include "fibheap.h"
  +++ |+#include <limits.h>

Amazing code quality :-)

 260 PackagesBug ReportMediumLow segfaults in pacstrap on 2022.05.02 ISO Closed
100%
Task Description

ISO segfaults when pacstrapping.

Several (if not all) build slaves show key verification errors.

I don’t think, it’s the keys, but gnupg slowly failing us on 32-bit.

Workaround as always: SigLevel=Never

Trick question (and possibly bonus points): what to do, if gnupg cannot be fixed..

 258 PackagesBug ReportMediumLow [clang] fails to build on i486 Closed
100%
Task Description
/usr/bin/c++ -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -I/build/clang/src/clang-13.0.1.src/build/unittests/Tooling -I/build/clang/src/clang-13.0.1.src/unittests/Tooling -I/build/clang/src/clang-13.0.1.src/include -I/build/clang/src/clang-13.0.1.src/build/include -I/build/clang/src/llvm-13.0.1.src/utils/unittest/googletest/include -I/build/clang/src/llvm-13.0.1.src/utils/unittest/googlemock/include -march=i486 -mtune=generic -O2 -pipe -fno-plt -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-protection  -Wp,-D_GLIBCXX_ASSERTIONS -fPIC -fno-semantic-interposition -fvisibility-inlines-hidden -Werror=date-time -Wall -Wextra -Wno-unused-parameter -Wwrite-strings -Wcast-qual -Wno-missing-field-initializers -Wimplicit-fallthrough -Wno-class-memaccess -Wno-redundant-move -Wno-pessimizing-move -Wno-noexcept-type -Wdelete-non-virtual-dtor -Wsuggest-override -Wno-comment -Wmisleading-indentation -fdiagnostics-color -ffunction-sections -fdata-sections -fno-common -Woverloaded-virtual -fno-strict-aliasing -pedantic -Wno-long-long -O3 -DNDEBUG  -fno-exceptions -Wno-suggest-override -std=c++14 -MD -MT unittests/Tooling/CMakeFiles/ToolingTests.dir/RecursiveASTVisitorTests/CallbacksLeaf.cpp.o -MF unittests/Tooling/CMakeFiles/ToolingTests.dir/RecursiveASTVisitorTests/CallbacksLeaf.cpp.o.d -o unittests/Tooling/CMakeFiles/ToolingTests.dir/RecursiveASTVisitorTests/CallbacksLeaf.cpp.o -c /build/clang/src/clang-13.0.1.src/unittests/Tooling/RecursiveASTVisitorTests/CallbacksLeaf.cpp
{standard input}: Assembler messages:
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
c++: fatal error: Killed signal terminated program cc1plus
compilation terminated.

We can ommit the tests..

Also lto is not good (breaks early) and you need lots of memory and swap to build it.

 255 PackagesBug ReportVery LowLow [seamonkey] Does not start, needs rebuilding Closed
100%
Task Description

Seamonkey is built with now outdated versions of libffi and icu (69). Neither pentium4 nor i686 build starts right now.

 250 PackagesBug ReportMediumLow [luajit] Illegal instruction on i686, i486 Closed
100%
Task Description

Happens for instance when starting mpv.

 249 PackagesBug ReportMediumLow [ssh] strange output instead of scp Closed
100%
Task Description
scp -rC user@server:directory .
\033[?2004lD0711 0 directory

Enabling -vvv just makes scp hang.

No clue, what the problem could be here..

 234 PackagesBug ReportMediumLow [xlockmore] just segfaults when started Closed
100%
Task Description

no task description

 218 PackagesBug ReportMediumLow [nss] shlibsign segfaults on IA-32 Closed
100%
Task Description

subprocess.CalledProcessError: Command ‘[’/build/nss/src/dist/Release/bin/shlibsign’, ‘-v’, ‘-i’, ‘/build/nss/src/dist/Release/lib/libfreebl3.so’]’ died with <Signals.SIGSEGV: 11>.

 193 Packages: StableBug ReportMediumLow pacman does not recognize sse2 on via processor Closed
100%
Task Description

/proc/cpuinfo:
processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 15
model name : VIA Nano U3400@800MHz
stepping : 10
cpu MHz : 798.016
cache size : 2048 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fdiv_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush acpi mmx fxsr sse sse2 ss tm syscall nx lm constant_tsc arch_perfmon rep_good cpuid pni monitor vmx est tm2 ssse3 cx16 xtpr sse4_1 popcnt rng rng_en ace ace_en ace2 phe phe_en pmm pmm_en lahf_lm tpr_shadow vnmi vpid ida
vmx flags : vnmi tsc_offset vtpr
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips : 1596.53
clflush size : 64
cache_alignment : 128
address sizes : 36 bits physical, 48 bits virtual
power management:

Other machine, also with via processor:

/proc/cpuinfo:
processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 13
model name : VIA C7-D Processor 1800MHz
stepping : 0
cpu MHz : 1596.326
cache size : 128 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fdiv_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge cmov pat clflush acpi mmx fxsr sse sse2 tm nx cpuid pni est tm2 xtpr rng rng_en ace ace_en ace2 ace2_en phe phe_en pmm pmm_en
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips : 3193.67
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 32 bits virtual
power management:

All the __builtin_cpu_supports() and __builtin_cpu_is() tests fail. Thus, pacman thinks, it’s not capable of sse2 and installs i686 packages instead of pentium4 ones.

Should we complain at gcc upstream? How does the kernel compile this line in /proc/cpuinfo? What checks does it perform?

 189 PackagesBug ReportMediumLow [mutter] test segfaults Closed
100%
Task Description
 50/105 mutter:clutter+clutter/conform / actor-clone                                                   FAIL            0.13s   killed by signal 11 SIGSEGV
 55/105 mutter:clutter+clutter/conform / actor-layout                                                  FAIL            0.13s   killed by signal 11 SIGSEGV
 61/105 mutter:clutter+clutter/conform / actor-shader-effect                                           FAIL            0.13s   killed by signal 11 SIGSEGV
 70/105 mutter:clutter+clutter/conform / timeline                                                      FAIL            0.12s   killed by signal 11 SIGSEGV
 71/105 mutter:clutter+clutter/conform / timeline-interpolate                                          FAIL            1.63s   killed by signal 11 SIGSEGV
 73/105 mutter:clutter+clutter/conform / timeline-rewind                                               FAIL            0.12s   killed by signal 11 SIGSEGV
 83/105 mutter:core+mutter/stacking / closed-transient-no-input-parent-delayed-focus-default-cancelled FAIL            0.14s   killed by signal 11 SIGSEGV
 84/105 mutter:core+mutter/stacking / closed-transient-no-input-parents                                FAIL            0.13s   killed by signal 11 SIGSEGV
104/105 mutter:core+mutter/ref-test/sanity / ref-test-sanity                                           FAIL            0.13s   killed by signal 11 SIGSEGV

For now I’m just ignoring test results.

 188 PackagesBug ReportMediumLow [gdal] python bindings don't build on i486 (stack smash ...Closed
100%
Task Description
#0  0xb79a0c6d in raise () from /usr/lib/libc.so.6
#1  0xb79892c6 in abort () from /usr/lib/libc.so.6
#2  0xb79e449c in __libc_message () from /usr/lib/libc.so.6
#3  0xb7a6ff4c in __fortify_fail () from /usr/lib/libc.so.6
#4  0xb7a6ff19 in __stack_chk_fail () from /usr/lib/libc.so.6
#5  0xb7182004 in ?? ()
   from /usr/lib/python3.9/site-packages/numpy/core/_multiarray_umath.cpython-39-i386-linux-gnu.so
#6  0xb7179c87 in ?? ()
   from /usr/lib/python3.9/site-packages/numpy/core/_multiarray_umath.cpython-39-i386-linux-gnu.so
#7  0xb6fd589a in PyInit__multiarray_umath ()
   from /usr/lib/python3.9/site-packages/numpy/core/_multiarray_umath.cpython-39-i386-linux-gnu.so
#8  0xb7d07f35 in ?? () from /usr/lib/libpython3.9.so.1.0
#9  0xb7c37301 in ?? () from /usr/lib/libpython3.9.so.1.0
#10 0xb7c46897 in PyObject_Call () from /usr/lib/libpython3.9.so.1.0
#11 0xb7c2c557 in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0
#12 0xb7c260b9 in ?? () from /usr/lib/libpython3.9.so.1.0
#13 0xb7c36b05 in _PyFunction_Vectorcall () from /usr/lib/libpython3.9.so.1.0
#14 0xb7c2b4e5 in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0
#15 0xb7c36938 in _PyFunction_Vectorcall () from /usr/lib/libpython3.9.so.1.0
#16 0xb7c2794c in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0
#17 0xb7c36938 in _PyFunction_Vectorcall () from /usr/lib/libpython3.9.so.1.0
#18 0xb7c2774a in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0
#19 0xb7c36938 in _PyFunction_Vectorcall () from /usr/lib/libpython3.9.so.1.0
#20 0xb7c2774a in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0

Builds fine on i686 and pentium4, so I suspect a i486 issue in numpy.

 187 DevopsBug ReportMediumLow linux-pae is for x86_64? Closed
100%
Task Description

This seems to be a problem of either update-archlinux32-package in devops or of the (commented) code path in the PKGBUILD which gets executed by this script.

 185 PackagesBug ReportMediumLow blender doesn't build Closed
100%
Task Description
- openexr missing header files?
/usr/include/openvdb/Types.h:10:10: fatal error: OpenEXR/half.h: No such file or directory
   10 | #include <OpenEXR/half.h>
      |          ^~~~~~~~~~~~~~~~
compilation terminated.

openexr 2->3 upgrade breaks blender in openvdb

openvdb needs numpy, which needs cythonize, which segfaults.
 182 Packages: StableBug ReportVery LowLow [blender] cannot resolve dependency to opensubdiv Closed
100%
Task Description

# pacman -S blender resolving dependencies… warning: cannot resolve "opensubdiv”, a dependency of "blender” :: The following package cannot be upgraded due to unresolvable dependencies:

    blender

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'opensubdiv’ required by blender

 181 PackagesBug ReportMediumLow rust 1.51.0 recompilation issues Closed
100%
Task Description
   Compiling same-file v1.0.6
     |                        ^^^
     = note: `-D non-fmt-panic` implied by `-D warnings`
     = note: this is no longer accepted in Rust 2021
help: add a "{}" format string to Display the message
     |
1493 |                 panic!("{}", out);
     |                        ^^^^^
help: or use std::panic::panic_any instead
     |
1493 |                 std::panic::panic_any(out);
     |                 ^^^^^^^^^^^^^^^^^^^^^^

Brilliantly fast changing language..

 180 Packages: StableBug ReportVery LowLow Pandoc requires specific-version haskell dependencies Closed
100%
Task Description
# pandoc --version
pandoc: error while loading shared libraries: libHSzip-archive-0.4.1-4yLWnBS0zifKkvfHVbmUo1-ghc8.10.2.so: cannot open shared object file: No such file or directory
<code>

Versions:
<code>
# pacman -Q | grep haskell
haskell-aeson 1.5.4.1-19.0
haskell-aeson-pretty 0.8.8-94.0
haskell-ansi-terminal 0.11-17.0
haskell-asn1-encoding 0.9.6-58.0
haskell-asn1-parse 0.9.5-58.0
haskell-asn1-types 0.3.4-37.0
haskell-assoc 1.0.2-27.0
haskell-async 2.2.2-40.0
haskell-attoparsec 0.13.2.4-36.0
haskell-base-compat 0.11.2-4.2
haskell-base-compat-batteries 0.11.2-11.0
haskell-base-orphans 0.8.3-14.0
haskell-base16-bytestring 0.1.1.7-3.0
haskell-base64-bytestring 1.2.0.1-3.0
haskell-basement 0.0.11-10.1
haskell-bifunctors 5.5.8-13.0
haskell-blaze-builder 0.4.2.1-2.1
haskell-blaze-html 0.9.1.2-57.0
haskell-blaze-markup 0.8.2.7-41.0
haskell-byteable 0.1.1-22.1
haskell-case-insensitive 1.2.1.0-39.0
haskell-cereal 0.5.8.1-9.0
haskell-citeproc 0.3.0.9-9.0
haskell-cmdargs 0.10.21-1.0
haskell-colour 2.3.5-75.0
haskell-commonmark 0.1.1.2-2.0
haskell-commonmark-extensions 0.2.0.3-1.0
haskell-commonmark-pandoc 0.2.0.1-24.0
haskell-comonad 5.0.6-58.0
haskell-conduit 1.3.4-3.0
haskell-conduit-extra 1.3.5-70.0
haskell-connection 0.3.1-99.0
haskell-cookie 0.4.5-9.1
haskell-cryptonite 0.27-32.0
haskell-data-default 0.7.1.1-87.0
haskell-data-default-class 0.1.2.0-21.1
haskell-data-default-instances-containers 0.0.1-33.1
haskell-data-default-instances-dlist 0.0.1-100.0
haskell-data-default-instances-old-locale 0.0.1-33.1
haskell-data-fix 0.3.0-35.0
haskell-digest 0.0.1.2-22.1
haskell-distributive 0.6.2-40.0
haskell-dlist 1.0-23.0
haskell-doclayout 0.3-45.0
haskell-doctemplates 0.9-40.0
haskell-emojis 0.1-47.0
haskell-erf 2.0.0.0-21.0
haskell-errors 2.3.0-59.1
haskell-file-embed 0.0.13.0-3.1
haskell-glob 0.10.1-28.0
haskell-haddock-library 1.9.0-58.0
haskell-hashable 1.3.0.0-36.0
haskell-hourglass 0.2.12-82.0
haskell-hslua 1.3.0-2.0
haskell-hslua-module-system 0.2.2.1-17.0
haskell-hslua-module-text 0.3.0.1-5.0
haskell-hsyaml 0.2.1.0-52.0
haskell-http 4000.3.15-49.0
haskell-http-client 0.7.6-14.0
haskell-http-client-tls 0.3.5.3-359.0
haskell-http-types 0.12.3-100.0
haskell-hxt 9.3.1.18-196.0
haskell-hxt-charproperties 9.5.0.0-1.0
haskell-hxt-regex-xmlschema 9.2.0.7-2.0
haskell-hxt-unicode 9.0.2.4-22.0
haskell-indexed-traversable 0.1.1-3.1
haskell-integer-logarithms 1.0.3.1-3.1
haskell-ipynb 0.1.0.1-192.0
haskell-jira-wiki-markup 1.3.2-27.0
haskell-juicypixels 3.3.5-37.0
haskell-memory 0.15.0-49.0
haskell-mime-types 0.1.0.9-11.1
haskell-mono-traversable 1.0.15.1-74.0
haskell-network 3.1.2.1-1.0
haskell-network-uri 2.6.3.0-217.0
haskell-old-locale 1.0.0.7-27.1
haskell-old-time 1.1.0.3-27.1
haskell-pandoc-types 1.22-13.0
haskell-pem 0.2.4-114.0
haskell-primitive 0.7.1.0-29.0
haskell-quickcheck 2.14.2-11.0
haskell-random 1.2.0-54.0
haskell-resourcet 1.2.4.2-31.0
haskell-safe 0.3.19-5.1
haskell-scientific 0.3.6.2-53.0
haskell-sha 1.6.4.4-16.1
haskell-skylighting 0.10.2-24.0
haskell-skylighting-core 0.10.2-24.0
haskell-socks 0.6.1-90.0
haskell-split 0.2.3.4-88.0
haskell-splitmix 0.1.0.3-5.0
haskell-streaming-commons 0.2.2.1-28.1
haskell-strict 0.4.0.1-1.0
haskell-syb 0.7.1-8.0
haskell-tagged 0.8.6.1-2.2
haskell-tagsoup 0.14.8-75.0
haskell-temporary 1.3-130.0
haskell-texmath 0.12.0.3-40.0
haskell-text-conversions 0.3.1-62.0
haskell-text-icu 0.7.0.1-37.1
haskell-th-abstraction 0.4.2.0-2.2
haskell-th-compat 0.1-12.0
haskell-these 1.1.1.1-28.0
haskell-time-compat 1.9.5-1.0
haskell-tls 1.5.5-3.0
haskell-transformers-compat 0.6.6-3.1
haskell-typed-process 0.2.6.0-63.0
haskell-unicode-transforms 0.3.7.1-42.0
haskell-uniplate 1.6.13-4.0
haskell-unliftio-core 0.2.0.1-6.1
haskell-unordered-containers 0.2.13.0-11.0
haskell-utf8-string 1.0.1.1-20.0
haskell-uuid-types 1.0.3-58.0
haskell-vector 0.12.1.2-64.0
haskell-vector-algorithms 0.8.0.4-1.0
haskell-x509 1.7.5-137.0
haskell-x509-store 1.6.7-136.0
haskell-x509-system 1.6.6-204.0
haskell-x509-validation 1.6.11-136.0
haskell-xml 1.3.14-27.2
haskell-xml-conduit 1.9.0.0-77.0
haskell-xml-types 0.3.8-5.1
haskell-zip-archive 0.4.1-66.0
haskell-zlib 0.6.2.2-4.0
 178 DevopsBug ReportVery LowLow New installer overwrites pacman mirrors Closed
100%
Task Description

I tried to install archlinux32 using the archinstall installer, which is shipped with the installation medium.
Installation is working fine until pacstrap, where it will crash because all mirrors will return 404. I checked
my connection and it is working and dns also works. When I viewed the /etc/pacman.d/mirrorlist file, I saw that the script
wrote the default archlinux mirrors for the region specified in the installer to the file and the don’t contain the 32bit packages.

 177 Packages: TestingBug ReportMediumMedium [gcc] CPU ISA level is lower than required Closed
100%
Task Description

$ cc –version
cc: CPU ISA level is lower than required

The same happens in a chroot for [staging].

$ pacman -Qo /usr/bin/cc
/usr/bin/cc is owned by gcc 10.2.0-6.0

$ pacman -Q glibc
glibc 2.33-4.0

Does that mean, anything building with gcc is doomed on i686, currently?

 168 DevopsBug ReportMediumLow i486 slaves are no longer working Closed
100%
Task Description

+ exec setarch i486 systemd-nspawn -q -D /var/lib/archbuild/staging-i486/root -E PATH=/usr/local/sbin:/usr/local/bin:/usr/bin –register=no –keep-unit –as-pid2 –bind=/var/cache/archbuild32 pacman -Syuu –noconfirm
error: failed to initialize alpm library

 161 PackagesBug ReportMediumLow buildbot fails to build Closed
100%
Task Description

/usr/bin/true install -e pkg
/usr/bin/true install mock wheel buildbot
cd www/build_common; yarn install –pure-lockfile
yarn install v1.22.10
warning package.json: No license field
warning buildbot-build-common@1.0.0: No license field
[1/4] Resolving packages… [2/4] Fetching packages… make: *** [Makefile:63: frontend_deps] Segmentation fault (core dumped)

 158 PackagesBug ReportMediumLow protobuf python bindings fail to build Closed
100%
Task Description

OK (skipped=10)
Traceback (most recent call last):

File "/usr/lib/python3.9/site-packages/packaging/version.py", line 57, in parse
  return Version(version)
File "/usr/lib/python3.9/site-packages/packaging/version.py", line 298, in __init__
  raise InvalidVersion("Invalid version: '{0}'".format(version))

packaging.version.InvalidVersion: Invalid version: ‘/build/protobuf/src/protobuf’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):

File "/build/protobuf/src/protobuf-3.12.4/python/setup.py", line 251, in <module>
  setup(
File "/usr/lib/python3.9/site-packages/setuptools/__init__.py", line 153, in setup
  return distutils.core.setup(**attrs)
File "/usr/lib/python3.9/distutils/core.py", line 148, in setup
  dist.run_commands()
File "/usr/lib/python3.9/distutils/dist.py", line 966, in run_commands
  self.run_command(cmd)
File "/usr/lib/python3.9/distutils/dist.py", line 985, in run_command
  cmd_obj.run()
File "/usr/lib/python3.9/site-packages/setuptools/command/test.py", line 232, in run
  self.run_tests()
File "/usr/lib/python3.9/contextlib.py", line 124, in __exit__
  next(self.gen)
File "/usr/lib/python3.9/site-packages/setuptools/command/test.py", line 169, in project_on_sys_path
  working_set.__init__()
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 552, in __init__
  self.add_entry(entry)
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 608, in add_entry
  for dist in find_distributions(entry, True):
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 2059, in find_on_path
  path_item_entries = _by_version_descending(filtered)
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 2029, in _by_version_descending
  return sorted(names, key=_by_version, reverse=True)
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 2027, in _by_version
  return [packaging.version.parse(part) for part in parts]
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 2027, in <listcomp>
  return [packaging.version.parse(part) for part in parts]
File "/usr/lib/python3.9/site-packages/packaging/version.py", line 59, in parse
  return LegacyVersion(version)
File "/usr/lib/python3.9/site-packages/packaging/version.py", line 127, in __init__
  warnings.warn(

DeprecationWarning: Creating a LegacyVersion has been deprecated and will be removed in the next major release
=⇒ ERROR: A failure occurred in check().

  Aborting...

=⇒ ERROR: Build failed, check /var/lib/archbuild/staging-pentium4/abaumann/build

both i686 and pentium4

 156 PackagesBug ReportMediumLow Cinnamon fails to start Closed
100%
Task Description

Funny, but actually not really helping:

Feb 17 20:42:17 arch32-stable-pentium4 cinnamon-session[3846]: CRITICAL: t+0.01217s: We failed, but the fail whale is dead. Sorry....
 153 PackagesBug ReportMediumLow plasma cannot be installed or updated Closed
100%
Task Description

:: removing user-manager breaks dependency ‘user-manager’ required by plasma-meta

 150 PackagesBug ReportMediumLow MATE doesn't start up Closed
100%
Task Description

no task description

 149 PackagesBug ReportMediumLow xfce desktop doesn't start Closed
100%
Task Description

no task description

 148 PackagesBug ReportMediumLow xfce4-power-man crashes Closed
100%
Task Description
Feb 12 12:00:29 arch32-testing-pentium4 kernel: audit: type=1130 audit(1613127629.283:106): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@0-9938-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 12 12:00:31 arch32-testing-pentium4 systemd-coredump[9939]: [🡕] Process 9886 (xfce4-power-man) of user 1000 dumped core.
                                                                
                                                                Stack trace of thread 9886:
                                                                #0  0x00000000b6fb37b4 g_log_structured_array (libglib-2.0.so.0 + 0x557b4)
                                                                #1  0x00000000b6fb3cdc g_log_default_handler (libglib-2.0.so.0 + 0x55cdc)
                                                                #2  0x00000000b6fb5224 g_logv (libglib-2.0.so.0 + 0x57224)
                                                                #3  0x00000000b6fb5485 g_log (libglib-2.0.so.0 + 0x57485)
                                                                #4  0x000000000041a4cf n/a (xfce4-power-manager + 0x64cf)
                                                                #5  0x00000000b6b5498d __libc_start_main (libc.so.6 + 0x1e98d)
                                                                #6  0x000000000041aa75 n/a (xfce4-power-manager + 0x6a75)
                                                                
                                                                Stack trace of thread 9901:
                                                                #0  0x00000000b7f12549 __kernel_vsyscall (linux-gate.so.1 + 0x549)
                                                                #1  0x00000000b6c22117 __poll (libc.so.6 + 0xec117)
                                                                #2  0x00000000b7000125 n/a (libglib-2.0.so.0 + 0xa2125)
                                                                #3  0x00000000b6faba46 g_main_context_iteration (libglib-2.0.so.0 + 0x4da46)
                                                                #4  0x00000000b6fabaa1 n/a (libglib-2.0.so.0 + 0x4daa1)
                                                                #5  0x00000000b6fda93e n/a (libglib-2.0.so.0 + 0x7c93e)
                                                                #6  0x00000000b6cfe39f start_thread (libpthread.so.0 + 0x839f)
                                                                #7  0x00000000b6c2db6a __clone (libc.so.6 + 0xf7b6a)
Feb 12 12:00:31 arch32-testing-pentium4 kernel: audit: type=1131 audit(1613127631.393:107): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@0-9938-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
 147 PackagesBug ReportMediumLow kpgp fails at startup Closed
100%
Task Description
Feb 12 11:57:48 arch32-testing-pentium4 audit[9829]: USER_LOGIN pid=9829 uid=0 auid=1000 ses=7 msg='op=login id=1000 exe="/usr/bin/lightdm" hostname=arch32-testing-pentium4 addr=? terminal=/dev/tty7 res=success'
Feb 12 11:57:48 arch32-testing-pentium4 kernel: audit: type=1112 audit(1613127468.816:104): pid=9829 uid=0 auid=1000 ses=7 msg='op=login id=1000 exe="/usr/bin/lightdm" hostname=arch32-testing-pentium4 addr=? terminal=/dev/tty7 res=success'
Feb 12 11:57:55 arch32-testing-pentium4 kaccess[9880]: Xlib XKB extension major= 1  minor= 0
Feb 12 11:57:56 arch32-testing-pentium4 kaccess[9880]: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-guest'
Feb 12 11:57:58 arch32-testing-pentium4 kaccess[9880]: "Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"
Feb 12 11:58:00 arch32-testing-pentium4 kgpg[9909]: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-guest'
Feb 12 11:58:01 arch32-testing-pentium4 kgpg[9909]: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-guest'
Feb 12 11:58:01 arch32-testing-pentium4 kgpg[9909]: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-guest'
Feb 12 11:58:01 arch32-testing-pentium4 kgpg[9909]: "Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"

 142 PackagesBug ReportMediumLow gnome-terminal doesn't start Closed
100%
Task Description
# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Could not connect: Connection refused

As this is the case since months, I cannot imagine somebody is still using Gnome on Archlinux32..

 136 PackagesBug ReportMediumLow Haskell probably completely fails to rebuild Closed
100%
Task Description
Configuring attoparsec-0.13.2.4...
Error:
    The following packages are broken because other packages they depend on are missing. These broken packages must be rebuilt before they can be used.
installed package tasty-1.3.1 is broken due to missing package ansi-terminal-0.11-2SXi8ZhU18i2uWLidRUotS, async-2.2.2-K8T9LglWxlG5HgD5vvGjbo, optparse-applicative-0.16.1.0-JDPEASK1GJS1Nsq2qjjZCq
installed package tasty-quickcheck-0.10.1.2 is broken due to missing package QuickCheck-2.14.2-io0WylueSG4seqSTUQCKM, optparse-applicative-0.16
 133 PackagesBug ReportMediumLow libao and libpulse mixup Closed
100%
Task Description
resolving dependencies...
warning: cannot resolve "libpulse.so=0-32", a dependency of "libao"
warning: cannot resolve "libpulse-simple.so=0-32", a dependency of "libao"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libao

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libpulse.so=0-32' required by libao
:: unable to satisfy dependency 'libpulse-simple.so=0-32' required by libao
 131 PackagesBug ReportMediumLow libseccomp doesn't build in python bindings Closed
100%
Task Description

no task description

 130 PackagesBug ReportMediumLow user-manager and plasma-meta are in conflict Closed
100%
Task Description

:: removing user-manager breaks dependency ‘user-manager’ required by plasma-meta

 125 PackagesBug ReportMediumLow seamonkey broken on i686 Closed
100%
Task Description

breaks in more SIMD optimizations.

 124 PackagesBug ReportMediumLow mutter and gnome-shell are in confllict Closed
100%
Task Description

:: installing mutter (3.38.1-1.1) breaks dependency ‘libmutter-6.so=0-32’ required by gnome-shell

 115 PackagesBug ReportMediumLow gnome doesn't start Closed
100%
Task Description

gnome-shell segfaults in libmutter.

                                                               Stack trace of thread 1009:
                                                               #0  0x00000000b64d5436 n/a (libmutter-cogl-6.so.0 + 0xe436)
                                                               #1  0x00000000b64d809c n/a (libmutter-cogl-6.so.0 + 0x1109c)
                                                               #2  0x00000000b653edb9 n/a (libmutter-cogl-6.so.0 + 0x77db9)
                                                               #3  0x00000000b64f8fc5 cogl_flush (libmutter-cogl-6.so.0 + 0x31fc5)
                                                               #4  0x00000000b6549154 cogl_onscreen_swap_buffers_with_damage (libmutter-cogl-6.so.0 + 0x82154)
                                                               #5  0x00000000b6c59f73 n/a (libmutter-clutter-6.so.0 + 0x10ff73)
                                                               #6  0x00000000b6c53cf2 n/a (libmutter-clutter-6.so.0 + 0x109cf2)
                                                               #7  0x00000000b6c54747 n/a (libmutter-clutter-6.so.0 + 0x10a747)
                                                               #8  0x00000000b6bf52ad n/a (libmutter-clutter-6.so.0 + 0xab2ad)
                                                               #9  0x00000000b7703bde g_main_context_dispatch (libglib-2.0.so.0 + 0x4dbde)
                                                               #10 0x00000000b7752962 n/a (libglib-2.0.so.0 + 0x9c962)
                                                               #11 0x00000000b7702299 g_main_loop_run (libglib-2.0.so.0 + 0x4c299)
                                                               #12 0x00000000b697f216 meta_run (libmutter-6.so.0 + 0xb9216)
                                                               #13 0x000000000043144e n/a (gnome-shell + 0x244e)
                                                               #14 0x00000000b7cd900e __libc_start_main (libc.so.6 + 0x1f00e)
                                                               #15 0x0000000000431635 n/a (gnome-shell + 0x2635)
 113 PackagesBug ReportVery LowLow [leafpad]: segfaults Closed
100%
Task Description

start leafpad
everything looks fine
type or paste anything and it segfaults with this error in dmesg

leafpad[550]: segfault at 1 ip b77adf13 sp bfd0eaec error 4 in libgobject-2.0.so.0.6400.3[b7787000+2f000]
 112 PackagesBug ReportVery LowLow [lxpanel]: segfaults on startup Closed
100%
Task Description

# pacman -Sy lxde
reboot and start lxsession
lxpanel will crash immediately, with this error in dmesg

pcmanfm[501]: segfault at 2d ip b74823cf sp bf9dd0d0 error 4 in libpango-1.0.so.0.4600.0[b7466000+29000]

lxpanel does not have this problem with GTK3
# pacman -Sy lxde-gtk3
works as expectd

 106 PackagesBug ReportMediumLow packages are unstripped? Closed
100%
Task Description

looks, like the new devtools do not strip packages anymore - maybe it was only an intermediate version, that lacked automatic stripping.

 105 Packages: StableBug ReportMediumLow chromium crash in blocked syscalls (libseccomp) Closed
100%
Task Description

chromium apparently also has trouble in some seccomp jailing:

 ../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
[1201:1210:0227/131355.020958:FATAL:gpu_data_manager_impl_private.cc(990)] The display compositor is frequently crashing. Goodbye.

[1]+  Trace/breakpoint trap   (core dumped) chromium
Showing tasks 151 - 200 of 351 Page 4 of 8<<First - 2 - 3 - 4 - 5 - 6 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing