Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategoryTask TypePrioritySeverity  descSummaryStatusProgress
231PackagesBug ReportMediumLow[libffi] packages needing a rebuildNew
0%
Task Description
'pypy_plugin.so' -> '/build/uwsgi/pkg/uwsgi-plugin-pypy/usr/lib/uwsgi/pypy_plugin.so'
install: creating directory '/build/uwsgi/pkg/uwsgi-plugin-pypy/opt'
install: creating directory '/build/uwsgi/pkg/uwsgi-plugin-pypy/opt/pypy'
install: creating directory '/build/uwsgi/pkg/uwsgi-plugin-pypy/opt/pypy/site-packages'
'uwsgidecorators.py' -> '/build/uwsgi/pkg/uwsgi-plugin-pypy/opt/pypy/site-packages/uwsgidecorators.py'
pypy: error while loading shared libraries: libffi.so.6: cannot open shared object file: No such file or directory
 230 PackagesBug ReportVery LowLow [SPAM] Closed
100%
Task Description

no task description

 229 PackagesBug ReportVery LowLow SPAM Closed
100%
Task Description

no task description

228PackagesBug ReportMediumLow[icu69] not updated packagesNew
0%
Task Description

starting to collect them here packages which require icu69 (and have thus not been rebuilt
for icu 70 yet):

- abiword: libical (rescheduled build)

 227 PackagesBug ReportMediumLow [object-introspection] [libosinfo] rebuild issue Closed
100%
Task Description

affects: tracker-miners tracker3-miners gnome-documents gnome-music gnome-photos nautilus

 226 PackagesBug ReportVery LowLow claws-mail needs to be recompiled on i686 Closed
100%
Task Description

On i686, with testing and without testing claws mail is broken:
$ claws-mail
claws-mail: error while loading shared libraries: liblber-2.4.so.2: cannot open shared object file: No such file or directory

While I run Parabola i686, the repositories being used come from Archlinux 32:
$ pacman -sS claws-mail
extra/claws-mail 4.0.0-2.0 [installed]

  A GTK+ based e-mail client

$ pacman -Q -o /usr/lib/liblber*
/usr/lib/liblber.so is owned by libldap 2.6.0-2.4
/usr/lib/liblber.so.2 is owned by libldap 2.6.0-2.4
/usr/lib/liblber.so.2.0.200 is owned by libldap 2.6.0-2.4
$ pacman -sS libldap
core/libldap 2.6.0-2.4 [installed]

  Lightweight Directory Access Protocol (LDAP) client libraries

$ pacman -Q -l libldap | grep /usr/lib/liblber
libldap /usr/lib/liblber.so
libldap /usr/lib/liblber.so.2
libldap /usr/lib/liblber.so.2.0.200

So it’s most probably broken on Arch Linux 32 as well.

Denis.

 223 PackagesBug ReportVery LowLow asp32 is broken Closed
100%
Task Description

It needs to be updated to reflect the switch to gitlab.archlinux.org

 222 PackagesBug ReportVery LowLow GNOME broken on pentium4 Closed
100%
Task Description

I’m getting a “BadAccess” Xorg error. I think this is happening because the packaged version has been compiled against libraries which have meanwhile been upgraded.

Just to get to this point I had to install “libldap24” and “libffi7”.

 219 PackagesBug ReportVery LowLow [postgresql] and [postgresql-old-upgrade] links against ...Closed
100%
Task Description

After my most recent sysupgrade, postgresql refuses to start. The main postgres binary appears to be linked to multiple versions of libicu:

$  ldd /usr/bin/postgres | grep icu
	libicui18n.so.69 => /usr/lib/libicui18n.so.69 (0xb6c00000)
	libicuuc.so.69 => /usr/lib/libicuuc.so.69 (0xb6a0c000)
	libicuuc.so.70 => /usr/lib/libicuuc.so.70 (0xb6582000)
	libicudata.so.69 => /usr/lib/libicudata.so.69 (0xb4601000)
	libicudata.so.70 => /usr/lib/libicudata.so.70 

(0xb27a4000)

Installing the icu69 compatibility package made it work again, but it doesn’t look right that it should link against multiple versions.

 218 PackagesBug ReportMediumLow [nss] shlibsign segfaults on IA-32 Closed
100%
Task Description

subprocess.CalledProcessError: Command ‘[’/build/nss/src/dist/Release/bin/shlibsign’, ‘-v’, ‘-i’, ‘/build/nss/src/dist/Release/lib/libfreebl3.so’]’ died with <Signals.SIGSEGV: 11>.

 217 PackagesBug ReportMediumLow [llvm12] shim needed Closed
100%
Task Description

librsvg/rust fails because llvm is now 13 and we don’t have the llvm12-libs around anymore.
Will make a shim package.

 215 PackagesBug ReportMediumLow firefox 93.0 (and seamonkey 2.53.9.1) doesn't build Closed
100%
Task Description
 2:52.15 error: `[u32; 2]` is forbidden as the type of a const generic parameter
 2:52.15   --> /build/firefox/src/firefox-93.0/third_party/rust/packed_simd/src/codegen/llvm.rs:20:44
 2:52.15    |
 2:52.15 20 | pub unsafe fn __shuffle_vector2<const IDX: [u32; 2], T, U>(x: T, y: T) -> U
 2:52.15    |                                            ^^^^^^^^
 2:52.15    |
 2:52.15    = note: the only supported types are integers, `bool` and `char`
 2:52.15    = help: more complex types are supported with `#![feature(adt_const_params)]`
 2:52.15 error: `[u32; 4]` is forbidden as the type of a const generic parameter
 2:52.15   --> /build/firefox/src/firefox-93.0/third_party/rust/packed_simd/src/codegen/llvm.rs:30:44
 2:52.15    |
 2:52.15 30 | pub unsafe fn __shuffle_vector4<const IDX: [u32; 4], T, U>(x: T, y: T) -> U
 2:52.15    |                                            ^^^^^^^^
 2:52.15    |
 2:52.15    = note: the only supported types are integers, `bool` and `char`
 2:52.15    = help: more complex types are supported with `#![feature(adt_const_params)]`
 2:52.15 error: `[u32; 8]` is forbidden as the type of a const generic parameter
 2:52.15   --> /build/firefox/src/firefox-93.0/third_party/rust/packed_simd/src/codegen/llvm.rs:40:44
 2:52.15    |
 2:52.15 40 | pub unsafe fn __shuffle_vector8<const IDX: [u32; 8], T, U>(x: T, y: T) -> U
 2:52.15    |                                            ^^^^^^^^
 2:52.15    |
 2:52.15    = note: the only supported types are integers, `bool` and `char`
 2:52.15    = help: more complex types are supported with `#![feature(adt_const_params)]`
 2:52.15 error: `[u32; 16]` is forbidden as the type of a const generic parameter
 2:52.15   --> /build/firefox/src/firefox-93.0/third_party/rust/packed_simd/src/codegen/llvm.rs:50:45
 2:52.15    |
 2:52.15 50 | pub unsafe fn __shuffle_vector16<const IDX: [u32; 16], T, U>(x: T, y: T) -> U
 2:52.15    |                                             ^^^^^^^^^
 2:52.15    |
 2:52.15    = note: the only supported types are integers, `bool` and `char`
 2:52.15    = help: more complex types are supported with `#![feature(adt_const_params)]`
 2:52.15 error: `[u32; 32]` is forbidden as the type of a const generic parameter
 2:52.15   --> /build/firefox/src/firefox-93.0/third_party/rust/packed_simd/src/codegen/llvm.rs:60:45
 2:52.15    |
 2:52.15 60 | pub unsafe fn __shuffle_vector32<const IDX: [u32; 32], T, U>(x: T, y: T) -> U
 2:52.15    |                                             ^^^^^^^^^
 2:52.15    |
 2:52.15    = note: the only supported types are integers, `bool` and `char`
 2:52.15    = help: more complex types are supported with `#![feature(adt_const_params)]`
 2:52.15 error: `[u32; 64]` is forbidden as the type of a const generic parameter
 2:52.15   --> /build/firefox/src/firefox-93.0/third_party/rust/packed_simd/src/codegen/llvm.rs:70:45
 2:52.15    |
 2:52.15 70 | pub unsafe fn __shuffle_vector64<const IDX: [u32; 64], T, U>(x: T, y: T) -> U
 2:52.15    |                                             ^^^^^^^^^
 2:52.15    |
 2:52.15    = note: the only supported types are integers, `bool` and `char`
 2:52.15    = help: more complex types are supported with `#![feature(adt_const_params)]`
 2:52.35    Compiling num_cpus v1.13.0
 2:53.13    Compiling fluent-langneg v0.13.0
 2:53.15    Compiling intl_pluralrules v7.0.1
 2:53.59    Compiling intl-memoizer v0.5.1
 2:55.32    Compiling gl_generator v0.14.0
 2:55.37    Compiling cose-c v0.1.5
 2:55.96    Compiling time v0.1.43
 2:56.01    Compiling iovec v0.1.4
 2:56.05    Compiling atty v0.2.14
 2:56.21 For more information about this error, try `rustc --explain E0557`.
 2:56.23    Compiling net2 v0.2.37
 2:56.24 The following warnings were emitted during compilation:
 2:56.25 warning: Cannot set `RUSTC_BOOTSTRAP=1` from build script of `packed_simd v0.3.4 (https://github.com/hsivonen/packed_simd?rev=6a16f954950401b92b4e220fbf2dfaf6f00e1fb2#6a16f954)`.
 2:56.25 note: Crates cannot set `RUSTC_BOOTSTRAP` themselves, as doing so would subvert the stability guarantees of Rust for your project.
 2:56.25 error: could not compile `packed_simd` due to 13 previous errors
 2:56.25 warning: build failed, waiting for other jobs to finish...
 3:17.66 error: build failed
 213 PackagesBug ReportMediumLow [libffi] libffi.so7/libffi.so.8 major ABI bump Closed
100%
Task Description

make and guile made it half (and broken) to stable.
breaking the cycle required a shim package libffi33 in build-support.
packages depending of libffi are rescheduled and need to be rebuilt first, pushing libffi.so.8 to stable now would make
‘make/guile’ work again, but break a lot of other stuff!

209PackagesBug ReportVery LowLowIntel High Definition Audio issue.Unconfirmed
0%
Task Description

I am using Arch Linux 32 latest version on Sony VAIO VGN-FS215Z . The following is the audio device:

-fs215z:~$ lspci | grep -i audio

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)

When I boot the system after some time getting crackling sound in speaker. Sometimes it stops after few minutes and sometimes continue to sound. Really annoying. I am not getting the normal audio in any application. This problem was there in debian based OSs also but not there in any other OS.

Please help.

 206 PackagesBug ReportVery LowLow SPAM Closed
100%
Task Description

no task description

 205 PackagesBug ReportVery LowLow SPAM Closed
100%
Task Description

no task description

 204 PackagesBug ReportMediumLow gdbm 1.21 fails in test 31 (convert new database format ...Closed
100%
Task Description

The bug report has been sent upstream to GDBM directly. This is too important to just ignore the failure.. (make check || true)

 203 PackagesBug ReportVery LowLow SPAM Closed
100%
Task Description

SPAM

 202 PackagesBug ReportVery LowLow SPAM Closed
100%
Task Description

SPAM

 201 PackagesBug ReportVery LowLow SPAM Closed
100%
Task Description

SPAM

 200 PackagesBug ReportVery LowLow SPAM Closed
100%
Task Description

SPAM

 199 PackagesBug ReportVery LowLow SPAM Closed
100%
Task Description

SPAM

196PackagesBug ReportMediumLowupdate filesystemNew
0%
Task Description

b3da2fc1c25065a1bd09f9930eeed1d11dc312e4 only updated half the package - we’re missing:

- update the logo
- update the url (?)
- only if both are done: updating the hash on top of the PKGBUILD

 195 Packages: TestingBug ReportVery LowLow libreoffice-fresh and libreoffice-still will not start  Closed
100%
Task Description

There is a problem with libreoffice-fresh and libreoffice-still which appears to be caused by the last update to boost and boost-libs which are now at version 1.76.0-1.3

~]$ libreoffice
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_locale.so.1.75.0: cannot open shared object file: No such file or directory
 194 PackagesBug ReportVery LowLow go 1.16 doesn't build. Closed
100%
Task Description

The go build fails with this error:

unsupported setting GO386=387. Consider using GO386=softfloat instead.

go tool dist: FAILED: /build/go/src/go/pkg/tool/linux_386/compile -std -pack -o /tmp/go-tool-dist-250139381/runtime/internal/atomic/_go_.a -p runtime/internal/atomic -importcfg /tmp/go-tool-dist-250139381/runtime/internal/atomic/importcfg -asmhdr /tmp/go-tool-dist-250139381/runtime/internal/atomic/go_asm.h -symabis /tmp/go-tool-dist-250139381/runtime/internal/atomic/symabis /build/go/src/go/src/runtime/internal/atomic/atomic_386.go /build/go/src/go/src/runtime/internal/atomic/stubs.go /build/go/src/go/src/runtime/internal/atomic/unaligned.go: exit status 1
go tool dist: open /tmp/go-tool-dist-250139381/runtime/internal/atomic/_go_.a: no such file or directory
go tool dist: open /tmp/go-tool-dist-250139381/runtime/internal/sys/_go_.a: no such file or directory
go tool dist: open /tmp/go-tool-dist-250139381/internal/cpu/_go_.a: no such file or directory
unsupported setting GO386=387. Consider using GO386=softfloat instead.

go tool dist: FAILED: /build/go/src/go/pkg/tool/linux_386/compile -std -pack -o /tmp/go-tool-dist-250139381/internal/cpu/_go_.a -p internal/cpu -importcfg /tmp/go-tool-dist-250139381/internal/cpu/importcfg -asmhdr /tmp/go-tool-dist-250139381/internal/cpu/go_asm.h -symabis /tmp/go-tool-dist-250139381/internal/cpu/symabis /build/go/src/go/src/internal/cpu/cpu.go /build/go/src/go/src/internal/cpu/cpu_386.go /build/go/src/go/src/internal/cpu/cpu_x86.go: exit status 1
unsupported setting GO386=387. Consider using GO386=softfloat instead.

go tool dist: FAILED: /build/go/src/go/pkg/tool/linux_386/compile -std -pack -o /tmp/go-tool-dist-250139381/runtime/internal/sys/_go_.a -p runtime/internal/sys -importcfg /tmp/go-tool-dist-250139381/runtime/internal/sys/importcfg -asmhdr /tmp/go-tool-dist-250139381/runtime/internal/sys/go_asm.h -symabis /tmp/go-tool-dist-250139381/runtime/internal/sys/symabis /build/go/src/go/src/runtime/internal/sys/arch.go /build/go/src/go/src/runtime/internal/sys/arch_386.go /build/go/src/go/src/runtime/internal/sys/intrinsics_common.go /build/go/src/go/src/runtime/internal/sys/intrinsics_stubs.go /build/go/src/go/src/runtime/internal/sys/stubs.go /build/go/src/go/src/runtime/internal/sys/sys.go /build/go/src/go/src/runtime/internal/sys/zgoarch_386.go /build/go/src/go/src/runtime/internal/sys/zgoos_linux.go /build/go/src/go/src/runtime/internal/sys/zversion.go: exit status 1
=⇒ ERROR: A failure occurred in build().

  Aborting...

Upstream discussion about this bug: https://github.com/golang/go/issues/44500

Someone mentions a fix, but it doesn’t apply for non SSE2 devices.

 193 Packages: StableBug ReportMediumLow pacman does not recognize sse2 on via processor Closed
100%
Task Description

/proc/cpuinfo:
processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 15
model name : VIA Nano U3400@800MHz
stepping : 10
cpu MHz : 798.016
cache size : 2048 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fdiv_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush acpi mmx fxsr sse sse2 ss tm syscall nx lm constant_tsc arch_perfmon rep_good cpuid pni monitor vmx est tm2 ssse3 cx16 xtpr sse4_1 popcnt rng rng_en ace ace_en ace2 phe phe_en pmm pmm_en lahf_lm tpr_shadow vnmi vpid ida
vmx flags : vnmi tsc_offset vtpr
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips : 1596.53
clflush size : 64
cache_alignment : 128
address sizes : 36 bits physical, 48 bits virtual
power management:

Other machine, also with via processor:

/proc/cpuinfo:
processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 13
model name : VIA C7-D Processor 1800MHz
stepping : 0
cpu MHz : 1596.326
cache size : 128 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fdiv_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge cmov pat clflush acpi mmx fxsr sse sse2 tm nx cpuid pni est tm2 xtpr rng rng_en ace ace_en ace2 ace2_en phe phe_en pmm pmm_en
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips : 3193.67
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 32 bits virtual
power management:

All the __builtin_cpu_supports() and __builtin_cpu_is() tests fail. Thus, pacman thinks, it’s not capable of sse2 and installs i686 packages instead of pentium4 ones.

Should we complain at gcc upstream? How does the kernel compile this line in /proc/cpuinfo? What checks does it perform?

 189 PackagesBug ReportMediumLow [mutter] test segfaults Closed
100%
Task Description
 50/105 mutter:clutter+clutter/conform / actor-clone                                                   FAIL            0.13s   killed by signal 11 SIGSEGV
 55/105 mutter:clutter+clutter/conform / actor-layout                                                  FAIL            0.13s   killed by signal 11 SIGSEGV
 61/105 mutter:clutter+clutter/conform / actor-shader-effect                                           FAIL            0.13s   killed by signal 11 SIGSEGV
 70/105 mutter:clutter+clutter/conform / timeline                                                      FAIL            0.12s   killed by signal 11 SIGSEGV
 71/105 mutter:clutter+clutter/conform / timeline-interpolate                                          FAIL            1.63s   killed by signal 11 SIGSEGV
 73/105 mutter:clutter+clutter/conform / timeline-rewind                                               FAIL            0.12s   killed by signal 11 SIGSEGV
 83/105 mutter:core+mutter/stacking / closed-transient-no-input-parent-delayed-focus-default-cancelled FAIL            0.14s   killed by signal 11 SIGSEGV
 84/105 mutter:core+mutter/stacking / closed-transient-no-input-parents                                FAIL            0.13s   killed by signal 11 SIGSEGV
104/105 mutter:core+mutter/ref-test/sanity / ref-test-sanity                                           FAIL            0.13s   killed by signal 11 SIGSEGV

For now I’m just ignoring test results.

 188 PackagesBug ReportMediumLow [gdal] python bindings don't build on i486 (stack smash ...Closed
100%
Task Description
#0  0xb79a0c6d in raise () from /usr/lib/libc.so.6
#1  0xb79892c6 in abort () from /usr/lib/libc.so.6
#2  0xb79e449c in __libc_message () from /usr/lib/libc.so.6
#3  0xb7a6ff4c in __fortify_fail () from /usr/lib/libc.so.6
#4  0xb7a6ff19 in __stack_chk_fail () from /usr/lib/libc.so.6
#5  0xb7182004 in ?? ()
   from /usr/lib/python3.9/site-packages/numpy/core/_multiarray_umath.cpython-39-i386-linux-gnu.so
#6  0xb7179c87 in ?? ()
   from /usr/lib/python3.9/site-packages/numpy/core/_multiarray_umath.cpython-39-i386-linux-gnu.so
#7  0xb6fd589a in PyInit__multiarray_umath ()
   from /usr/lib/python3.9/site-packages/numpy/core/_multiarray_umath.cpython-39-i386-linux-gnu.so
#8  0xb7d07f35 in ?? () from /usr/lib/libpython3.9.so.1.0
#9  0xb7c37301 in ?? () from /usr/lib/libpython3.9.so.1.0
#10 0xb7c46897 in PyObject_Call () from /usr/lib/libpython3.9.so.1.0
#11 0xb7c2c557 in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0
#12 0xb7c260b9 in ?? () from /usr/lib/libpython3.9.so.1.0
#13 0xb7c36b05 in _PyFunction_Vectorcall () from /usr/lib/libpython3.9.so.1.0
#14 0xb7c2b4e5 in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0
#15 0xb7c36938 in _PyFunction_Vectorcall () from /usr/lib/libpython3.9.so.1.0
#16 0xb7c2794c in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0
#17 0xb7c36938 in _PyFunction_Vectorcall () from /usr/lib/libpython3.9.so.1.0
#18 0xb7c2774a in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0
#19 0xb7c36938 in _PyFunction_Vectorcall () from /usr/lib/libpython3.9.so.1.0
#20 0xb7c2774a in _PyEval_EvalFrameDefault () from /usr/lib/libpython3.9.so.1.0

Builds fine on i686 and pentium4, so I suspect a i486 issue in numpy.

 187 DevopsBug ReportMediumLow linux-pae is for x86_64? Closed
100%
Task Description

This seems to be a problem of either update-archlinux32-package in devops or of the (commented) code path in the PKGBUILD which gets executed by this script.

 186 PackagesBug ReportMediumLow [pacman] /etc/makeconf.conf for i486 contains flags res ...Closed
100%
Task Description

-fstack-clash-protection
-fcf-protection

We have to investiagate if one of them (or both) are
introducing illegal opcodes for i486..

 185 PackagesBug ReportMediumLow blender doesn't build Closed
100%
Task Description
- openexr missing header files?
/usr/include/openvdb/Types.h:10:10: fatal error: OpenEXR/half.h: No such file or directory
   10 | #include <OpenEXR/half.h>
      |          ^~~~~~~~~~~~~~~~
compilation terminated.

openexr 2->3 upgrade breaks blender in openvdb

openvdb needs numpy, which needs cythonize, which segfaults.
 184 Packages: StableBug ReportVery LowLow [ffmpeg] error loading share library libaom.so.2 Closed
100%
Task Description

$ ffmpeg -v
ffmpeg: error while loading shared libraries: libaom.so.2: cannot open shared object file: No such file or directory

From pacman:
extra/aom 3.0.0-2.1 [installed]

 183 PackagesBug ReportVery LowLow [gedit] error loading shared library libtepl-5.so.0 Closed
100%
Task Description

$ gedit
gedit: error while loading shared libraries: libtepl-5.so.0: cannot open shared object file: No such file or directory

Exist extra/tepl 6.00.0-1.0 in the pacman.
I’m not sure if gedit is old or can only be used with an older version of tepl, which is not possible because i get tepl from 3 days.

 182 Packages: StableBug ReportVery LowLow [blender] cannot resolve dependency to opensubdiv Closed
100%
Task Description

# pacman -S blender resolving dependencies… warning: cannot resolve "opensubdiv”, a dependency of "blender” :: The following package cannot be upgraded due to unresolvable dependencies:

    blender

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'opensubdiv’ required by blender

 181 PackagesBug ReportMediumLow rust 1.51.0 recompilation issues Closed
100%
Task Description
   Compiling same-file v1.0.6
     |                        ^^^
     = note: `-D non-fmt-panic` implied by `-D warnings`
     = note: this is no longer accepted in Rust 2021
help: add a "{}" format string to Display the message
     |
1493 |                 panic!("{}", out);
     |                        ^^^^^
help: or use std::panic::panic_any instead
     |
1493 |                 std::panic::panic_any(out);
     |                 ^^^^^^^^^^^^^^^^^^^^^^

Brilliantly fast changing language..

 180 Packages: StableBug ReportVery LowLow Pandoc requires specific-version haskell dependencies Closed
100%
Task Description
# pandoc --version
pandoc: error while loading shared libraries: libHSzip-archive-0.4.1-4yLWnBS0zifKkvfHVbmUo1-ghc8.10.2.so: cannot open shared object file: No such file or directory
<code>

Versions:
<code>
# pacman -Q | grep haskell
haskell-aeson 1.5.4.1-19.0
haskell-aeson-pretty 0.8.8-94.0
haskell-ansi-terminal 0.11-17.0
haskell-asn1-encoding 0.9.6-58.0
haskell-asn1-parse 0.9.5-58.0
haskell-asn1-types 0.3.4-37.0
haskell-assoc 1.0.2-27.0
haskell-async 2.2.2-40.0
haskell-attoparsec 0.13.2.4-36.0
haskell-base-compat 0.11.2-4.2
haskell-base-compat-batteries 0.11.2-11.0
haskell-base-orphans 0.8.3-14.0
haskell-base16-bytestring 0.1.1.7-3.0
haskell-base64-bytestring 1.2.0.1-3.0
haskell-basement 0.0.11-10.1
haskell-bifunctors 5.5.8-13.0
haskell-blaze-builder 0.4.2.1-2.1
haskell-blaze-html 0.9.1.2-57.0
haskell-blaze-markup 0.8.2.7-41.0
haskell-byteable 0.1.1-22.1
haskell-case-insensitive 1.2.1.0-39.0
haskell-cereal 0.5.8.1-9.0
haskell-citeproc 0.3.0.9-9.0
haskell-cmdargs 0.10.21-1.0
haskell-colour 2.3.5-75.0
haskell-commonmark 0.1.1.2-2.0
haskell-commonmark-extensions 0.2.0.3-1.0
haskell-commonmark-pandoc 0.2.0.1-24.0
haskell-comonad 5.0.6-58.0
haskell-conduit 1.3.4-3.0
haskell-conduit-extra 1.3.5-70.0
haskell-connection 0.3.1-99.0
haskell-cookie 0.4.5-9.1
haskell-cryptonite 0.27-32.0
haskell-data-default 0.7.1.1-87.0
haskell-data-default-class 0.1.2.0-21.1
haskell-data-default-instances-containers 0.0.1-33.1
haskell-data-default-instances-dlist 0.0.1-100.0
haskell-data-default-instances-old-locale 0.0.1-33.1
haskell-data-fix 0.3.0-35.0
haskell-digest 0.0.1.2-22.1
haskell-distributive 0.6.2-40.0
haskell-dlist 1.0-23.0
haskell-doclayout 0.3-45.0
haskell-doctemplates 0.9-40.0
haskell-emojis 0.1-47.0
haskell-erf 2.0.0.0-21.0
haskell-errors 2.3.0-59.1
haskell-file-embed 0.0.13.0-3.1
haskell-glob 0.10.1-28.0
haskell-haddock-library 1.9.0-58.0
haskell-hashable 1.3.0.0-36.0
haskell-hourglass 0.2.12-82.0
haskell-hslua 1.3.0-2.0
haskell-hslua-module-system 0.2.2.1-17.0
haskell-hslua-module-text 0.3.0.1-5.0
haskell-hsyaml 0.2.1.0-52.0
haskell-http 4000.3.15-49.0
haskell-http-client 0.7.6-14.0
haskell-http-client-tls 0.3.5.3-359.0
haskell-http-types 0.12.3-100.0
haskell-hxt 9.3.1.18-196.0
haskell-hxt-charproperties 9.5.0.0-1.0
haskell-hxt-regex-xmlschema 9.2.0.7-2.0
haskell-hxt-unicode 9.0.2.4-22.0
haskell-indexed-traversable 0.1.1-3.1
haskell-integer-logarithms 1.0.3.1-3.1
haskell-ipynb 0.1.0.1-192.0
haskell-jira-wiki-markup 1.3.2-27.0
haskell-juicypixels 3.3.5-37.0
haskell-memory 0.15.0-49.0
haskell-mime-types 0.1.0.9-11.1
haskell-mono-traversable 1.0.15.1-74.0
haskell-network 3.1.2.1-1.0
haskell-network-uri 2.6.3.0-217.0
haskell-old-locale 1.0.0.7-27.1
haskell-old-time 1.1.0.3-27.1
haskell-pandoc-types 1.22-13.0
haskell-pem 0.2.4-114.0
haskell-primitive 0.7.1.0-29.0
haskell-quickcheck 2.14.2-11.0
haskell-random 1.2.0-54.0
haskell-resourcet 1.2.4.2-31.0
haskell-safe 0.3.19-5.1
haskell-scientific 0.3.6.2-53.0
haskell-sha 1.6.4.4-16.1
haskell-skylighting 0.10.2-24.0
haskell-skylighting-core 0.10.2-24.0
haskell-socks 0.6.1-90.0
haskell-split 0.2.3.4-88.0
haskell-splitmix 0.1.0.3-5.0
haskell-streaming-commons 0.2.2.1-28.1
haskell-strict 0.4.0.1-1.0
haskell-syb 0.7.1-8.0
haskell-tagged 0.8.6.1-2.2
haskell-tagsoup 0.14.8-75.0
haskell-temporary 1.3-130.0
haskell-texmath 0.12.0.3-40.0
haskell-text-conversions 0.3.1-62.0
haskell-text-icu 0.7.0.1-37.1
haskell-th-abstraction 0.4.2.0-2.2
haskell-th-compat 0.1-12.0
haskell-these 1.1.1.1-28.0
haskell-time-compat 1.9.5-1.0
haskell-tls 1.5.5-3.0
haskell-transformers-compat 0.6.6-3.1
haskell-typed-process 0.2.6.0-63.0
haskell-unicode-transforms 0.3.7.1-42.0
haskell-uniplate 1.6.13-4.0
haskell-unliftio-core 0.2.0.1-6.1
haskell-unordered-containers 0.2.13.0-11.0
haskell-utf8-string 1.0.1.1-20.0
haskell-uuid-types 1.0.3-58.0
haskell-vector 0.12.1.2-64.0
haskell-vector-algorithms 0.8.0.4-1.0
haskell-x509 1.7.5-137.0
haskell-x509-store 1.6.7-136.0
haskell-x509-system 1.6.6-204.0
haskell-x509-validation 1.6.11-136.0
haskell-xml 1.3.14-27.2
haskell-xml-conduit 1.9.0.0-77.0
haskell-xml-types 0.3.8-5.1
haskell-zip-archive 0.4.1-66.0
haskell-zlib 0.6.2.2-4.0
 178 DevopsBug ReportVery LowLow New installer overwrites pacman mirrors Closed
100%
Task Description

I tried to install archlinux32 using the archinstall installer, which is shipped with the installation medium.
Installation is working fine until pacstrap, where it will crash because all mirrors will return 404. I checked
my connection and it is working and dns also works. When I viewed the /etc/pacman.d/mirrorlist file, I saw that the script
wrote the default archlinux mirrors for the region specified in the installer to the file and the don’t contain the 32bit packages.

176DevopsFeature RequestMediumLowbring back archiso32 dual bootNew
0%
Task Description

We should make archiso32 be able to build a i686- and x86_64-bootable iso, again. This is really handy on a usb stick as a rescue system.

The problem with the old dual iso is, that I had to do the i686 iso from scratch, because upstream changed from build.sh to putting everything into mkarchiso. Now, everything is steered from a profile file.

So either, we find a way to make a profile for multiple architectures, or we need to patch mkarchiso to do that for us - and maybe upstream these changes.

 175 PackagesBug ReportVery LowLow [pango]: symbol lookup error: /usr/lib/libpango-1.0.so. ...Closed
100%
Task Description

this is a rather severe bug - it prevents GTK DMs, DEs, and programs from starting (lightdm, lxdm, lxde, leafpad)

the error is evident immediately in the pacman log - see: http://termbin.com/vezp

g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /usr/lib/libpango-1.0.so.0: undefined symbol: g_memdup2
/usr/bin/gtk-query-immodules-3.0: symbol lookup error: /usr/lib/libpango-1.0.so.0: undefined symbol: g_memdup2

if you disable the DM service, you can get the same error by launching the DE directly

$ startlxde
/usr/bin/lxsession: symbol lookup error: /usr/lib/libpango-1.0.so.0: undefined symbol: g_memdup2
 174 PackagesBug ReportMediumLow firefox 87.0 doesn't build Closed
100%
Task Description

Again, we get into out-of-memory situations with rust:

pentium4
41:24.75   cargo:warning=src/vector_type.h:502:11: warning: ‘void* memcpy(void*, const void*, size_t)’ writing to an object of type ‘struct glsl::vec4’ with no trivial copy-assignment; use copy-assignment or copy-initialization instead [-Wclass-memaccess]
41:24.75   cargo:warning=  502 |     memcpy(&v, p, sizeof(v));
41:24.75   cargo:warning=      |     ~~~~~~^~~~~~~~~~~~~~~~~~
41:24.75   cargo:warning=In file included from src/gl.cc:78:
41:24.75   cargo:warning=src/glsl.h:1772:8: note: ‘struct glsl::vec4’ declared here
41:24.75   cargo:warning= 1772 | struct vec4 {
41:24.75   cargo:warning=      |        ^~~~
41:24.75   cargo:warning=
41:24.75   cargo:warning=cc1plus: out of memory allocating 21906724 bytes after a total of 213745664 bytes

i686
 6:42.75    Compiling geckoservo v0.0.1 (/build/firefox/src/firefox-87.0/servo/ports/geckolib)
Process Process-1:
Traceback (most recent call last):
  File "/usr/lib/python3.9/multiprocessing/process.py", line 315, in _bootstrap
    self.run()
  File "/usr/lib/python3.9/multiprocessing/process.py", line 108, in run
    self._target(*self._args, **self._kwargs)
  File "/build/firefox/src/firefox-87.0/testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py", line 141, in _collect
    while not _poll(pipe, poll_interval=sleep_interval):
  File "/build/firefox/src/firefox-87.0/testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py", line 107, in _poll
    return pipe.poll(poll_interval)
  File "/usr/lib/python3.9/multiprocessing/connection.py", line 262, in poll
    return self._poll(timeout)
  File "/usr/lib/python3.9/multiprocessing/connection.py", line 429, in _poll
    r = wait([self], timeout)
  File "/usr/lib/python3.9/multiprocessing/connection.py", line 936, in wait
    ready = selector.select(timeout)
  File "/usr/lib/python3.9/selectors.py", line 416, in select
    fd_event_list = self._selector.poll(timeout)
KeyboardInterrupt
52:46.35 make[4]: *** [/build/firefox/src/firefox-87.0/config/makefiles/rust.mk:348: force-cargo-library-build] Interrupt
52:46.35 make[3]: *** [/build/firefox/src/firefox-87.0/config/recurse.mk:72: toolkit/library/rust/target] Interrupt
52:46.35 make[2]: *** [/build/firefox/src/firefox-87.0/config/recurse.mk:34: compile] Interrupt
52:46.35 make[1]: *** [/build/firefox/src/firefox-87.0/config/rules.mk:355: default] Interrupt

Rust is 1.51.0 on both pentium4 and i686.

 171 PackagesBug ReportVery LowLow [pacman] libarchive minimum version dependency - libarc ...Closed
100%
Task Description

pacman has a dependency upon libarchive with a version recent enough to support zstd compression.

depends=(... 'libarchive>=3.3.3')

This is an issue when upgrading pacman to support the zstd packaging format.
pacman must depend upon libarchive>=3.3.3 for zstd compression support.
libarchive will then depend upon zstd>=1.3.6 for the symbol ZSTD_minCLevel.

Without these, upgrading an old Arch Linux system gives the incomplete - so unhelpful - error message:

error: could not open file /var/cache/pacman/pkg/something.pkg.tar.zst: Unrecognized archive format

How does pacman recognize an archive format? If the user does not already know the answer, they are in trouble. And, mistakenly circumventing the package compression to force an upgrade of pacman alone will lead to even more trouble, since pacman itself is not the source of the problem.

 170 PackagesBug ReportVery LowLow [libarchive] zstd minimum version dependency - zstd>=1. ...Closed
100%
Task Description

libarchive has a dependency upon the zstd libzstd with a version recent enough to provide the symbol ZSTD_minCLevel.

PKGBUILD:
depends=(... 'zstd>=1.3.6')

This is an issue when upgrading pacman to support the zstd packaging format.
pacman must depend upon libarchive>=3.3.3 for zstd compression support.
libarchive will then depend upon zstd>=1.3.6 for the symbol ZSTD_minCLevel.

Without these, upgrading an old Arch Linux system gives the incomplete - so unhelpful - error message:

error: could not open file /var/cache/pacman/pkg/something.pkg.tar.zst: Unrecognized archive format

How does pacman recognize an archive format? If the user does not already know the answer, they are in trouble. And, mistakenly circumventing the package compression to force an upgrade of pacman alone will lead to even more trouble, since pacman itself is not the source of the problem.

 169 PackagesFeature RequestVery LowLow New mirror: mirror.nw-sys.ru Closed
100%
Task Description

I didn’t found any message about reporting new mirrors of archlinux32 project, so I decided to open new FR. Sorry if I mistaken and show me the right way, please :)

Domain name: mirror.nw-sys.ru
Country: Russia
Supported access methods for mirror:
http(s) - http(s)://mirror.nw-sys.ru/archlinux32/
rsync - rsync://mirror.nw-sys.ru/archlinux32
Mirror bandwidth - 100 Mbit/s almostly, with slight slowdowns around the day.
Primary administrative contact - no1@no1sg.ru
Alternative administrative contact - morgan29rus@gmail.com
Source mirror - mirror.archlinux32.org

 168 DevopsBug ReportMediumLow i486 slaves are no longer working Closed
100%
Task Description

+ exec setarch i486 systemd-nspawn -q -D /var/lib/archbuild/staging-i486/root -E PATH=/usr/local/sbin:/usr/local/bin:/usr/bin –register=no –keep-unit –as-pid2 –bind=/var/cache/archbuild32 pacman -Syuu –noconfirm
error: failed to initialize alpm library

166PackagesBug ReportMediumLows2n-tls: failing testsNew
0%
Task Description

The following tests FAILED:

       91 - s2n_pq_kem_hybrid_kat_test (Failed)
      145 - s2n_session_ticket_test (Failed)
      154 - s2n_stuffer_network_order_test (Failed)
      184 - s2n_x509_validator_test (Failed)

https://github.com/aws/s2n-tls/issues/2405 https://github.com/aws/s2n-tls/issues/2406 https://github.com/aws/s2n-tls/issues/2404

3 are known upstream too.

 165 PackagesBug ReportMediumLow xorgproto check() fails Closed
100%
Task Description

———————————– output ———————————– stderr:
Traceback (most recent call last):

File "/build/xorgproto/src/xorgproto-2021.3/scripts/keysym-generator.py", line 18, in <module>
  import libevdev

ModuleNotFoundError: No module named ‘libevdev’

root cause is python-libevdev not building:

Theme error:
sphinx_rtd_theme is no longer a hard dependency since version 1.4.0. Please install it manually.(pip install sphinx_rtd_theme)

another victim of documentation generation..

164PackagesBug ReportMediumLowpam_systemd.so hangs openssh 2 out of 3 timesNew
0%
Task Description

Effect: you can not log in.
The SSHd child runs on 100% CPU doing something.
This happens on i486, i686 and pentium4 equally.

163PackagesBug ReportMediumLowsphinx_rtd_theme is used to build documentation but doe...New
0%
Task Description
build
running build_py
npm WARN npm npm does not support Node.js v15.9.0
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 6, 8, 9, 10, 11, 12, 13.
npm WARN npm You can find the latest version at https://nodejs.org/

> sphinx_rtd_theme@0.5.1 preinstall /build/python-sphinx_rtd_theme/src/sphinx_rtd_theme-0.5.1
> bin/preinstall.js

Traceback (most recent call last):
  File "/build/python-sphinx_rtd_theme/src/sphinx_rtd_theme-0.5.1/setup.py", line 86, in <module>
    setup(
  File "/usr/lib/python3.9/site-packages/setuptools/__init__.py", line 153, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib/python3.9/distutils/core.py", line 148, in setup
    dist.run_commands()
  File "/usr/lib/python3.9/distutils/dist.py", line 966, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python3.9/distutils/dist.py", line 985, in run_command
    cmd_obj.run()
  File "/usr/lib/python3.9/distutils/command/build.py", line 135, in run
    self.run_command(cmd_name)
  File "/usr/lib/python3.9/distutils/cmd.py", line 313, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python3.9/distutils/dist.py", line 985, in run_command
    cmd_obj.run()
  File "/build/python-sphinx_rtd_theme/src/sphinx_rtd_theme-0.5.1/setup.py", line 22, in run
    subprocess.run(['npm', 'install'], check=True)
  File "/usr/lib/python3.9/subprocess.py", line 524, in run
    raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '['npm', 'install']' died with <Signals.SIGSEGV: 11>.
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Build failed, check /var/lib/archbuild/staging-pentium4/abaumann/build
162PackagesBug ReportMediumLowbrowsers based on Chromium break in secomp sanboxingNew
0%
Task Description

Everything using chromium/seccomp jailing breaks currently including chromium due to missing IA-32
rules in libseccomp and/or chromium itself.

Firefox seems to work fine.
epiphany works.
midori works.
luakit works.

Chromium crashes with sigsegv (I would expect something which reminds me of a seccomp syscall?).

konqueror, falkon, qutebrowser are based on qt5-webengine. They all open up but then don’t render a page (issuing the seccomp error messages attached below).

vivaldi the same, but as it is closed source, we cannot fix it.

 161 PackagesBug ReportMediumLow buildbot fails to build Closed
100%
Task Description

/usr/bin/true install -e pkg
/usr/bin/true install mock wheel buildbot
cd www/build_common; yarn install –pure-lockfile
yarn install v1.22.10
warning package.json: No license field
warning buildbot-build-common@1.0.0: No license field
[1/4] Resolving packages… [2/4] Fetching packages… make: *** [Makefile:63: frontend_deps] Segmentation fault (core dumped)

Showing tasks 151 - 200 of 350 Page 4 of 7<<First - 2 - 3 - 4 - 5 - 6 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing