Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategory  descTask TypePrioritySeveritySummaryStatusProgress
343PackagesBug ReportVery LowLowPackage 'screen 4.9.1-1.0' is missing dependency libute...Unconfirmed
0%
Task Description

Package ‘screen 4.9.1-1.0’ is missing dependency libutempter. I assume this is because libutempter used to be a dependency of util-linux which is part of base, so was assumed to be installed.

With the regular Arch Linux distro libutempter is still a dependency of util-linux.

342PackagesBug ReportVery LowVery Lownmap missing dependency openssl-1.1Unconfirmed
0%
Task Description

no task description

341PackagesBug ReportVery LowCriticalpython3 is version 11, but all packages install only 3....Unconfirmed
0%
Task Description

From a fresh install just now:

The /usr/lib/python3.10/site-packages folder is full of dozens of files, but there is little in the 3.11 folder. Some examples: gajim yt-dlp zippy samba.

This seems to affect most new packages that I install, so it is by no means limited to just the examples.

340PackagesBug ReportVery LowCritical[chromium] broken due to outdated libraries, plus also ...Unconfirmed
0%
Task Description

The package needs to be recompiled for re2 v10 and several required dependencies were not installed, such as icu69 (?) and more.

339PackagesBug ReportVery LowLow[libcanberra-pulse]: can not be installedUnconfirmed
0%
Task Description
# pacman -S libcanberra-pulse
resolving dependencies...
warning: cannot resolve "libcanberra=0.30+2+gc0620e4-3.2", a dependency of "libcanberra-pulse"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libcanberra-pulse

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcanberra=0.30+2+gc0620e4-3.2' required by libcanberra-pulse
338PackagesBug ReportVery LowLow[libreoffice-still]: error while loading shared librari...Unconfirmed
0%
Task Description

needs rebuild against latest ‘boost’

$ sudo pacman -Sy libreoffice-still

$ pacman -Qs libreoffice-still
local/libreoffice-still 7.3.7-2.0
    LibreOffice maintenance branch

$ lowriter
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_locale.so.1.80.0: cannot open shared object file: No such file or directory
337PackagesBug ReportMediumLowpackages are being downgraded in reposNew
0%
Task Description

warning: filesystem: local (2023.09.18-1.0) is newer than core (2023.01.31-1.0)

336PackagesBug ReportVery LowLow[pyqt-builder]: needs rebuildUnconfirmed
0%
Task Description

just wanted to get this one on the board - i am unable to build ‘python-pyqt5’ which many other packages depend on, such as ‘qutebrowser’

the current ‘python-pyqt5’ PKGBUILD, which builds fine for x86_64 and arm, has unspecified dependencies in the i686 repos - not sure why that is

ModuleNotFoundError: No module named ‘jaraco.functools’
ModuleNotFoundError: No module named ‘jaraco.context’

that is easily fixed by requiring them explicitly:
> makedepends_i686=(’python-jaraco.context’ ‘python-jaraco.functools’)

however, after that, it gives a more fatal error:

sip-build: Unable to import ‘project.py’: No module named ‘pyqtbuild’

that module is in the ‘pyqt-builder’ package, i beleive - ‘pyqt-builder’ is installed as a build dependency; but it was built for python 3.9 - so probably that is why the build could not find the module

335PackagesBug ReportVery LowMediumpython-setuptools-scm 7.1.0-4.1 missing dependencyUnconfirmed
0%
Task Description

python-setuptools-scm 7.1.0-4.1 as found in the repo is missing the dependencies python-packaging and python-setuptools, which breaks the build of many other packages.

 334 PackagesBug ReportVery LowLow Calibre is out of date and will not start Closed
100%
Task Description

The latest version of calibre is 6.16.

The version in the repositories is 6.11.0-1.0 and unfortunately will no longer start.

[keith@Arch32 ~]$ calibre
Failed to import PyQt module: PyQt6.QtNetwork with error: /usr/lib/python3.10/site-packages/PyQt6/QtNetwork.abi3.so: undefined symbol: _ZN16QNetworkDatagram7destroyEP23QNetworkDatagramPrivate, version Qt_6
Traceback (most recent call last):
  File "/usr/bin/calibre", line 21, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 72, in calibre
    from calibre.gui2.main import main
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 13, in <module>
    from qt.core import (
ImportError: cannot import name 'QNetworkProxyFactory' from 'qt.core' (/usr/lib/calibre/qt/core.py)
[keith@Arch32 ~]$ pacman -Qi calibre
Name            : calibre
Version         : 6.11.0-1.0
Description     : Ebook management application
Architecture    : pentium4
URL             : https://calibre-ebook.com
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : hunspell  hyphen  icu  jxrlib  libmtp  libstemmer  libusb  libwmf  mathjax  mtdev  optipng  podofo
                  python-apsw  python-beautifulsoup4  python-cchardet  python-css-parser  python-cssselect  python-dateutil
                  python-dnspython  python-feedparser  python-html2text  python-html5-parser  python-jeepney  python-lxml
                  python-markdown  python-mechanize  python-msgpack  python-netifaces  python-pdftotext  python-pillow
                  python-psutil  python-py7zr  python-pychm  python-pycryptodome  python-pygments  python-pyqt6
                  python-pyqt6-webengine  python-regex  python-unrardll  python-zeroconf  qt6-imageformats  qt6-svg
                  qt6-webengine  ttf-liberation  uchardet  udisks2
Optional Deps   : poppler: required for converting pdf to html [installed]
                  speech-dispatcher: TTS support in the viewer
Required By     : None
Optional For    : None
Conflicts With  : calibre-common  calibre-python3
Replaces        : calibre-common  calibre-python3
Installed Size  : 91.69 MiB
Packager        : Andreas Baumann <mail@andreasbaumann.cc>
Build Date      : Thu 12 Jan 2023 05:31:50 GMT
Install Date    : Tue 24 Jan 2023 10:15:48 GMT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

[keith@Arch32 ~]$ 
333PackagesBug ReportVery LowHighSddm 0.19.0-9.0 crashes with Qt 5.15.9Assigned
0%
Task Description

The current version of sddm (0.19.0-9.0) depends on the previous version of Qt (5.15.8). After updating Qt, sddm crashes with an incompatible Qt library error.

 332 PackagesBug ReportVery LowLow firefox 112 compilation Closed
100%
Task Description

any ideas hpw to get past this error (i686)?

18:33.80 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:38:16: error: ‘any’ is not a member of ‘xsimd’
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:16:70: error: incomplete type ‘xsimd::batch<short int, xsimd::sse2>’ used in nested name specifier
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:35:31: error: ‘xsimd::batch<short int, xsimd::sse2> vectmask’ has incomplete type
18:49.36 /build/iceweasel/src/firefox-112.0/dom/base/nsTextFragmentGeneric.h:37:64: error: incomplete type ‘xsimd::batch<short int, xsimd::sse2>’ used in nested name specifier
 331 PackagesBug ReportMediumLow [rust] rebootstrap Closed
100%
Task Description

seems like the virtual memory exhaustion is fixed in the newest version.
We have to bootstrap again (mainly for librsvg and firefox).

 330 PackagesBug ReportVery LowLow [gcompris-qt] no game icons Closed
100%
Task Description

gcompris-qt 3.0-1.0 is missing a dependency on llvm14 (or maybe it needs a rebuild for llvm) and thus it doesn’t show any game in the menu.

 329 PackagesBug ReportVery LowHigh [go] Cannot install yay from AUR Closed
100%
Task Description

Installing yay from AUR

git clone https://aur.archlinux.org/yay.git
cd yay
makepkg -sri

gives following error

go: updates to go.sum needed, disabled by -mod=readonly

Reason - outdated version of go in i686 architecture

Temporary solution - use go for pentium4 (change temporarily architecture to pentium4 in /etc/pacman.conf)

 328 PackagesBug ReportVery LowMedium libreoffice-fresh on i686 is newer then pentium4 Closed
100%
Task Description

i686:- libreoffice-fresh 7.3.4-2.1
pentium4:- libreoffice-fresh 7.3.2-1.0

 327 PackagesBug ReportVery LowHigh [firefox-106.0.3.1.1-pentium4] crashes in VMware virtua ...Closed
100%
Task Description

This is pentium4 related problem. Firefox crashes on startup with following messages:

ExceptionHandler::GenerateDump cloned child 814
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

Screenshot. Firefox folder after crash.

Temporary solution is to change in /etc/pacman/conf

Architecture=i686

, delete firefox for pentium4 from pacman cache and reinstall firefox

firefox-106.0.3.1.1-i686
326PackagesBug ReportMediumLow[php] needs a rebuildNew
0%
Task Description

httpd/conf/httpd.conf: Cannot load modules/libphp.so into server: libssl.so.1.1>

325PackagesBug ReportVery LowHigh[terminus] crashes with message undefined symbol: cairo...Unconfirmed
0%
Task Description

Starting terminus gives following error:

from ._cairo import *  # noqa: F401,F403
ImportError: /usr/lib/python3.10/site-packages/cairo/_cairo.cpython-310-i386-linux-gnu.so: undefined symbol: cairo_tee_surface_index

Bug seens to be related to

https://bugs.archlinux.org/task/77367

There is generall mess on cairo related files for different architectures (pentium4, i486, i686) - some packages for one architecture are outdated, while for other archictectures are up to date, for instance:

  • python-cairo i486/extra : 1.21.0-1.0
  • python-cairo i686/extra : 1.23.0-3.0
  • python-cairo pentium4/extra : 1.23.0-3.0
 324 PackagesBug ReportMediumLow [libxft] segfaults Closed
100%
Task Description
Mar 08 19:16:01 arch32 audit[409]: ANOM_ABEND auid=1000 uid=0 gid=0 ses=5 pid=409 comm="slim" exe="/usr/bi                                                                                                          n/slim" sig=11 res=1                                                                                                                                                                                                
Mar 08 19:16:01 arch32 kernel: slim[409]: segfault at 30 ip b7dbe9e9 sp bf84f680 error 4 in libX11.so.6.4.                                                                                                          0[b7d9c000+8c000] likely on CPU 0 (core 0, socket 0)                                                                                                                                                                
Mar 08 19:16:01 arch32 kernel: Code: 04 00 00 83 c4 10 eb 8e 8d b4 26 00 00 00 00 66 90 53 e8 1a dd fd ff                                                                                                           81 c3 92 7a 11 00 83 ec 08 8b 44 24 10 8b 88 38 05 00 00 <8b> 51 30 83 fa ff 74 52 c7 41 30 ff ff ff ff 8b                                                                                                           88 d0 04 00 00 85                                                                                                                                                                  
Mar 08 19:16:01 arch32 systemd[1]: Started Process Core Dump (PID 424/UID 0).                                                                                                                                       
Mar 08 19:16:01 arch32 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=system                                                                                                          d-coredump@1-424-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'                                                                                                          
Mar 08 19:16:01 arch32 systemd-coredump[425]: [🡕] Process 409 (slim) of user 0 dumped core.                                                                                                                         
                                                                                                                                                                                                                    
                                              Stack trace of thread 409:                                                                                                                                            
                                              #0  0x00000000b7dbe9e9 _XAllocID (libX11.so.6 + 0x349e9)                                                                                                              
                                              #1  0x00000000b7d9f710 XCreatePixmap (libX11.so.6 + 0x15710)                                                                                                          
                                              #2  0x00000000b74cbd41 XRenderFindDisplay (libXrender.so.1 +                                                                                                           0x2d41)                                                                                                                                                                                                            
                                              #3  0x00000000b74cccf1 XRenderFreeGlyphSet (libXrender.so.1                                                                                                           + 0x3cf1)                                                                                                                                                                                                           
                                              #4  0x00000000b766e55b n/a (libXft.so.2 + 0x655b)                                                                                                                     
                                              #5  0x00000000b7c9a4fa _ZN5PanelD2Ev (libslim.so.1.3.6 + 0x1                                                                                                          34fa)                                                                                                                                                                                                               
                                              #6  0x00000000004bc49f _ZN3App13RestartServerEv (slim + 0xd4                                                                                                          9f)                                                                                                                                                                                                                 
                                              #7  0x00000000004bd623 _ZN3App5LoginEv (slim + 0xe623)                                                                                                                
                                              #8  0x00000000004bc073 _ZN3App3RunEv (slim + 0xd073)                                                                                                                  
                                              #9  0x00000000004b4742 main (slim + 0x5742)                                                                                                                           
                                              #10 0x00000000b7850129 n/a (libc.so.6 + 0x1f129)                                                                                                                      
                                              #11 0x00000000b78501fd __libc_start_main (libc.so.6 + 0x1f1f                                                                                                          d)                                                                                                                                                                                                                  
                                              #12 0x00000000004b48b5 _start (slim + 0x58b5)                                                                                                                         
                                              ELF object binary architecture: Intel 80386                                                                                                                           
 323 PackagesBug ReportVery LowMedium qemu-desktop installation error Closed
100%
Task Description

While installing qemu-desktop for Archlinux32 following error appears:

/usr/bin/gtk-query-immodules-3.0: symbol lookup error: /usr/liblibpango-1.0.so.0: undefined symbol: hb_ot_color_has_paint

Pango version pango-1:1.50.14-1.0-pentium4. This is a problem of Archlinux32 only - in Archlinux there is no error.

321PackagesBug ReportMediumLow[gnome] brokenAssigned
0%
Task Description

mutter had a checksum issue (trivial).

gnome-shell misses a current version of gjs:

Dependency gjs-1.0 found: NO found 1.70.2 but need: '>= 1.73.1'
Did not find CMake 'cmake'
Found CMake: NO
Run-time dependency gjs-1.0 found: NO 

gnome-shell/meson.build:80:0: ERROR: Dependency lookup for gjs-1.0 with method 'pkgconfig' failed: Invalid version, need 'gjs-1.0' ['>= 1.73.1'] found '1.70.2'.

A full log can be found at /build/gnome-shell/src/build/meson-logs/meson-log.txt
320PackagesBug ReportMediumLow[btop] On i486 fails on clock_gettime64New
0%
Task Description

shows a red ERROR: on startup, strace shows:

write(2, "\n", 1
)                       = 1
clock_gettime64(CLOCK_REALTIME, {tv_sec=1675495215, tv_nsec=436798535}) = 0
exit_group(1)                           = ?
+++ exited with 1 +++
[root@eurobuild6-7-i486 ~]# btop
ERROR: No UTF-8 locale detected!
319PackagesBug ReportMediumLow[js102] rebuild results in a broken JS interpreter outp...New
0%
Task Description
 2:33.16 1 warning generated.
 2:47.25     Finished release [optimized] target(s) in 2m 24s
 3:50.23 js/src/build/libjs_static.a
 3:50.23 js/src/build/libmozjs-102.so
 3:51.27 js/src/gdb/gdb-tests
 3:51.27 js/src/shell/js
 3:51.33 js/src/jsapi-tests/jsapi-tests
 3:52.83 ./spidermonkey_checks.stub
 3:54.52 TEST-PASS | check_spidermonkey_style.py | ok
 3:54.79 TEST-PASS | check_macroassembler_style.py | ok
 3:54.84 TEST-PASS | check_js_opcode.py | ok
 3:55.04 7 compiler warnings present.
 3:55.09 Overall system resources - Wall time: 233s; CPU: 0%; Read bytes: 0; Write bytes: 0; Read time: 0; Write time: 0
 3:55.13 warning: intl/icu/source/i18n/nfsubs.cpp:1313:17 [-Wunused-but-set-variable] variable 'pow' set but not used
 3:55.13 warning: intl/icu/source/i18n/ucol.cpp:108:12 [-Wdeprecated-declarations] 'ucol_safeClone_71' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:101:20 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<int *, Failed>>' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:102:20 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<mozilla::Ok, Failed>>' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:103:20 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<mozilla::Ok, Foo8>>' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:104:20 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<Foo8, Foo16>>' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:105:21 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<mozilla::Ok, mozilla::UniquePtr<int>>>' is deprecated
 3:55.13 Your build was successful!
 Config object not found by mach.
Configure complete!
Be sure to run |mach build| to pick up any changes
To view resource usage of the build, run |mach resource-usage|.
To take your build for a test drive, run: |mach run|
Profiling instrumented JS...
/startdir/PKGBUILD: line 154:  6398 Segmentation fault      (core dumped) "$js" run.js
 318 PackagesBug ReportVery LowLow [multiple]: Note: This key has expired! Closed
100%
Task Description
$ wget http://pool.mirror.archlinux32.org/i686/core/binutils-2.40-2.0-i686.pkg.tar.zst
$ wget http://pool.mirror.archlinux32.org/i686/core/binutils-2.40-2.0-i686.pkg.tar.zst.sig
$ sudo pacman-key --verify binutils-2.40-2.0-i686.pkg.tar.zst.sig
==> Checking binutils-2.40-2.0-i686.pkg.tar.zst.sig... (detached)
gpg: Signature made Mon Jan 23 01:17:18 2023 EST
gpg:                using RSA key 16194A82231E9EF823562181C8E8F5A0AF9BA7E7
gpg: Good signature from "Andreas Baumann (sign) <mail@andreasbaumann.cc>" [expired]
gpg: Note: This key has expired!
Primary key fingerprint: 1619 4A82 231E 9EF8 2356  2181 C8E8 F5A0 AF9B A7E7
==> ERROR: The signature identified by binutils-2.40-2.0-i686.pkg.tar.zst.sig could not be verified.

<KitsuWhooa> fuse also fails for me

 317 PackagesBug ReportVery LowMedium [pacutils] paccheck core dumps Closed
100%
Task Description

$ paccheck pacman
pacman: all dependencies satisfied
zsh: segmentation fault (core dumped) paccheck pacman

It seems to be in the –files check (as with that the crash happens quicker).

Debuginfod doesn’t seem to work for ArchLinux32 (unlike standard ArchLinux) so no debug symbols, but here is the gdb backtrace:

(gdb) bt
#0 0xb7d1989a in strnlen () from /usr/lib/libc.so.6
#1 0xb7d197ac in strncpy () from /usr/lib/libc.so.6
#2 0x00402abe in ?? ()
#3 0x0040244a in ?? ()
#4 0xb7c96129 in ?? () from /usr/lib/libc.so.6
#5 0xb7c961fd in __libc_start_main () from /usr/lib/libc.so.6
#6 0x004026f5 in ?? ()

Valgrind does not seem to work properly on Arch32 either, so I can’t test that.

 316 PackagesBug ReportMediumLow [rust] exhausts virtual memory Closed
100%
Task Description
/usr/bin/ld: error: lib/libLLVMSupport.a(FileOutputBuffer.cpp.o)(.text._ZN12_GLOBAL__N_112OnDiskBufferD0Ev
) is too large (0x105 bytes)
/usr/bin/ld: failed to set dynamic section sizes: memory exhausted
collect2: error: ld returned 1 exit status

maybe we have to resort to cross-compiling rust in the end..

314PackagesBug ReportVery LowLowMumble requires a outdated protobuf Unconfirmed
0%
Task Description

libprotobuf=28 is a mumble (package) dependency, but protobuf package has libprotobuf=32.

I needed to downgrade to protobuf-3.17.3-1.3-pentium4.pkg.tar.zst (from the archive) to install mumble.

313PackagesBug ReportMediumLow[hg] broken on i486New
0%
Task Description
Traceback (most recent call last):
  File "/usr/bin/hg", line 59, in <module>
    dispatch.run()
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 143, in run
    status = dispatch(req)
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 232, in dispatch
    status = _rundispatch(req)
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 276, in _rundispatch
    ret = _runcatch(req) or 0
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 451, in _runcatch
    return _callcatch(ui, _runcatchfunc)
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 461, in _callcatch
    return scmutil.callcatch(ui, func)
  File "/usr/lib/python3.10/site-packages/mercurial/scmutil.py", line 153, in callcatch
    return func()
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 441, in _runcatchfunc
    return _dispatch(req)

That’s why ‘nss’ is not rebuilding on i486.

 312 PackagesBug ReportVery LowLow In testing calibre will not start Closed
100%
Task Description
[keith@Arch32 ~]$ calibre
Failed to import PyQt module: PyQt6.QtQuick with error: No module named 'PyQt6.QtQuick'
Traceback (most recent call last):
  File "/usr/bin/calibre", line 21, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 546, in main
    app, opts, args = init_qt(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 123, in init_qt
    app = Application(args, override_program_name=override, windows_app_uid=MAIN_APP_UID)
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 1096, in __init__
    setup_to_run_webengine()
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 1078, in setup_to_run_webengine
    from qt.core import QQuickWindow, QSGRendererInterface
ImportError: cannot import name 'QQuickWindow' from 'qt.core' (/usr/lib/calibre/qt/core.py)
[keith@Arch32 ~]$ calibre --version
calibre (calibre 6.7.1)
[keith@Arch32 ~]$ 
311PackagesBug ReportMediumLow[ffmpeg] fails with SIGILL on i686Assigned
0%
Task Description

work fine on pentium4

reproducable: ffplay <file.mp4>

offending opcode:

 0xb5f315e7:  f3 0f 10 83 d0 0b 00 00 movss  
                  0xbd0(%ebx),%xmm0
310PackagesBug ReportMediumLow[webkit2gtk] needs a running RubyNew
0%
Task Description
<internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require': cannot load such file -- date_core (LoadError)
        from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
        from /usr/lib/ruby/3.0.0/date.rb:4:in `<top (required)>'
        from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
        from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
        from /build/webkit2gtk/src/webkitgtk-2.38.2/Source/JavaScriptCore/generator/GeneratedFile.rb:24:in `<top (required)>'
        from /build/webkit2gtk/src/webkitgtk-2.38.2/Source/JavaScriptCore/generator/DSL.rb:25:in `require_relative'
        from /build/webkit2gtk/src/webkitgtk-2.38.2/Source/JavaScriptCore/generator/DSL.rb:25:in `<top (required)>'
        from /build/webkit2gtk/src/webkitgtk-2.38.2/Source/JavaScriptCore/generator/main.rb:24:in `require_relative'
        from /build/webkit2gtk/src/webkitgtk-2.38.2/Source/JavaScriptCore/generator/main.rb:24:in `<main>'

And ruby is currently broken..

 309 PackagesBug ReportVery LowLow gcompris links to openssl-1.1.so Closed
100%
Task Description

```
gcompris-qt: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory
```

 308 PackagesBug ReportVery LowLow gettext needs a rebuild for libunistring Closed
100%
Task Description

I’m on pentium4 and I’m getting:

/usr/bin/xgettext: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory
/usr/bin/msgmerge: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory
/usr/bin/msgfmt: error while loading shared libraries: libunistring.so.2: cannot open shared object file: No such file or directory

gettext 0.21.1-1.1
libunistring 1.1-2.0

 307 PackagesBug ReportMediumLow [i486] make guile JIT failing Closed
100%
Task Description
*** work/functions/guile.base   Wed Nov 16 17:55:19 2022
--- work/functions/guile.log    Wed Nov 16 17:55:19 2022
***************
*** 1,3 ****
--- 1,7 ----
+ JIT failed to initialize
+ disabling automatic JIT compilation
+ JIT failed due to resource exhaustion
+ disabling automatic JIT compilation
 306 PackagesBug ReportMediumLow [Xorg] fails on i686 Closed
100%
Task Description

For instance xauth cannot find libXext.so.6.

 304 PackagesBug ReportMediumCritical [systemd] 251.2 breaking systems, cannot login Closed
100%
Task Description
Assertion 'close_nointr(fd) != -EBADF' failed at src/basic/fd-util.c:76, function safe_close(). Aborting.

The temporary workaround is to comment out ‘pam_system.so’ in system-auth and system-login..

 303 PackagesBug ReportVery LowLow codeblocks issue.. Closed
100%
Task Description

its requested that please push the codeblocks testing to stable..

 301 PackagesBug ReportVery LowLow [dino]: wont start Closed
100%
Task Description
# pacman -Syu dino
$ dino
main.vala:25: Fatal error: /usr/lib/libgupnp-1.2.so.1: undefined symbol: gssdp_client_can_reach
 300 PackagesBug ReportVery LowLow Pinta needs to be updated Closed
100%
Task Description

please update pinta i am facing problems with p.net clone and the closest is pinta so if u look to update it then it would be greatful

 299 PackagesFeature RequestVery LowLow [dart] request for bootstrapping dart Closed
100%
Task Description

The dart sdk files are still availble for ia32:-
https://storage.googleapis.com/dart-archive/channels/stable/release/2.18.2/sdk/dartsdk-linux-ia32-release.zip

can you send the old PKGBUILD which was used

 298 PackagesBug ReportVery LowLow Please update Arduino Closed
100%
Task Description

Arduino is out dated and my teacher said to use the latest arduino version 1.8.x for the robotics class…

 297 PackagesBug ReportVery LowLow jack2 can not install Closed
100%
Task Description
# pacman -S jack --noconfirm
:: There are 2 providers available for jack:
:: Repository extra
   1) jack2  2) pipewire-jack

Enter a number (default=1): 
resolving dependencies...
warning: cannot resolve "libcelt0.so=2-32", a dependency of "jack2"
:: The following package cannot be upgraded due to unresolvable dependencies:
      jack2

:: Do you want to skip the above package for this upgrade? [y/N] error: failed to prepare transaction (could not satisfy dependencies)

:: unable to satisfy dependency 'libcelt0.so=2-32' required by jack2
 296 PackagesBug ReportVery LowLow Fix terminal emulators  Closed
100%
Task Description

On arch32 currently foot and alacritty is broken

 295 PackagesBug ReportVery LowLow [qemu][seabios]: file conflict Closed
100%
Task Description
# pacman -S qemu seabios
resolving dependencies...
looking for conflicting packages...

Packages (2) qemu-6.2.0-4.0  seabios-1.16.0-3.2

Total Installed Size:  36.97 MiB

checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
/usr/share/qemu/bios-microvm.bin exists in both 'seabios' and 'qemu'
/usr/share/qemu/vgabios-ati.bin exists in both 'seabios' and 'qemu'
Errors occurred, no packages were upgraded.

294PackagesBug ReportVery LowHigh[qtile] importlib.metadata.PackageNotFoundError: No pac...Assigned
0%
Task Description

When running qtile I get the following error message:

[qtile] importlib.metadata.PackageNotFoundError: No package metadata was found for qtile

Running qtile on Arch Linux works as expected.

$ qtile start
Traceback (most recent call last):
  File "/usr/bin/qtile", line 33, in <module>
    sys.exit(load_entry_point('qtile==0.18.1', 'console_scripts', 'qtile')())
  File "/usr/bin/qtile", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 957, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 548, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for qtile
$ pacman -Qi qtile
Name            : qtile
Version         : 0.18.1-3.0
Description     : A full-featured, pure-Python tiling window manager
Architecture    : pentium4
URL             : http://www.qtile.org
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : gdk-pixbuf2  glibc  libnotify  librsvg  pango  python-cairocffi  python-cffi  python-xcffib  python-gobject  python-setuptools
Optional Deps   : alsa-utils: for volume widget
                  canto-daemon: for canto widget
                  cmus: for cmus widget
                  jupyter_console: for interaction with qtile via Jupyter
                  khal: for khal_calendar widget
                  libpulse: for pulse_volume and pulseaudio_ffi widget [installed]
                  lm_sensors: for sensors widget [installed]
                  moc: for moc widget
                  python-dbus-next: for utils, notifications and several widgets
                  python-iwlib: for wlan widget
                  python-keyring: for imapwidget widget
                  python-mpd2: mpd2widget widget
                  python-psutil: graph, net and memory widget [installed]
                  python-pywlroots: for experimental wayland support
                  python-setproctitle: change process name to qtile
                  python-xdg: launchbar widget
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 3.25 MiB
Packager        : Andreas Baumann <mail@andreasbaumann.cc>
Build Date      : Mon 04 Oct 2021 12:02:58
Install Date    : Mon 26 Sep 2022 13:33:45
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature
$ sudo pacman -Syu
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
:: Starting full system upgrade...
 there is nothing to do
 293 PackagesBug ReportVery LowLow Please update those packages:- Closed
100%
Task Description

Gimp
Krita

If possible can u add Julia Lang though its on blacklist but i will try to compile it :)

 292 PackagesFeature RequestVery LowLow Hey , if possible can u build temite based on https://g ...Closed
100%
Task Description

Note:- It will compile very easily as i have a modified PKGBUILD

# Maintainer: Frederik Schwan freswa@archlinux.org pkgdesc=’A simple VTE-based terminal’ pkgname=termite
pkgver=16.4
pkgrel=2
url=https://github.com/aperezdc/termite license=(LGPL)
depends=(gtk3 pcre2 gnutls vte-common)
makedepends=(gperf ‘meson>=0.58’ ninja)
arch=(’x86_64’,’i686’,’pentium4’‘i486’)
backup=(etc/xdg/termite/config)

source=(”${url}/releases/download/v${pkgver}/termite-${pkgver}.tar.xz”{,.asc})
b2sums=(’SKIP’

      'SKIP')

build () {

rm -rf _build
arch-meson _build "${pkgname}-${pkgver}"
meson compile -C _build

}

package () {

meson install -C _build --skip-subprojects vte --destdir "${pkgdir}"

}

 291 PackagesFeature RequestVery LowLow Hey , if possible can u build temite based on https://g ...Closed
100%
Task Description

Note:- It will compile very easily as i have a modified PKGBUILD

```
# Maintainer: Frederik Schwan freswa@archlinux.org pkgdesc=’A simple VTE-based terminal’ pkgname=termite
pkgver=16.4
pkgrel=2
url=https://github.com/aperezdc/termite license=(LGPL)
depends=(gtk3 pcre2 gnutls vte-common)
makedepends=(gperf ‘meson>=0.58’ ninja)
arch=(’x86_64’,’i686’,’pentium4’‘i486’)
backup=(etc/xdg/termite/config)

source=(”${url}/releases/download/v${pkgver}/termite-${pkgver}.tar.xz”{,.asc})
b2sums=(’SKIP’

      'SKIP')

build () {

rm -rf _build
arch-meson _build "${pkgname}-${pkgver}"
meson compile -C _build

}

package () {

meson install -C _build --skip-subprojects vte --destdir "${pkgdir}"

}
```

290PackagesBug ReportMediumLow[qt6-webengine] fails building with nodeNew
0%
Task Description
Traceback (most recent call last):
  File "/build/qt6-webengine/src/build/src/core/RelWithDebInfo/i686/../../../../../qtwebengine-everywhere-src-6.3.2/src/3rdparty/chromium/third_party/node/node.py", line 62, in <module>
    RunNode(sys.argv[1:])
  File "/build/qt6-webengine/src/build/src/core/RelWithDebInfo/i686/../../../../../qtwebengine-everywhere-src-6.3.2/src/3rdparty/chromium/third_party/node/node.py", line 57, in RunNode
    raise RuntimeError('Command \'%s\' failed\n%s' % (' '.join(cmd), err))
RuntimeError: Command '/usr/bin/node ../../../../../qtwebengine-everywhere-src-6.3.2/src/3rdparty/chromium/third_party/devtools-frontend/src/scripts/build/compress_files.js --file_list __third_party_devtools-frontend_src_compress__build_qt6-webengine_src_build_src_core_target_toolchain_target__rule..rsp' failed

This is presumably knitting together some documentation, node is currently broken on Arch32..

Showing tasks 101 - 150 of 351 Page 3 of 8 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing