Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategoryTask TypePriority  descSeveritySummaryStatusProgress
325PackagesBug ReportVery LowHigh[terminus] crashes with message undefined symbol: cairo...Unconfirmed
0%
Task Description

Starting terminus gives following error:

from ._cairo import *  # noqa: F401,F403
ImportError: /usr/lib/python3.10/site-packages/cairo/_cairo.cpython-310-i386-linux-gnu.so: undefined symbol: cairo_tee_surface_index

Bug seens to be related to

https://bugs.archlinux.org/task/77367

There is generall mess on cairo related files for different architectures (pentium4, i486, i686) - some packages for one architecture are outdated, while for other archictectures are up to date, for instance:

  • python-cairo i486/extra : 1.21.0-1.0
  • python-cairo i686/extra : 1.23.0-3.0
  • python-cairo pentium4/extra : 1.23.0-3.0
327PackagesBug ReportVery LowHigh[firefox-106.0.3.1.1-pentium4] crashes in VMware virtua...Unconfirmed
0%
Task Description

This is pentium4 related problem. Firefox crashes on startup with following messages:

ExceptionHandler::GenerateDump cloned child 814
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

Screenshot. Firefox folder after crash.

Temporary solution is to change in /etc/pacman/conf

Architecture=i686

, delete firefox for pentium4 from pacman cache and reinstall firefox

firefox-106.0.3.1.1-i686
333PackagesBug ReportVery LowHighSddm 0.19.0-9.0 crashes with Qt 5.15.9Assigned
0%
Task Description

The current version of sddm (0.19.0-9.0) depends on the previous version of Qt (5.15.8). After updating Qt, sddm crashes with an incompatible Qt library error.

172PackagesBug ReportVery LowMediumiwd requires some kernel flagsUnconfirmed
0%
Task Description

RC4 support not found
The following options are missing in the kernel:

CONFIG_CRYPTO_USER_API_SKCIPHER
CONFIG_CRYPTO_ECB
CONFIG_CRYPTO_ARC4
210PackagesBug ReportVery LowMediumkeymap don't gets fixed on login as set in /etc/vconsol...Unconfirmed
0%
Task Description

gzip comes with asm code, if enabled, built a TEXTREL which gets bloqued on boot, so systemd don’t set keymap
A lot of tricks in forums, old thread more complete here $506 An old problem. Work around while asm gets fixed is call configure with DEFS=”NO_ASM” like this:

...
export DEFS="NO_ASM"
./configure ....

or,

./configure DEFS="NO_ASM" ....

I have not tested it, but gentoo on x32 have gzip like this and no TEXTRELS here.
No matter i486, i686 or pentium.

Hope it helps.

Best regards.

243PackagesBug ReportVery LowMedium[linux and linux-zen] 5.16.12 needs a rebuild with gcc...New
0%
Task Description

[linux and linux-zen] 5.16.12 needs a rebuild with gcc 11.2 so DKMS packages will work

get errors when dkms installing in make log

cc1: error: incompatible gcc/plugin versions
cc1: error: failed to initialize plugin ./scripts/gcc-plugins/structleak_plugin.so

322Packages: StableBug ReportVery LowMediumfile header absentNew
0%
Task Description

on fresh install file /usr/lib/libbfd.so lacks header “/* GNU ld script */” so I see complains on terminal

335PackagesBug ReportVery LowMediumpython-setuptools-scm 7.1.0-4.1 missing dependencyUnconfirmed
0%
Task Description

python-setuptools-scm 7.1.0-4.1 as found in the repo is missing the dependencies python-packaging and python-setuptools, which breaks the build of many other packages.

344PackagesBug ReportVery LowMedium[linux] No kernel updatesUnconfirmed
0%
Task Description

The linux kernel seems to be stuck at version 6.1.12.arch1-1.0. The build log of the latest stable kernel (linux-6.6.4.arch1-1.0) shows the following error:

=⇒ ERROR: Integrity checks (sha256) differ in size from the source array.
erich@rechenknecht

351Packages: StableBug ReportVery LowMediumVarious python-X packages building for Python 3.10 and ...New
0%
Task Description

yes, confirmed, that’s because python 3.11 is the only package building and being
published to stable, the python modules need bootstrapping (since months).

100Packages: StableBug ReportVery LowLowmldonkey crashesUnconfirmed
0%
Task Description

All versions of mldonkey crash in arch32 updated. (segmentation fault and core dumped)

117PackagesBug ReportVery LowLowvboxdrive module missingNew
0%
Task Description

vboxdrv module is missing making virtualbox unusable.

I’m currently running kernel 5.9.0-1.0-pae but it doesn’t seem to be there in any version

209PackagesBug ReportVery LowLowIntel High Definition Audio issue.Unconfirmed
0%
Task Description

I am using Arch Linux 32 latest version on Sony VAIO VGN-FS215Z . The following is the audio device:

-fs215z:~$ lspci | grep -i audio

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)

When I boot the system after some time getting crackling sound in speaker. Sometimes it stops after few minutes and sometimes continue to sound. Really annoying. I am not getting the normal audio in any application. This problem was there in debian based OSs also but not there in any other OS.

Please help.

283PackagesBug ReportVery LowLow[icu70/icu71 ] packages not rebuilt yetAssigned
0%
Task Description

starting to collect them here packages which require icu69 (and have thus not been rebuilt
for icu 71 yet):

libreoffice-fresh

287PackagesFeature RequestVery LowLowchromium not able to buildAssigned
0%
Task Description

Wait unfortunately i found a patch through which chromium would compile on x86

please try to build chromium using those patches

https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/reenable-linux-i686-builds.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-i686-vaapi-fpermissive.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-105-bitmap-include.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-105-browser-include.patch

314PackagesBug ReportVery LowLowMumble requires a outdated protobuf Unconfirmed
0%
Task Description

libprotobuf=28 is a mumble (package) dependency, but protobuf package has libprotobuf=32.

I needed to downgrade to protobuf-3.17.3-1.3-pentium4.pkg.tar.zst (from the archive) to install mumble.

336PackagesBug ReportVery LowLow[pyqt-builder]: needs rebuildUnconfirmed
0%
Task Description

just wanted to get this one on the board - i am unable to build ‘python-pyqt5’ which many other packages depend on, such as ‘qutebrowser’

the current ‘python-pyqt5’ PKGBUILD, which builds fine for x86_64 and arm, has unspecified dependencies in the i686 repos - not sure why that is

ModuleNotFoundError: No module named ‘jaraco.functools’
ModuleNotFoundError: No module named ‘jaraco.context’

that is easily fixed by requiring them explicitly:
> makedepends_i686=(’python-jaraco.context’ ‘python-jaraco.functools’)

however, after that, it gives a more fatal error:

sip-build: Unable to import ‘project.py’: No module named ‘pyqtbuild’

that module is in the ‘pyqt-builder’ package, i beleive - ‘pyqt-builder’ is installed as a build dependency; but it was built for python 3.9 - so probably that is why the build could not find the module

338PackagesBug ReportVery LowLow[libreoffice-still]: error while loading shared librari...Unconfirmed
0%
Task Description

needs rebuild against latest ‘boost’

$ sudo pacman -Sy libreoffice-still

$ pacman -Qs libreoffice-still
local/libreoffice-still 7.3.7-2.0
    LibreOffice maintenance branch

$ lowriter
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_locale.so.1.80.0: cannot open shared object file: No such file or directory
339PackagesBug ReportVery LowLow[libcanberra-pulse]: can not be installedUnconfirmed
0%
Task Description
# pacman -S libcanberra-pulse
resolving dependencies...
warning: cannot resolve "libcanberra=0.30+2+gc0620e4-3.2", a dependency of "libcanberra-pulse"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libcanberra-pulse

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcanberra=0.30+2+gc0620e4-3.2' required by libcanberra-pulse
343PackagesBug ReportVery LowLowPackage 'screen 4.9.1-1.0' is missing dependency libute...Unconfirmed
0%
Task Description

Package ‘screen 4.9.1-1.0’ is missing dependency libutempter. I assume this is because libutempter used to be a dependency of util-linux which is part of base, so was assumed to be installed.

With the regular Arch Linux distro libutempter is still a dependency of util-linux.

345PackagesBug ReportVery LowLow[gcompris-qt] doesn't start due to Qt 5.15.10Unconfirmed
0%
Task Description

I fails to start with: “Cannot mix incompatible Qt library (5.15.9) with this library (5.15.10)”

346PackagesBug ReportVery LowLowpandoc: error while loading shared librariesUnconfirmed
0%
Task Description
# pacman -Syyuu base
# pacman -S pandoc
# pandoc
pandoc: error while loading shared libraries: libHSzip-archive-0.4.1-FOOm53qGfUr2AB1Oel9iH4-ghc8.10.2.so: cannot open shared object file: No such file or directory
347PackagesBug ReportVery LowLowMeld will not start - error message -> Meld requires Gt...Unconfirmed
0%
Task Description

[keith@Arch32 ~]$ meld
Meld requires Gtk+ 3.20 or higher.
[keith@Arch32 ~]$ pacman -Qi meld
Name : meld
Version : 3.22.0-2.0
Description : Compare files, directories and working copies
Architecture : any
URL : https://meldmerge.org/ Licenses : GPL Groups : None
Provides : None
Depends On : python-gobject python-cairo gtksourceview4 gsettings-desktop-schemas dconf
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 5.06 MiB
Packager : TasosSah arch32@tasossah.com Build Date : Sat 19 Aug 2023 23:25:57 BST
Install Date : Sat 26 Aug 2023 07:08:59 BST
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

[keith@Arch32 ~]$ pacman -Qi gtksourceview4
Name : gtksourceview4
Version : 4.8.4-1.0
Description : A text widget adding syntax highlighting and more to GNOME
Architecture : pentium4
URL : https://wiki.gnome.org/Projects/GtkSourceView Licenses : GPL Groups : None
Provides : libgtksourceview-4.so=0-32
Depends On : gtk3 libxml2
Optional Deps : None
Required By : meld xed
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 7.44 MiB
Packager : Andreas Baumann mail@andreasbaumann.cc Build Date : Mon 07 Nov 2022 11:50:56 GMT
Install Date : Mon 28 Nov 2022 11:49:04 GMT
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

[keith@Arch32 ~]$ pacman -Qi gtk3
Name : gtk3
Version : 1:3.24.37-1.0
Description : GObject-based multi-platform GUI toolkit
Architecture : pentium4
URL : https://www.gtk.org/ Licenses : LGPL Groups : None
Provides : gtk3-print-backends libgailutil-3.so=0-32 libgdk-3.so=0-32 libgtk-3.so=0-32
Depends On : adwaita-icon-theme atk cairo cantarell-fonts dconf desktop-file-utils fontconfig fribidi gdk-pixbuf2 glib2 harfbuzz iso-codes

                libcloudproviders  libcolord  libcups  libegl  libepoxy  libgl  librsvg  libxcomposite  libx11  libxcursor  libxdamage  libxext  libxfixes
                libxi  libxinerama  libxkbcommon  libxrandr  libxrender  pango  shared-mime-info  wayland  at-spi2-core  tracker3  gtk-update-icon-cache

Optional Deps : evince: Default print preview command
Required By : bleachbit engrampa firefox gcr gpicview gspell gtkmm3 gtksourceview4 libdbusmenu-gtk3 libgnomekbd libindicator-gtk3 libnma

                libpeas  lightdm-gtk-greeter  lxmusic  vte3  xdg-user-dirs-gtk

Optional For : avahi gvfs libcanberra libdecor libreoffice-still
Conflicts With : gtk3-print-backends
Replaces : gtk3-print-backends⇐3.22.26-1
Installed Size : 49.88 MiB
Packager : Andreas Baumann mail@andreasbaumann.cc Build Date : Sun 16 Apr 2023 11:18:09 BST
Install Date : Tue 25 Apr 2023 13:06:04 BST
Install Reason : Installed as a dependency for another package
Install Script : Yes
Validated By : Signature

[keith@Arch32 ~]$

342PackagesBug ReportVery LowVery Lownmap missing dependency openssl-1.1Unconfirmed
0%
Task Description

no task description

Showing tasks 51 - 74 of 74 Page 2 of 2 - 1 - 2

Available keyboard shortcuts

Tasklist

Task Details

Task Editing