Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategoryTask TypePriority  descSeveritySummaryStatusProgress
344PackagesBug ReportVery LowMedium[linux] No kernel updatesUnconfirmed
0%
Task Description

The linux kernel seems to be stuck at version 6.1.12.arch1-1.0. The build log of the latest stable kernel (linux-6.6.4.arch1-1.0) shows the following error:

=⇒ ERROR: Integrity checks (sha256) differ in size from the source array.
erich@rechenknecht

343PackagesBug ReportVery LowLowPackage 'screen 4.9.1-1.0' is missing dependency libute...Unconfirmed
0%
Task Description

Package ‘screen 4.9.1-1.0’ is missing dependency libutempter. I assume this is because libutempter used to be a dependency of util-linux which is part of base, so was assumed to be installed.

With the regular Arch Linux distro libutempter is still a dependency of util-linux.

342PackagesBug ReportVery LowVery Lownmap missing dependency openssl-1.1Unconfirmed
0%
Task Description

no task description

341PackagesBug ReportVery LowCriticalpython3 is version 11, but all packages install only 3....Unconfirmed
0%
Task Description

From a fresh install just now:

The /usr/lib/python3.10/site-packages folder is full of dozens of files, but there is little in the 3.11 folder. Some examples: gajim yt-dlp zippy samba.

This seems to affect most new packages that I install, so it is by no means limited to just the examples.

340PackagesBug ReportVery LowCritical[chromium] broken due to outdated libraries, plus also ...Unconfirmed
0%
Task Description

The package needs to be recompiled for re2 v10 and several required dependencies were not installed, such as icu69 (?) and more.

339PackagesBug ReportVery LowLow[libcanberra-pulse]: can not be installedUnconfirmed
0%
Task Description
# pacman -S libcanberra-pulse
resolving dependencies...
warning: cannot resolve "libcanberra=0.30+2+gc0620e4-3.2", a dependency of "libcanberra-pulse"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libcanberra-pulse

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcanberra=0.30+2+gc0620e4-3.2' required by libcanberra-pulse
338PackagesBug ReportVery LowLow[libreoffice-still]: error while loading shared librari...Unconfirmed
0%
Task Description

needs rebuild against latest ‘boost’

$ sudo pacman -Sy libreoffice-still

$ pacman -Qs libreoffice-still
local/libreoffice-still 7.3.7-2.0
    LibreOffice maintenance branch

$ lowriter
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_locale.so.1.80.0: cannot open shared object file: No such file or directory
336PackagesBug ReportVery LowLow[pyqt-builder]: needs rebuildUnconfirmed
0%
Task Description

just wanted to get this one on the board - i am unable to build ‘python-pyqt5’ which many other packages depend on, such as ‘qutebrowser’

the current ‘python-pyqt5’ PKGBUILD, which builds fine for x86_64 and arm, has unspecified dependencies in the i686 repos - not sure why that is

ModuleNotFoundError: No module named ‘jaraco.functools’
ModuleNotFoundError: No module named ‘jaraco.context’

that is easily fixed by requiring them explicitly:
> makedepends_i686=(’python-jaraco.context’ ‘python-jaraco.functools’)

however, after that, it gives a more fatal error:

sip-build: Unable to import ‘project.py’: No module named ‘pyqtbuild’

that module is in the ‘pyqt-builder’ package, i beleive - ‘pyqt-builder’ is installed as a build dependency; but it was built for python 3.9 - so probably that is why the build could not find the module

335PackagesBug ReportVery LowMediumpython-setuptools-scm 7.1.0-4.1 missing dependencyUnconfirmed
0%
Task Description

python-setuptools-scm 7.1.0-4.1 as found in the repo is missing the dependencies python-packaging and python-setuptools, which breaks the build of many other packages.

333PackagesBug ReportVery LowHighSddm 0.19.0-9.0 crashes with Qt 5.15.9Assigned
0%
Task Description

The current version of sddm (0.19.0-9.0) depends on the previous version of Qt (5.15.8). After updating Qt, sddm crashes with an incompatible Qt library error.

327PackagesBug ReportVery LowHigh[firefox-106.0.3.1.1-pentium4] crashes in VMware virtua...Unconfirmed
0%
Task Description

This is pentium4 related problem. Firefox crashes on startup with following messages:

ExceptionHandler::GenerateDump cloned child 814
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

Screenshot. Firefox folder after crash.

Temporary solution is to change in /etc/pacman/conf

Architecture=i686

, delete firefox for pentium4 from pacman cache and reinstall firefox

firefox-106.0.3.1.1-i686
325PackagesBug ReportVery LowHigh[terminus] crashes with message undefined symbol: cairo...Unconfirmed
0%
Task Description

Starting terminus gives following error:

from ._cairo import *  # noqa: F401,F403
ImportError: /usr/lib/python3.10/site-packages/cairo/_cairo.cpython-310-i386-linux-gnu.so: undefined symbol: cairo_tee_surface_index

Bug seens to be related to

https://bugs.archlinux.org/task/77367

There is generall mess on cairo related files for different architectures (pentium4, i486, i686) - some packages for one architecture are outdated, while for other archictectures are up to date, for instance:

  • python-cairo i486/extra : 1.21.0-1.0
  • python-cairo i686/extra : 1.23.0-3.0
  • python-cairo pentium4/extra : 1.23.0-3.0
322Packages: StableBug ReportVery LowMediumfile header absentNew
0%
Task Description

on fresh install file /usr/lib/libbfd.so lacks header “/* GNU ld script */” so I see complains on terminal

314PackagesBug ReportVery LowLowMumble requires a outdated protobuf Unconfirmed
0%
Task Description

libprotobuf=28 is a mumble (package) dependency, but protobuf package has libprotobuf=32.

I needed to downgrade to protobuf-3.17.3-1.3-pentium4.pkg.tar.zst (from the archive) to install mumble.

294PackagesBug ReportVery LowHigh[qtile] importlib.metadata.PackageNotFoundError: No pac...Assigned
0%
Task Description

When running qtile I get the following error message:

[qtile] importlib.metadata.PackageNotFoundError: No package metadata was found for qtile

Running qtile on Arch Linux works as expected.

$ qtile start
Traceback (most recent call last):
  File "/usr/bin/qtile", line 33, in <module>
    sys.exit(load_entry_point('qtile==0.18.1', 'console_scripts', 'qtile')())
  File "/usr/bin/qtile", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 957, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 548, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for qtile
$ pacman -Qi qtile
Name            : qtile
Version         : 0.18.1-3.0
Description     : A full-featured, pure-Python tiling window manager
Architecture    : pentium4
URL             : http://www.qtile.org
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : gdk-pixbuf2  glibc  libnotify  librsvg  pango  python-cairocffi  python-cffi  python-xcffib  python-gobject  python-setuptools
Optional Deps   : alsa-utils: for volume widget
                  canto-daemon: for canto widget
                  cmus: for cmus widget
                  jupyter_console: for interaction with qtile via Jupyter
                  khal: for khal_calendar widget
                  libpulse: for pulse_volume and pulseaudio_ffi widget [installed]
                  lm_sensors: for sensors widget [installed]
                  moc: for moc widget
                  python-dbus-next: for utils, notifications and several widgets
                  python-iwlib: for wlan widget
                  python-keyring: for imapwidget widget
                  python-mpd2: mpd2widget widget
                  python-psutil: graph, net and memory widget [installed]
                  python-pywlroots: for experimental wayland support
                  python-setproctitle: change process name to qtile
                  python-xdg: launchbar widget
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 3.25 MiB
Packager        : Andreas Baumann <mail@andreasbaumann.cc>
Build Date      : Mon 04 Oct 2021 12:02:58
Install Date    : Mon 26 Sep 2022 13:33:45
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature
$ sudo pacman -Syu
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
:: Starting full system upgrade...
 there is nothing to do
287PackagesFeature RequestVery LowLowchromium not able to buildAssigned
0%
Task Description

Wait unfortunately i found a patch through which chromium would compile on x86

please try to build chromium using those patches

https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/reenable-linux-i686-builds.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-i686-vaapi-fpermissive.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-105-bitmap-include.patch https://github.com/void-linux/void-packages/blob/master/srcpkgs/chromium/patches/chromium-105-browser-include.patch

283PackagesBug ReportVery LowLow[icu70/icu71 ] packages not rebuilt yetAssigned
0%
Task Description

starting to collect them here packages which require icu69 (and have thus not been rebuilt
for icu 71 yet):

libreoffice-fresh

243PackagesBug ReportVery LowMedium[linux and linux-zen] 5.16.12 needs a rebuild with gcc...New
0%
Task Description

[linux and linux-zen] 5.16.12 needs a rebuild with gcc 11.2 so DKMS packages will work

get errors when dkms installing in make log

cc1: error: incompatible gcc/plugin versions
cc1: error: failed to initialize plugin ./scripts/gcc-plugins/structleak_plugin.so

210PackagesBug ReportVery LowMediumkeymap don't gets fixed on login as set in /etc/vconsol...Unconfirmed
0%
Task Description

gzip comes with asm code, if enabled, built a TEXTREL which gets bloqued on boot, so systemd don’t set keymap
A lot of tricks in forums, old thread more complete here $506 An old problem. Work around while asm gets fixed is call configure with DEFS=”NO_ASM” like this:

...
export DEFS="NO_ASM"
./configure ....

or,

./configure DEFS="NO_ASM" ....

I have not tested it, but gentoo on x32 have gzip like this and no TEXTRELS here.
No matter i486, i686 or pentium.

Hope it helps.

Best regards.

209PackagesBug ReportVery LowLowIntel High Definition Audio issue.Unconfirmed
0%
Task Description

I am using Arch Linux 32 latest version on Sony VAIO VGN-FS215Z . The following is the audio device:

-fs215z:~$ lspci | grep -i audio

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)

When I boot the system after some time getting crackling sound in speaker. Sometimes it stops after few minutes and sometimes continue to sound. Really annoying. I am not getting the normal audio in any application. This problem was there in debian based OSs also but not there in any other OS.

Please help.

172PackagesBug ReportVery LowMediumiwd requires some kernel flagsUnconfirmed
0%
Task Description

RC4 support not found
The following options are missing in the kernel:

CONFIG_CRYPTO_USER_API_SKCIPHER
CONFIG_CRYPTO_ECB
CONFIG_CRYPTO_ARC4
117PackagesBug ReportVery LowLowvboxdrive module missingNew
0%
Task Description

vboxdrv module is missing making virtualbox unusable.

I’m currently running kernel 5.9.0-1.0-pae but it doesn’t seem to be there in any version

108Packages: StagingBug ReportVery LowHighlldb fails to run any binary (error: failed to launch o...Unconfirmed
0%
Task Description

Very easy to reproduce. lldb version 10.0.0, just try to run any binary.

[aeden@arch32 bin]$ lldb $(which date)
(lldb) target create “/usr/bin/date” Current executable set to ‘/usr/bin/date’ (i386).
(lldb) run
error: failed to launch or debug process
(lldb)

100Packages: StableBug ReportVery LowLowmldonkey crashesUnconfirmed
0%
Task Description

All versions of mldonkey crash in arch32 updated. (segmentation fault and core dumped)

Showing tasks 51 - 74 of 74 Page 2 of 2 - 1 - 2

Available keyboard shortcuts

Tasklist

Task Details

Task Editing