Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategory  descTask TypePrioritySeveritySummaryStatusProgress
336PackagesBug ReportVery LowLow[pyqt-builder]: needs rebuildUnconfirmed
0%
Task Description

just wanted to get this one on the board - i am unable to build ‘python-pyqt5’ which many other packages depend on, such as ‘qutebrowser’

the current ‘python-pyqt5’ PKGBUILD, which builds fine for x86_64 and arm, has unspecified dependencies in the i686 repos - not sure why that is

ModuleNotFoundError: No module named ‘jaraco.functools’
ModuleNotFoundError: No module named ‘jaraco.context’

that is easily fixed by requiring them explicitly:
> makedepends_i686=(’python-jaraco.context’ ‘python-jaraco.functools’)

however, after that, it gives a more fatal error:

sip-build: Unable to import ‘project.py’: No module named ‘pyqtbuild’

that module is in the ‘pyqt-builder’ package, i beleive - ‘pyqt-builder’ is installed as a build dependency; but it was built for python 3.9 - so probably that is why the build could not find the module

275PackagesBug ReportMediumLow[protobuf] breaks heavily on 32-bitNew
0%
Task Description

/build/protobuf/src/protobuf-21.2/src/google/protobuf/repeated_field.h: In instantiation of ‘constexpr int google::protobuf::internal::RepeatedFieldLowerClampLimit() [with T = long long int; int kRepHeaderSize = 4]’:

/data/work/arch32/protobuf/src/protobuf-21.2/src/google/protobuf/repeated_field.h:81:27: note: the comparison reduces to ‘(8 ⇐ 4)’

326PackagesBug ReportMediumLow[php] needs a rebuildNew
0%
Task Description

httpd/conf/httpd.conf: Cannot load modules/libphp.so into server: libssl.so.1.1>

257PackagesBug ReportMediumLow[openjdk 11/17/18] fails to build almost in all version...New
0%
Task Description

no task description

245PackagesBug ReportMediumLow[opencv] Python stack smashingNew
0%
Task Description

– Found PythonInterp: /usr/bin/python3 (found suitable version “3.10.4”, minimum required is “3.2”)
– Found PythonLibs: /lib/libpython3.10.so (found suitable exact version “3.10.4”)
* stack smashing detected *: terminated

Building falls through, only in package() we see the errors then:

rm: cannot remove ‘/build/opencv/pkg/opencv/usr/lib/python3*’: No such file or directory
=⇒ ERROR: A failure occurred in package_opencv().

Happens on real i486, not in staging-i486-build, making it even more annoying.

This blocks gstreamer with the opencv plugin..

280PackagesBug ReportMediumLow[mesa] and [mesa-amber] fail on DRI-2 on i486New
0%
Task Description

Most likely DRI-2 has been removed, rendering a whole bunch of old cards useless.

344PackagesBug ReportVery LowMedium[linux] No kernel updatesUnconfirmed
0%
Task Description

The linux kernel seems to be stuck at version 6.1.12.arch1-1.0. The build log of the latest stable kernel (linux-6.6.4.arch1-1.0) shows the following error:

=⇒ ERROR: Integrity checks (sha256) differ in size from the source array.
erich@rechenknecht

243PackagesBug ReportVery LowMedium[linux and linux-zen] 5.16.12 needs a rebuild with gcc...New
0%
Task Description

[linux and linux-zen] 5.16.12 needs a rebuild with gcc 11.2 so DKMS packages will work

get errors when dkms installing in make log

cc1: error: incompatible gcc/plugin versions
cc1: error: failed to initialize plugin ./scripts/gcc-plugins/structleak_plugin.so

338PackagesBug ReportVery LowLow[libreoffice-still]: error while loading shared librari...Unconfirmed
0%
Task Description

needs rebuild against latest ‘boost’

$ sudo pacman -Sy libreoffice-still

$ pacman -Qs libreoffice-still
local/libreoffice-still 7.3.7-2.0
    LibreOffice maintenance branch

$ lowriter
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_locale.so.1.80.0: cannot open shared object file: No such file or directory
254PackagesBug ReportMediumLow[libinput/libadwaita/gtk4/tracker3] on i486 failNew
0%
Task Description
/usr/bin/ld: warning: libicuuc.so.69, needed by /usr/lib/libtracker-sparql-3.0.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libicui18n.so.69, needed by /usr/lib/libtracker-sparql-3.0.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: /usr/lib/libtracker-sparql-3.0.so: undefined reference to `unorm2_getNFKCInstance_69'
/usr/bin/ld: /usr/lib/libtracker-sparql-3.0.so: undefined reference to `u_strToLower_69'
/usr/bin/ld: /usr/lib/libtracker-sparql-3.0.so: undefined reference to `ubrk_first_69'

tracker3 is not rebuilding on i486:

tracker/docs/reference/libtracker-sparql/meson.build:78:7: ERROR: Unknown variable "tracker_sparql_gir".
231PackagesBug ReportMediumLow[libffi] packages needing a rebuildNew
0%
Task Description
'pypy_plugin.so' -> '/build/uwsgi/pkg/uwsgi-plugin-pypy/usr/lib/uwsgi/pypy_plugin.so'
install: creating directory '/build/uwsgi/pkg/uwsgi-plugin-pypy/opt'
install: creating directory '/build/uwsgi/pkg/uwsgi-plugin-pypy/opt/pypy'
install: creating directory '/build/uwsgi/pkg/uwsgi-plugin-pypy/opt/pypy/site-packages'
'uwsgidecorators.py' -> '/build/uwsgi/pkg/uwsgi-plugin-pypy/opt/pypy/site-packages/uwsgidecorators.py'
pypy: error while loading shared libraries: libffi.so.6: cannot open shared object file: No such file or directory
339PackagesBug ReportVery LowLow[libcanberra-pulse]: can not be installedUnconfirmed
0%
Task Description
# pacman -S libcanberra-pulse
resolving dependencies...
warning: cannot resolve "libcanberra=0.30+2+gc0620e4-3.2", a dependency of "libcanberra-pulse"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libcanberra-pulse

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcanberra=0.30+2+gc0620e4-3.2' required by libcanberra-pulse
319PackagesBug ReportMediumLow[js102] rebuild results in a broken JS interpreter outp...New
0%
Task Description
 2:33.16 1 warning generated.
 2:47.25     Finished release [optimized] target(s) in 2m 24s
 3:50.23 js/src/build/libjs_static.a
 3:50.23 js/src/build/libmozjs-102.so
 3:51.27 js/src/gdb/gdb-tests
 3:51.27 js/src/shell/js
 3:51.33 js/src/jsapi-tests/jsapi-tests
 3:52.83 ./spidermonkey_checks.stub
 3:54.52 TEST-PASS | check_spidermonkey_style.py | ok
 3:54.79 TEST-PASS | check_macroassembler_style.py | ok
 3:54.84 TEST-PASS | check_js_opcode.py | ok
 3:55.04 7 compiler warnings present.
 3:55.09 Overall system resources - Wall time: 233s; CPU: 0%; Read bytes: 0; Write bytes: 0; Read time: 0; Write time: 0
 3:55.13 warning: intl/icu/source/i18n/nfsubs.cpp:1313:17 [-Wunused-but-set-variable] variable 'pow' set but not used
 3:55.13 warning: intl/icu/source/i18n/ucol.cpp:108:12 [-Wdeprecated-declarations] 'ucol_safeClone_71' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:101:20 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<int *, Failed>>' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:102:20 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<mozilla::Ok, Failed>>' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:103:20 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<mozilla::Ok, Foo8>>' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:104:20 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<Foo8, Foo16>>' is deprecated
 3:55.13 warning: mfbt/tests/TestResult.cpp:105:21 [-Wdeprecated-declarations] 'is_literal_type_v<mozilla::Result<mozilla::Ok, mozilla::UniquePtr<int>>>' is deprecated
 3:55.13 Your build was successful!
 Config object not found by mach.
Configure complete!
Be sure to run |mach build| to pick up any changes
To view resource usage of the build, run |mach resource-usage|.
To take your build for a test drive, run: |mach run|
Profiling instrumented JS...
/startdir/PKGBUILD: line 154:  6398 Segmentation fault      (core dumped) "$js" run.js
283PackagesBug ReportVery LowLow[icu70/icu71 ] packages not rebuilt yetAssigned
0%
Task Description

starting to collect them here packages which require icu69 (and have thus not been rebuilt
for icu 71 yet):

libreoffice-fresh

228PackagesBug ReportMediumLow[icu69] not updated packagesNew
0%
Task Description

starting to collect them here packages which require icu69 (and have thus not been rebuilt
for icu 70 yet):

- abiword: libical (rescheduled build)

313PackagesBug ReportMediumLow[hg] broken on i486New
0%
Task Description
Traceback (most recent call last):
  File "/usr/bin/hg", line 59, in <module>
    dispatch.run()
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 143, in run
    status = dispatch(req)
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 232, in dispatch
    status = _rundispatch(req)
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 276, in _rundispatch
    ret = _runcatch(req) or 0
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 451, in _runcatch
    return _callcatch(ui, _runcatchfunc)
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 461, in _callcatch
    return scmutil.callcatch(ui, func)
  File "/usr/lib/python3.10/site-packages/mercurial/scmutil.py", line 153, in callcatch
    return func()
  File "/usr/lib/python3.10/site-packages/mercurial/dispatch.py", line 441, in _runcatchfunc
    return _dispatch(req)

That’s why ‘nss’ is not rebuilding on i486.

321PackagesBug ReportMediumLow[gnome] brokenAssigned
0%
Task Description

mutter had a checksum issue (trivial).

gnome-shell misses a current version of gjs:

Dependency gjs-1.0 found: NO found 1.70.2 but need: '>= 1.73.1'
Did not find CMake 'cmake'
Found CMake: NO
Run-time dependency gjs-1.0 found: NO 

gnome-shell/meson.build:80:0: ERROR: Dependency lookup for gjs-1.0 with method 'pkgconfig' failed: Invalid version, need 'gjs-1.0' ['>= 1.73.1'] found '1.70.2'.

A full log can be found at /build/gnome-shell/src/build/meson-logs/meson-log.txt
345PackagesBug ReportVery LowLow[gcompris-qt] doesn't start due to Qt 5.15.10Unconfirmed
0%
Task Description

I fails to start with: “Cannot mix incompatible Qt library (5.15.9) with this library (5.15.10)”

311PackagesBug ReportMediumLow[ffmpeg] fails with SIGILL on i686Assigned
0%
Task Description

work fine on pentium4

reproducable: ffplay <file.mp4>

offending opcode:

 0xb5f315e7:  f3 0f 10 83 d0 0b 00 00 movss  
                  0xbd0(%ebx),%xmm0
252PackagesBug ReportMediumLow[dbus-python/python-dbus] mixupNew
0%
Task Description

packages (like upower) which include a dependency on python-dbus
use a 3.9 version and miss the correct one dbus-python (which
replaces python-dbus). This will only solve itself when upstream
adapts the PKGBUILDs to this name change.

340PackagesBug ReportVery LowCritical[chromium] broken due to outdated libraries, plus also ...Unconfirmed
0%
Task Description

The package needs to be recompiled for re2 v10 and several required dependencies were not installed, such as icu69 (?) and more.

320PackagesBug ReportMediumLow[btop] On i486 fails on clock_gettime64New
0%
Task Description

shows a red ERROR: on startup, strace shows:

write(2, "\n", 1
)                       = 1
clock_gettime64(CLOCK_REALTIME, {tv_sec=1675495215, tv_nsec=436798535}) = 0
exit_group(1)                           = ?
+++ exited with 1 +++
[root@eurobuild6-7-i486 ~]# btop
ERROR: No UTF-8 locale detected!
246PackagesBug ReportMediumLow[blender] doesn't work (and doesn't build)New
0%
Task Description

blender 2.93 has dependencies on wrong versions of
- llvm (via openshadinglanguage)
- boost (via openimageio)

Could NOT find PythonLibsUnix (missing: PYTHON_LIBRARY PYTHON_LIBPATH PYTHON_INCLUDE_DIR PYTHON_INCLUDE_CONFIG_DIR)’

blender 3.0.1:
Haru not found, disabling WITH_HARU’ and ‘Cycles OSL requires WITH_LLVM, the library may not have been found. Configure LLVM or disable WITH_CYCLES_OSL

Let’s tackle one issue after the other. :-)

141DevopsBug ReportMediumLowmake iso build more reliablyNew
0%
Task Description

Currently, the iso build are several bash scripts on several machines requiring to move stuff via sshfs and alike.

This should become more stable - ideally some single script/package/systemd-unit with proper error reporting (email or irc come to my mind)

176DevopsFeature RequestMediumLowbring back archiso32 dual bootNew
0%
Task Description

We should make archiso32 be able to build a i686- and x86_64-bootable iso, again. This is really handy on a usb stick as a rescue system.

The problem with the old dual iso is, that I had to do the i686 iso from scratch, because upstream changed from build.sh to putting everything into mkarchiso. Now, everything is steered from a profile file.

So either, we find a way to make a profile for multiple architectures, or we need to patch mkarchiso to do that for us - and maybe upstream these changes.

Showing tasks 51 - 75 of 75 Page 2 of 2 - 1 - 2

Available keyboard shortcuts

Tasklist

Task Details

Task Editing