Bugs in Archlinux32 packages, specific to 32-bit issues.

Bugs  FS#2  to  FS#92  have been recovered and may be incomplete, the
recovered Google/Bing cache data can be found here.

IDCategoryTask TypePrioritySeveritySummaryStatus  descProgress
322Packages: StableBug ReportVery LowMediumfile header absentNew
0%
Task Description

on fresh install file /usr/lib/libbfd.so lacks header “/* GNU ld script */” so I see complains on terminal

342PackagesBug ReportVery LowVery Lownmap missing dependency openssl-1.1Unconfirmed
0%
Task Description

no task description

100Packages: StableBug ReportVery LowLowmldonkey crashesUnconfirmed
0%
Task Description

All versions of mldonkey crash in arch32 updated. (segmentation fault and core dumped)

209PackagesBug ReportVery LowLowIntel High Definition Audio issue.Unconfirmed
0%
Task Description

I am using Arch Linux 32 latest version on Sony VAIO VGN-FS215Z . The following is the audio device:

-fs215z:~$ lspci | grep -i audio

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)

When I boot the system after some time getting crackling sound in speaker. Sometimes it stops after few minutes and sometimes continue to sound. Really annoying. I am not getting the normal audio in any application. This problem was there in debian based OSs also but not there in any other OS.

Please help.

314PackagesBug ReportVery LowLowMumble requires a outdated protobuf Unconfirmed
0%
Task Description

libprotobuf=28 is a mumble (package) dependency, but protobuf package has libprotobuf=32.

I needed to downgrade to protobuf-3.17.3-1.3-pentium4.pkg.tar.zst (from the archive) to install mumble.

330PackagesBug ReportVery LowLow[gcompris-qt] no game iconsUnconfirmed
0%
Task Description

gcompris-qt 3.0-1.0 is missing a dependency on llvm14 (or maybe it needs a rebuild for llvm) and thus it doesn’t show any game in the menu.

334PackagesBug ReportVery LowLowCalibre is out of date and will not startUnconfirmed
0%
Task Description

The latest version of calibre is 6.16.

The version in the repositories is 6.11.0-1.0 and unfortunately will no longer start.

[keith@Arch32 ~]$ calibre
Failed to import PyQt module: PyQt6.QtNetwork with error: /usr/lib/python3.10/site-packages/PyQt6/QtNetwork.abi3.so: undefined symbol: _ZN16QNetworkDatagram7destroyEP23QNetworkDatagramPrivate, version Qt_6
Traceback (most recent call last):
  File "/usr/bin/calibre", line 21, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 72, in calibre
    from calibre.gui2.main import main
  File "/usr/lib/calibre/calibre/gui2/__init__.py", line 13, in <module>
    from qt.core import (
ImportError: cannot import name 'QNetworkProxyFactory' from 'qt.core' (/usr/lib/calibre/qt/core.py)
[keith@Arch32 ~]$ pacman -Qi calibre
Name            : calibre
Version         : 6.11.0-1.0
Description     : Ebook management application
Architecture    : pentium4
URL             : https://calibre-ebook.com
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : hunspell  hyphen  icu  jxrlib  libmtp  libstemmer  libusb  libwmf  mathjax  mtdev  optipng  podofo
                  python-apsw  python-beautifulsoup4  python-cchardet  python-css-parser  python-cssselect  python-dateutil
                  python-dnspython  python-feedparser  python-html2text  python-html5-parser  python-jeepney  python-lxml
                  python-markdown  python-mechanize  python-msgpack  python-netifaces  python-pdftotext  python-pillow
                  python-psutil  python-py7zr  python-pychm  python-pycryptodome  python-pygments  python-pyqt6
                  python-pyqt6-webengine  python-regex  python-unrardll  python-zeroconf  qt6-imageformats  qt6-svg
                  qt6-webengine  ttf-liberation  uchardet  udisks2
Optional Deps   : poppler: required for converting pdf to html [installed]
                  speech-dispatcher: TTS support in the viewer
Required By     : None
Optional For    : None
Conflicts With  : calibre-common  calibre-python3
Replaces        : calibre-common  calibre-python3
Installed Size  : 91.69 MiB
Packager        : Andreas Baumann <mail@andreasbaumann.cc>
Build Date      : Thu 12 Jan 2023 05:31:50 GMT
Install Date    : Tue 24 Jan 2023 10:15:48 GMT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

[keith@Arch32 ~]$ 
336PackagesBug ReportVery LowLow[pyqt-builder]: needs rebuildUnconfirmed
0%
Task Description

just wanted to get this one on the board - i am unable to build ‘python-pyqt5’ which many other packages depend on, such as ‘qutebrowser’

the current ‘python-pyqt5’ PKGBUILD, which builds fine for x86_64 and arm, has unspecified dependencies in the i686 repos - not sure why that is

ModuleNotFoundError: No module named ‘jaraco.functools’
ModuleNotFoundError: No module named ‘jaraco.context’

that is easily fixed by requiring them explicitly:
> makedepends_i686=(’python-jaraco.context’ ‘python-jaraco.functools’)

however, after that, it gives a more fatal error:

sip-build: Unable to import ‘project.py’: No module named ‘pyqtbuild’

that module is in the ‘pyqt-builder’ package, i beleive - ‘pyqt-builder’ is installed as a build dependency; but it was built for python 3.9 - so probably that is why the build could not find the module

338PackagesBug ReportVery LowLow[libreoffice-still]: error while loading shared librari...Unconfirmed
0%
Task Description

needs rebuild against latest ‘boost’

$ sudo pacman -Sy libreoffice-still

$ pacman -Qs libreoffice-still
local/libreoffice-still 7.3.7-2.0
    LibreOffice maintenance branch

$ lowriter
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_locale.so.1.80.0: cannot open shared object file: No such file or directory
339PackagesBug ReportVery LowLow[libcanberra-pulse]: can not be installedUnconfirmed
0%
Task Description
# pacman -S libcanberra-pulse
resolving dependencies...
warning: cannot resolve "libcanberra=0.30+2+gc0620e4-3.2", a dependency of "libcanberra-pulse"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libcanberra-pulse

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcanberra=0.30+2+gc0620e4-3.2' required by libcanberra-pulse
172PackagesBug ReportVery LowMediumiwd requires some kernel flagsUnconfirmed
0%
Task Description

RC4 support not found
The following options are missing in the kernel:

CONFIG_CRYPTO_USER_API_SKCIPHER
CONFIG_CRYPTO_ECB
CONFIG_CRYPTO_ARC4
210PackagesBug ReportVery LowMediumkeymap don't gets fixed on login as set in /etc/vconsol...Unconfirmed
0%
Task Description

gzip comes with asm code, if enabled, built a TEXTREL which gets bloqued on boot, so systemd don’t set keymap
A lot of tricks in forums, old thread more complete here $506 An old problem. Work around while asm gets fixed is call configure with DEFS=”NO_ASM” like this:

...
export DEFS="NO_ASM"
./configure ....

or,

./configure DEFS="NO_ASM" ....

I have not tested it, but gentoo on x32 have gzip like this and no TEXTRELS here.
No matter i486, i686 or pentium.

Hope it helps.

Best regards.

335PackagesBug ReportVery LowMediumpython-setuptools-scm 7.1.0-4.1 missing dependencyUnconfirmed
0%
Task Description

python-setuptools-scm 7.1.0-4.1 as found in the repo is missing the dependencies python-packaging and python-setuptools, which breaks the build of many other packages.

108Packages: StagingBug ReportVery LowHighlldb fails to run any binary (error: failed to launch o...Unconfirmed
0%
Task Description

Very easy to reproduce. lldb version 10.0.0, just try to run any binary.

[aeden@arch32 bin]$ lldb $(which date)
(lldb) target create “/usr/bin/date” Current executable set to ‘/usr/bin/date’ (i386).
(lldb) run
error: failed to launch or debug process
(lldb)

325PackagesBug ReportVery LowHigh[terminus] crashes with message undefined symbol: cairo...Unconfirmed
0%
Task Description

Starting terminus gives following error:

from ._cairo import *  # noqa: F401,F403
ImportError: /usr/lib/python3.10/site-packages/cairo/_cairo.cpython-310-i386-linux-gnu.so: undefined symbol: cairo_tee_surface_index

Bug seens to be related to

https://bugs.archlinux.org/task/77367

There is generall mess on cairo related files for different architectures (pentium4, i486, i686) - some packages for one architecture are outdated, while for other archictectures are up to date, for instance:

  • python-cairo i486/extra : 1.21.0-1.0
  • python-cairo i686/extra : 1.23.0-3.0
  • python-cairo pentium4/extra : 1.23.0-3.0
327PackagesBug ReportVery LowHigh[firefox-106.0.3.1.1-pentium4] crashes in VMware virtua...Unconfirmed
0%
Task Description

This is pentium4 related problem. Firefox crashes on startup with following messages:

ExceptionHandler::GenerateDump cloned child 814
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

Screenshot. Firefox folder after crash.

Temporary solution is to change in /etc/pacman/conf

Architecture=i686

, delete firefox for pentium4 from pacman cache and reinstall firefox

firefox-106.0.3.1.1-i686
340PackagesBug ReportVery LowCritical[chromium] broken due to outdated libraries, plus also ...Unconfirmed
0%
Task Description

The package needs to be recompiled for re2 v10 and several required dependencies were not installed, such as icu69 (?) and more.

341PackagesBug ReportVery LowCriticalpython3 is version 11, but all packages install only 3....Unconfirmed
0%
Task Description

From a fresh install just now:

The /usr/lib/python3.10/site-packages folder is full of dozens of files, but there is little in the 3.11 folder. Some examples: gajim yt-dlp zippy samba.

This seems to affect most new packages that I install, so it is by no means limited to just the examples.

Showing tasks 51 - 68 of 68 Page 2 of 2 - 1 - 2

Available keyboard shortcuts

Tasklist

Task Details

Task Editing