IDCategoryTask TypePrioritySeveritySummaryStatusProgress
 241 PackagesBug ReportVery LowLow mpd probably needs to be rebuilt against pipewire Closed
Task Description


If I run mpd, it fails to run due to a missing PW_LOG_TOPIC_DEFAULT symbol:
> $ mpd
> mpd: symbol lookup error: mpd: undefined symbol: PW_LOG_TOPIC_DEFAULT

While I run Parabola, both mpd and pipewire comes from the i686 repository of Arch Linux 32:
> extra/mpd 0.23.5-1.2 [installed]
> Flexible, powerful, server-side application for playing music
> extra/pipewire 1:0.3.36-1.0 [installed]
> Low-latency audio/video router and processor

If I look on a x86_64 Parabola installation instead, PW_LOG_TOPIC_DEFAULT can be found in libpipewire:
> $ readelf -s /usr/lib/ | grep PW_LOG_
> 383: 00000000000d7128 8 OBJECT GLOBAL DEFAULT 21 > PW_LOG_TOPIC_DEFAULT

But that command returns nothing on Parabola i686.


 237 PackagesBug ReportVery LowLow i686: pango need to be rebuilt against harfbuzz Closed
Task Description


pango-list (and many packages depending on pango) fails to run with the following error:

$ pango-list 
pango-list: symbol lookup error: /usr/lib/ undefined symbol: hb_font_set_synthetic_slant

hb_font_set_synthetic_slant seems to be related to harfbuzz.

While I used Parabola i686 for the test, both pango and harfbuzz come from Arch Linux 32 i686, so Arch Linux 32 i686 should also be affected:

$ pacman -Q -o pango-list 
/usr/bin/pango-list is owned by pango 1:1.50.4-1.0
$ pacman -sS "^pango$"
extra/pango 1:1.50.4-1.0 [installed]
    A library for layout and rendering of text
$ pacman -sS "^harfbuzz$"
extra/harfbuzz 3.1.2-1.0 [installed]
    OpenType text shaping engine


 226 PackagesBug ReportVery LowLow claws-mail needs to be recompiled on i686 Closed
Task Description

On i686, with testing and without testing claws mail is broken:
$ claws-mail
claws-mail: error while loading shared libraries: cannot open shared object file: No such file or directory

While I run Parabola i686, the repositories being used come from Archlinux 32:
$ pacman -sS claws-mail
extra/claws-mail 4.0.0-2.0 [installed]

  A GTK+ based e-mail client

$ pacman -Q -o /usr/lib/liblber*
/usr/lib/ is owned by libldap 2.6.0-2.4
/usr/lib/ is owned by libldap 2.6.0-2.4
/usr/lib/ is owned by libldap 2.6.0-2.4
$ pacman -sS libldap
core/libldap 2.6.0-2.4 [installed]

  Lightweight Directory Access Protocol (LDAP) client libraries

$ pacman -Q -l libldap | grep /usr/lib/liblber
libldap /usr/lib/
libldap /usr/lib/
libldap /usr/lib/

So it’s most probably broken on Arch Linux 32 as well.


Showing tasks 1 - 3 of 3 Page 1 of 1

Available keyboard shortcuts


Task Details

Task Editing