• Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages → Stable
  • Assigned To
    Erich Eckner
  • Operating System pentium4
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Arch Linux 32
Opened by Rodney Rod - 18.11.2019
Last edited by Erich Eckner - 11.12.2019

FS#93 - pyparsing error is preventing applications from starting

Came across this after completing a system update two days ago.

I run Radicale and that is refusing to start with the following error:

Traceback (most recent call last):
  File "/usr/bin/radicale", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 84, in <module>
    __import__('packaging.requirements')
  File "/usr/lib/python3.7/site-packages/packaging/requirements.py", line 9, in <module>
    from pyparsing import stringStart, stringEnd, originalTextFor, ParseException
ModuleNotFoundError: No module named 'pyparsing'

When attempting to run pip to see if that might correct the issue, I got the following error:

Traceback (most recent call last):
  File "/usr/bin/pip", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 84, in <module>
    __import__('packaging.requirements')
  File "/usr/lib/python3.7/site-packages/packaging/requirements.py", line 9, in <module>
    from pyparsing import stringStart, stringEnd, originalTextFor, ParseException
ModuleNotFoundError: No module named 'pyparsing'

It looks as though something recently broke pyparsing and that’s had a knockon effect for a few packages.

Closed by  Erich Eckner
11.12.2019 04:55
Reason for closing:  Fixed
Additional comments about closing:  

python 3.8 is in stable now - *this* issue should be resolved, though there might be some python packages missing, still

Admin
Andreas Baumann commented on 18.11.2019 12:40

Confirmed, python-pyparse somehow made its way to stable though half of Python is still
rebuilding in staging.

levi commented on 18.11.2019 20:56

Indeed, pyparsing in stable targets python 3.8, but in stable python is still at version 3.7. Pyparsing from stable with python from testing is functional. Verification:

$ python
...
>>>import pyparsing
>>>exit()
$ python --version
Python 3.8.0
$ find /usr/lib/python3* -iname pyparsing\*
/usr/lib/python3.8/site-packages/pyparsing.py
/usr/lib/python3.8/site-packages/pyparsing-2.4.5-py3.8.egg-info
/usr/lib/python3.8/site-packages/__pycache__/pyparsing.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/__pycache__/pyparsing.cpython-38.pyc

On a stable only system at present I expect python –version to report 3.7.4, which won't match the files in /usr/lib.

Edit: A workaround, should it prove necessary is to roll back your version of python-pyparsing, using copies in /var/cache/pacman/pkg. But hopefully a fix for this can be provided relatively promptly.

Rodney Rod commented on 18.11.2019 21:47

Thanks, downgrading is a workaround and I've got my services back up, thanks all. Good to see that the problem causing this was figured out so quickly.

Admin
Erich Eckner commented on 21.11.2019 08:14

I'll look, how this had happened. Though, I will not put the old python-pyparsing into stable - in case, someone stumbles over this and does not have the package in his cache, one can download old versions of the package at the package archive

Admin
Erich Eckner commented on 21.11.2019 10:23

ok, I found and fixed the bug.
The problem was, that db-update did not check the version of the dependencies - so this could have happened to any package which did not pull in other dependencies carrying the version directly in the name (like libraries and symbols)

levi commented on 25.11.2019 01:21

This also seems to affect anything using xcb-proto which contains a python library in its distribution, for what it's worth.

I personally have that installed as a dependency from ffmpeg ultimately. I don't know under what situations ffmpeg actually uses that python code if at all though. It certainly starts up even if I've moved the python code out of the way.

Admin
Andreas Baumann commented on 25.11.2019 17:40

Downgrade to python-pyparsing 2.4.4-1.0.

levi commented on 25.11.2019 22:26

And also downgrade xcb-proto to version 1.13-2.1, if you're getting any python errors about xcbgen.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing