• Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Packages → Packages: Stable
  • Assigned To No-one
  • Operating System i686
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Archlinux32
Opened by bill auger - 08.04.2019

FS#65 - [qt5-styleplugins] incompatile QT version

i can not get any QT program to start while that is installed - they complain about mixed QT versions

it looks like qt5-styleplugins was built with the [testing] repo enabled, with qt5-base-5.12.2, while other QT-base programs were built against qt5-base-5.12.1

bill auger commented on 08.04.2019 16:47
$ qv4l2 
Cannot mix incompatible Qt library (version 0x50c02) with this library (version 0x50c01)
Aborted (core dumped)
$ sudo octopi
Cannot mix incompatible Qt library (version 0x50c02) with this library (version 0x50c01)
Aborted
$ sudo calamares 
Cannot mix incompatible Qt library (version 0x50c02) with this library (version 0x50c01)
Aborted
$ sudo qtox      
[16:43:22.069 UTC] :0 : Fatal: Cannot mix incompatible Qt library (version 0x50c02) with this library (version 0x50c01)
Aborted
Admin
Erich Eckner commented on 08.04.2019 19:36

where does qt see this versions?
The symbols in e.g. usr/lib/libQt5-Widgets.so.5.* do not have the least version part:

14 0x02 0x08a28110 Qt_5.10

      Qt_5.9 

15 0x02 0x08a28111 Qt_5.11

      Qt_5.10 

16 0x00 0x08a28112 Qt_5.12

      Qt_5.11 
required from libQt5Core.so.5:
  0x08a28112 0x00 22 Qt_5.12
  0x00058a25 0x00 03 Qt_5
required from libQt5Widgets.so.5:
  0x00058a25 0x00 02 Qt_5

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing