• Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages → Packages: Stable
  • Assigned To No-one
  • Operating System i686
  • Severity Low
  • Priority Medium
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Archlinux32
Opened by Andreas Baumann - 10.01.2019
Last edited by Andreas Baumann - 10.01.2019

FS#59 - unison segfault

Calling unison, a file synchronizer written in Ocaml. Segfaults.
Most likely a string optimization inside Ocaml itself or a non-matching
library somewhere (recompile ocaml?)

(gdb) bt
#0  0x006782df in caml_string_equal ()
#1  0x005ce0d8 in camlUpdate__archiveMode_802888 ()
#2  0x005ce6e5 in camlUpdate__setArchiveData_802926 ()
#3  0x005da668 in camlGlobals__fun_802549 ()
#4  0x005fed99 in camlLwt_util__map_1080 ()
#5  0x005fedac in camlLwt_util__map_1080 ()
#6  0x005da5b9 in camlGlobals__allRootsMap_301891 ()
#7  0x005cea7f in camlUpdate__loadArchives_802958 ()
#8  0x005d4637 in camlUpdate__findUpdatesOnPaths_2603478 ()
#9  0x005b36f5 in camlUitext__synchronizeOnce_1102725 ()
#10 0x005b4041 in camlUitext__loop_1203129 ()
#11 0x005b41d6 in camlUitext__synchronizeUntilDone_1203134 ()
#12 0x005b442e in camlUitext__start_1303143 ()
#13 0x005acc54 in camlMain__Body_401249 ()
#14 0x005ac19d in camlLinktext__entry ()
#15 0x005a8220 in caml_program ()
#16 0x0068b64d in caml_start_program ()
#17 0x0068b9f1 in caml_startup_common ()
#18 0x0068ba6a in caml_startup ()
#19 0x005a7c25 in main ()
Closed by  Andreas Baumann
10.01.2019 14:15
Reason for closing:  Not a bug
Additional comments about closing:  

Cannot reprodduce but on a single machine. Might as well be something completly different..

Admin
Erich Eckner commented on 10.01.2019 08:31

easy trials first: let's recompile ocaml

Admin
Andreas Baumann commented on 10.01.2019 09:30

Some things seem to be wrong here:

Warning 3: deprecated: Stdlib.String.capitalize
Use String.capitalize_ascii instead.
File "/build/unison/src/unison-2.51.2/build/src/uigtk2.ml", line 1:
Error: /usr/lib/ocaml/lablgtk2/pango.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
make[1]: *** [Makefile.OCaml:423: uigtk2.cmx] Error 2
make[1]: Leaving directory '/build/unison/src/unison-2.51.2/build/src'
make: *** [Makefile:14: src] Error 2
Admin
Andreas Baumann commented on 10.01.2019 09:56

rebuilding lablgtk2 now.

Admin
Andreas Baumann commented on 10.01.2019 11:29

rebuilding unison didn't help.

Admin
Andreas Baumann commented on 10.01.2019 11:35

Ok, let's rebuild ocaml itself.

Admin
Andreas Baumann commented on 10.01.2019 12:51

works on two vms (libvirt and Virtualbox), but not on my real eeepc.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing