• Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages → Packages: Testing
  • Assigned To No-one
  • Operating System i686
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Archlinux32
Opened by Levi - 19.08.2018
Last edited by Erich Eckner - 24.09.2018

FS#48 - Testing repo missing a new version of python-six

I’ve become aware that python-six doesn’t identify that it depends specifically on python3.6 (it claims in the text that it’s for python 3 as well as python 2, which I don’t believe can be true; it only puts python files in /usr/lib/python3.6).

It has however allowed python 3.7 into the testing repo while no new version of python-six is available, and this version of python3 can no longer find a version of six when you import it.

As far as I know this is not an issue for anyone strictly on the release repos yet, and still won’t be an issue for anyone not using python-six either directly or indirectly.

Steps to reproduce

(upgrade at least python from the testing repos)
# python
# import six
> ...
> ModuleNotFoundError: No module named ‘six’

Steps to fix

A new version of python-six that supplies its files to python3.7/site-packages should be built and uploaded to the testing repos, and it should probably identify its dependent versions better.

I note arch64 has a newer python-six that supplies its libs to python3.7 just fine, although it also doesn’t identify its versions to my liking.

Closed by  Erich Eckner
24.09.2018 08:45
Reason for closing:  Fixed
Admin
Erich Eckner commented on 20.08.2018 04:26

python-six-1.11.0-3.0 in [staging] is made for python 3.7

The issue is known, (internally) documented and won't be fixed within the next weeks, but hopefully I have time to look into this after my holidays.

Levi commented on 27.08.2018 16:39

Thanks, I see this is available in the testing repo already, and I've just tested it. I don't seem to have rights to comment and close (or perhaps this bug needs to be further progressed before that become available, I dunno), but I've tried to reproduce this after upgrading, and it now works for me, so I can confirm that I consider this issue resolved and closed, unless you want to keep it open as a note that I don't think this has been pushed through the the mainline repos yet, while python 3.7 is there already.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing