• Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages → Packages: Build-list
  • Assigned To No-one
  • Operating System
  • Severity Low
  • Priority Medium
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Archlinux32
Opened by Andreas Baumann - 16.12.2017
Last edited by Erich Eckner - 17.12.2017

FS#22 - [firefox-developer-edition] build fails with out of memory when using rust

49:50.05 note: rustc 1.22.1 running on i686-unknown-linux-gnu
49:50.05 
49:50.05 note: run with `RUST_BACKTRACE=1` for a backtrace
49:50.05 
49:50.05 thread 'rustc' panicked at 'called `Result::unwrap()` on an `Err` value: Error { repr: Custom(Custom { kind: Other, error: StringError("Cannot allocate memory") }) }', src/libcore/result.rs:906:4
49:50.05 stack backtrace:
49:50.05    0: 0xf7caf5ea - rust_metadata_std_a60a98c24b539dcf2508f3d395979a97
49:50.05    1: 0xf7caa43e - rust_metadata_std_a60a98c24b539dcf2508f3d395979a97
49:50.05    2: 0xf7cbb31c - rust_metadata_std_a60a98c24b539dcf2508f3d395979a97
49:50.05    3: 0xf7cbb051 - rust_metadata_std_a60a98c24b539dcf2508f3d395979a97
49:50.05    4: 0xf7cbb82b - std::panicking::rust_panic_with_hook::h269fa2b74a2a0cee
49:50.05    5: 0xf7cbb6f6 - rust_metadata_std_a60a98c24b539dcf2508f3d395979a97
49:50.05    6: 0xf7cbb616 - std::panicking::begin_panic_fmt::hfe3f4b4d254fe489
49:50.05    7: 0xf7cbb57d - rust_begin_unwind
49:50.05    8: 0xf7d10dd6 - core::panicking::panic_fmt::h39c7136c9dc224e1
49:50.05    9: 0xf791f50a - rust_metadata_rustc_trans_73f1dcf221d7505426c13ccaa7d81bf3
49:50.05   10: 0xf79558dc - rust_metadata_rustc_trans_73f1dcf221d7505426c13ccaa7d81bf3
49:50.05   11: 0xf794f7e6 - rustc_trans::back::link::each_linked_rlib::h1e799094f6b686fb
49:50.05   12: 0xf794ff56 - rust_metadata_rustc_trans_73f1dcf221d7505426c13ccaa7d81bf3
49:50.05   13: 0xf794f19b - rustc_trans::back::link::link_binary::ha97335099e542ac0
49:50.06   14: 0xf79f455e - ::link_binary::h62e43ed882d32b44
49:50.06   15: 0xf7e686c5 - rustc_driver::driver::compile_input::hfa914359aa3118bb
49:50.06   16: 0xf7e82a2a - rustc_driver::run_compiler::hcd191a8815d2728b
49:50.06   17: 0xf7d9cc8f - rust_metadata_rustc_driver_e8ab70a79951e31413d2f7ce5f23c51c
49:50.06   18: 0xf7cc5542 - __rust_maybe_catch_panic
49:50.06   19: 0xf7dd6891 - 
49:50.06   20: 0xf7cba2db - rust_metadata_std_a60a98c24b539dcf2508f3d395979a97
49:50.06   21: 0xf622ee55 - start_thread
49:50.06   22: 0xf7b6dd05 - __clone
49:50.06   23:        0x0 - 
49:50.06 
49:50.23 error: Could not compile `gkrust`.
49:50.23 
49:50.23 To learn more, run the command again with --verbose.
49:50.24 make[4]: *** [/build/firefox-developer-edition/src/mozilla-unified/config/rules.mk:953: force-cargo-library-build] Error 101
49:50.24 make[3]: *** [/build/firefox-developer-edition/src/mozilla-unified/config/recurse.mk:73: toolkit/library/rust/target] Error 2
49:50.24 make[2]: *** [/build/firefox-developer-edition/src/mozilla-unified/config/recurse.mk:33: compile] Error 2
49:50.24 make[1]: *** [/build/firefox-developer-edition/src/mozilla-unified/config/rules.mk:432: default] Error 2
49:50.24 make: *** [client.mk:274: build] Error 2
49:50.28 635 compiler warnings present.
49:50.44 Notification center failed: Install notify-send (usually part of the libnotify package) to get a notification when the build finishes.
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Build failed, check /var/lib/archbuild/staging-with-build-support-i686/erich/build
Closed by  Erich Eckner
17.12.2017 19:10
Reason for closing:  Not a bug

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing