• Status Assigned
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System i686
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Arch Linux 32
Opened by Peter Tirsek - 09.01.2021
Last edited by Andreas Baumann - 16.01.2021

FS#121 - Multiple packages need rebuild after libicu upgrade

Over in  FS#119 , @abaumann mentioned that the libicu upgrade from 67 to 68 was part of what broke gdb. I missed the libicu upgrade when looking at gdb, but now that that one is resolved, I noticed a number of other packages that still link against the old and now nonexistant /usr/lib/libicu*.so.67 files. On my particular system, the following packages are installed, link to icu 67, and need rebuilt as well:

* harfbuzz-icu (2.7.0-1.0)
* mongo-c-driver (1.17.3-1.0)
* postfix (3.5.6-2.0)
* postgresql (12.4-1.0)
* postgresql-old-upgrade (12.5-1.0)
* samba (4.12.3-1.2)
* smbclient (4.12.3-1.2)
* syslog-ng (3.28.1-3.0)
* texlive-bin (2020.54586-4.0)
* xfsprogs (5.8.0-1.0)

… but I’m sure you have a way of determining all the affected packages?

As a workaround, in case others have the same problem, I manually extracted the old versioned .so files from the previous package to get things working again:

```
tar -C / -xf /var/cache/pacman/pkg/icu-67.1-1.0-i686.pkg.tar.zst –wildcards ‘usr/lib/lib*.so.*’ ```

- I’ll just have to remember to clean them up again later.

Peter Tirsek commented on 09.01.2021 03:20

(I wasn't quite sure if you'd prefer a new issue or the gdb one reopened, but since gdb actually got fixed, I opted for a new one).

Admin
Andreas Baumann commented on 10.01.2021 10:08

That's fine. I prefer news bugs being opened.. :-)

Admin
Andreas Baumann commented on 10.01.2021 13:05

I retriggered rebuilds. I also need my NAS back with Samba.. :-)

Admin
Andreas Baumann commented on 10.01.2021 13:38

Rebuilding samba fails in a Python issue:

ERROR: Use of system library ldb depends on missing system library/libraries ['pyldb-util.cpython-39-i386-linux-gnu']

apparently still not all Python modules made it from 3.8 to 3.9

Admin
Andreas Baumann commented on 10.01.2021 13:43

rebuilding samba requires updated ldb, which in turn requires tdb, talloc..
talloc has some source checksuming and pgp key issues..

Peter Tirsek commented on 10.01.2021 17:13

This is giving me horrible flashbacks of "emerge world" from my Gentoo days! ;-)

Admin
Andreas Baumann commented on 10.01.2021 19:51

The better workaround (as mentioned in the forums) is to temporarily install the icu67
package.

Admin
Andreas Baumann commented on 11.01.2021 13:14

Samba, smbclient and postfix are in stable. postfix in 486 not as it depends on
mariadb-libs SIMD-stuff. i686 and pentium4 are fine for postfix.

Admin
Andreas Baumann commented on 11.01.2021 14:51

xfsprogs and syslog-ng are also in stable.

Admin
Andreas Baumann commented on 13.01.2021 19:10

https://lists.archlinux.org/pipermail/arch-ports/2021-January/thread.html

I pushed facter and it's libraries leatherman (due to a boost conflict),
libwhereami, cpp-hocon and yaml-cpp to stable

Admin
Andreas Baumann commented on 14.01.2021 08:48

I seem not to be able to answer on the mailing list (nor receive mails, as a matter of fact). :-(

Admin
Andreas Baumann commented on 18.01.2021 10:08

Re-registration to the mailing list helped.. :-)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing