• Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages → Packages: Testing
  • Assigned To No-one
  • Operating System
  • Severity Low
  • Priority Medium
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Archlinux32
Opened by Andreas Baumann - 13.11.2017
Last edited by Andreas Baumann - 13.11.2017

FS#11 - [libmongoc] tries to overwrite /usr/lib/libsnappy.so

[quote]
pacman -S libmongoc
resolving dependencies...
looking for conflicting packages...

Packages (2) libbson-1.8.1-1 libmongoc-1.8.1-1

Total Installed Size: 1.23 MiB

:: Proceed with installation? [Y/n]
(2/2) checking keys in keyring [######################] 100%
(2/2) checking package integrity [######################] 100%
(2/2) loading package files [######################] 100%
(2/2) checking for file conflicts [######################] 100%
error: failed to commit transaction (conflicting files)
libmongoc: /usr/lib/libsnappy.so exists in filesystem
Errors occurred, no packages were upgraded.
[/quote]

libsnappy.so clearly belongs to the snappy package.

This doesn’t happen upstream with the same package.

Closed by  Andreas Baumann
13.11.2017 18:24
Reason for closing:  Not a bug
Additional comments about closing:  

..allow rebuild.closing.

Admin
Andreas Baumann commented on 13.11.2017 18:24

Just did a fresh rebuild and:

tar tvf libmongoc-1.8.1-2-i686.pkg.tar.xz |& grep snappy

doesn't show any snappy. Weird.

Ok. Closing the bug and hope a new build solves the issue.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing